You are Here:
Linux Lite 5.2 RC1 is now available for download and testing

[ SOLVED ] Software pgk compiled from source works but winds up in wrong direc. What to do?

Author (Read 993 times)

0 Members and 1 Guest are viewing this topic.



  • PayPal Supporter
  • Forum Regular
  • *****
  • 140
  • Country: 00
  • Reputation: 16
  • Enjoying Linux Lite.

  • Linux Lite: 3.4 64bit

  • CPU: Intel Quad Core 1.6GHz

  • MEMORY: 8Gb

  • VIDEO CARD: AMD Radeon
UPDATE - not an issue anymore as explained below.

I just now installed the latest version of a piece of software via source code. No, I did not WANT to do it that way, I only did it because I needed the latest version, but Synaptic only had an older version that was missing critical features. This is for my LL 4.0 machine FYI.

I followed exact instructions from the package about downloading latest version and compiling, it gave me the commands to use. Everything seemed to go fine - there was a make command, a make check, and sudo make install. All looked good, the make check command showed everything as PASS. As you can probably tell, I have never done anything like this and am a total newbie to compiling. Anyway, since it all looked good and because it showed up properly on the man pages, I wanted to run it. Here is the problem:

When I try to run the command, I get an error from bash indicating that the software is not found in usr/bin.

I tried the catfish finder to see where it got compiled into. It went into usr/local/bin. If I run the software by typing in usr/local/bin/..., then it works.

This sounds well and good, but I am wanting to invoke it in a script, and it's clunky to have to type in usr/local/bin.... etc every time I want to use the command.

What is the best way to deal with this? Any ideas?

UPDATE: I don't know why or how, but now everything works as expected. I logged out and in between times, so maybe that's the reason for it working properly. Who knows what happened or why, but anyway, it's all working. Feel free to delete this entire question if needed - I couldn't figure out how to delete it.
Last Edit: July 09, 2018, 01:03:01 PM by Vera
Using Linux Lite for everything now. I put it on my desktop and my laptop. Woohoo!



  • Forum Regular
  • ***
  • 237
  • Country: wales
  • Reputation: 40
  • Linux Lite Member
    • WKDfm Radio | WKDfm Chat

  • Linux Lite: 5.0 64bit

  • CPU: AMD Turion(tm) 64 x 2 Mobile Technology TL-60

  • MEMORY: 4Gb


  • Kernel: 5.x
 /usr/local/bin and /usr/bin should both be part of your $PATH so it should have worked straight away, but sometimes a reboot or logout is required for new software to be recognised.

Glad you managed to sort it
Owner and DJ at WKDfm Radio ( )


Linux Lite 5.2 RC1 is now available for download and testing