You are Here:
Linux Lite 4.4 Final has been released. See the Release Announcements section for more information.



gdebi is not working for me

Author (Read 418 times)

0 Members and 1 Guest are viewing this topic.

gdebi is not working for me
« on: January 01, 2019, 08:53:06 AM »
 

torreydale

  • PayPal Supporter
  • Platinum Level Poster
  • *****
  • 1422
    Posts
  • Country: us
  • Reputation: 229
  • * Forum Moderator *

  • Linux Lite: 4.4 64bit

  • CPU: Intel Core i5-5300U (-HT-MCP-)

  • MEMORY: 8Gb

  • VIDEO CARD: Intel Broadwell-U Integrated Graphics
I upgraded a laptop from LL 3.8 to LL 4.2 via a clean install of LL 4.2 two days ago.  I think I've counted about three .deb files I needed to install post LL 4.2 upgrade.  When I click on the .deb file, gdebi opens, and I click on Install.  The window disappears, and nothing happens.  I resort to installing the software using the command line with the "sudo dpkg -i" approach.  That does work.

I have used the reinstallation option in Install/Remove Software on the gdebi package to no avail.  Any suggestions?
Want to thank me?  Click my [Thank] link.
 


Re: gdebi is not working for me
« Reply #1 on: January 01, 2019, 09:29:35 AM »
 

trinidad

  • Gold Level Poster
  • *******
  • 921
    Posts
  • Country: us
  • Reputation: 164
  • Linux Lite Member
    • dbts-analytics.com

  • Linux Lite: 4.2 64bit

  • CPU: AMD A8 5500 4 cores

  • MEMORY: 8Gb

  • VIDEO CARD: AMD/ATI Radeon HD 7560D
run: sudo gdebi yourfilename.deb and see what errors if any the terminal throws. It's more than likely a GTK problem.
May be related to this bug: https://bugs.launchpad.net/ubuntu/+source/gdebi/+bug/1760910

TC
Last Edit: January 01, 2019, 09:42:08 AM by trinidad
"You can't depend on your eyes when your imagination is out of focus."
 

Re: gdebi is not working for me
« Reply #2 on: January 01, 2019, 10:55:34 AM »
 

torreydale

  • PayPal Supporter
  • Platinum Level Poster
  • *****
  • 1422
    Posts
  • Country: us
  • Reputation: 229
  • * Forum Moderator *

  • Linux Lite: 4.4 64bit

  • CPU: Intel Core i5-5300U (-HT-MCP-)

  • MEMORY: 8Gb

  • VIDEO CARD: Intel Broadwell-U Integrated Graphics

@trinidad ,


Thank you.  That link helped.  I had to make the following change to my gdebi.desktop file using the following:


I opened the file using the following command:
Code: [Select]
gksudo leafpad /usr/share/applications/gdebi.desktop

And I made the following change:


Change the following line:
Exec=gdebi-gtk %f


To this:
Exec=gksudo gdebi-gtk %f


I tested it on my google-chrome-stable_current_amd64.deb file.  Google Chrome was already installed, so I ran a Reinstallation, and things were better.  I saw things install instead of the window disappearing and nothing happening as before.
Want to thank me?  Click my [Thank] link.
 


Tags:
 


Linux Lite 4.4 Final has been released. See the Release Announcements section for more information.