You are Here:
Linux Lite 4.6 Final has been released. See the Release Announcements section for more information.



List of package sources corrupted after failed/erroneous installation of Brave

Author (Read 1038 times)

0 Members and 4 Guests are viewing this topic.

 

gretsgrets

  • New to Forums
  • *
  • 3
    Posts
  • Country: ph
  • Reputation: 0
  • Linux Lite Member

  • Linux Lite: 4.0 64bit
I tried to install Brave browser in my Linux desktop by following an online guide/article. I apparently did not correctly follow the instructions as I ended up corrupting my package sources. Now, I cannot update nor install any application. I cannot restore because I have not installed Timelight or similar ones.

Please, please help. Here is what the terminal says:

E: Malformed entry 2 in list file /etc/apt/sources.list.d/brave.list (Component)
E: The list of sources could not be read.
E: Malformed entry 2 in list file /etc/apt/sources.list.d/brave.list (Component)
E: The list of sources could not be read.
 


 

trinidad

  • Gold Level Poster
  • *******
  • 999
    Posts
  • Country: us
  • Reputation: 178
  • Linux Lite Member
    • dbts-analytics.com

  • Linux Lite: 4.4 64bit

  • CPU: AMD A8 5500 4 cores

  • MEMORY: 8Gb

  • VIDEO CARD: AMD/ATI Radeon HD 7560D
There are users here who use Brave. Did you enter the repo URL manually into the sources list file? Perhaps one of the users could post the list file for you and you could then correct yours to match. In the mean time you could post your list file  /etc/apt/sources.list.d/brave.list
Also near as I can tell you would probably need to run LL 3.8 as it has no Bionic release file I can find, though it may still work with 4.4 but not update.

TC
Last Edit: July 16, 2019, 09:23:46 AM by trinidad
All opinions expressed and all advice given by Trinidad Cruz on this forum are his responsibility alone and do not necessarily reflect the views or methods of the developers of Linux Lite. He is a citizen of the United States where it is acceptable to occasionally be uninformed and inept as long as you pay your taxes.
 

 

torreydale

  • PayPal Supporter
  • Platinum Level Poster
  • *****
  • 1482
    Posts
  • Country: us
  • Reputation: 242
  • * Forum Moderator *

  • Linux Lite: 4.6 64bit

  • CPU: Intel Core i5-5300U (-HT-MCP-)

  • MEMORY: 8Gb

  • VIDEO CARD: Intel Broadwell-U Integrated Graphics
I use Brave on Linux Lite 4.4 64 bit.  It is my main browser choice now.  I just copied and pasted the terminal installation instructions one at a time.  I do recall it creating a duplicate repository source.  I think it was a duplicate of the one used for Google Chrome.  I noticed it when I ran updates and I just had to remove the duplicate. 
Want to thank me?  Click my [Thank] link.
 


 


Linux Lite 4.6 Final has been released. See the Release Announcements section for more information.