You are Here:
Download Linux Lite 5.8 RC1 today - See Release Announcements



X Close Ad
X Close Ad
Error while updating

Author (Read 582 times)

0 Members and 4 Guests are viewing this topic.

Error while updating
« on: January 06, 2022, 10:05:35 PM »
 

jboscoe

  • New to Forums
  • *
  • 5
    Posts
  • Reputation: 0
 My name is Joe and i have been using linux for years but due tomy non tech savy i just broke my linux lite. I am getting an error when my linux tries to update.I have been using lite for a couple years now and like it overall. This happened after i installed the edge browser and now i am getting error of some sort the pub license for windows will not allow my os to update. i can paste the error here if thats ok.  And thanks in advance just in case i bricked the update feature.
============ Log ===========

Hit:1 http://us.archive.ubuntu.com/ubuntu focal InRelease
Hit:2 http://us.archive.ubuntu.com/ubuntu focal-updates InRelease
Hit:3 http://us.archive.ubuntu.com/ubuntu focal-backports InRelease
Hit:4 http://dl.google.com/linux/chrome/deb stable InRelease
Hit:5 http://repo.linuxliteos.com/linuxlite emerald InRelease
Hit:6 http://archive.canonical.com/ubuntu focal InRelease
Get:7 http://security.ubuntu.com/ubuntu focal-security InRelease [114 kB]
Get:8 https://packages.microsoft.com/repos/edge stable InRelease [7,342 B]
Err:8 https://packages.microsoft.com/repos/edge stable InRelease
  The following signatures couldn't be verified because the public key is not available: NO_PUBKEY EB3E94ADBE1229CF
Reading package lists...
W: GPG error: https://packages.microsoft.com/repos/edge stable InRelease: The following signatures couldn't be verified because the public key is not available: NO_PUBKEY EB3E94ADBE1229CF
E: The repository 'https://packages.microsoft.com/repos/edge stable InRelease' is not signed.
 

Re: Error while updating
« Reply #1 on: January 07, 2022, 09:36:46 AM »
 

trinidad

  • Platinum Level Poster
  • **********
  • 1325
    Posts
  • Reputation: 205
  • Linux Lite Member
    • dbts-analytics.com

  • Linux Lite: 5.6 64bit

  • CPU: AMD A8 5500 4 cores

  • MEMORY: 8Gb

  • VIDEO CARD: AMD/ATI Radeon HD 7560D

  • Kernel: 5.x
I think this is it though I use Edge DEV. Run the command below:
Code: [Select]
curl https://packages.microsoft.com/keys/microsoft.asc | sudo apt-key add TC

All opinions expressed and all advice given by Trinidad Cruz on this forum are his responsibility alone and do not necessarily reflect the views or methods of the developers of Linux Lite. He is a citizen of the United States where it is acceptable to occasionally be uninformed and inept as long as you pay your taxes.
 

Re: Error while updating
« Reply #2 on: January 08, 2022, 01:08:26 PM »
 

jboscoe

  • New to Forums
  • *
  • 5
    Posts
  • Reputation: 0
thank you for your reply i will try it as soon as i get rebooted. i was thinking i needed to wipe it all out and start over again.  once again thanks from joe
 

Re: Error while updating
« Reply #3 on: January 09, 2022, 08:03:36 AM »
 

jboscoe

  • New to Forums
  • *
  • 5
    Posts
  • Reputation: 0
I want to thank  you for your help but i tried your suggestion to no avail. The update still stalls with the error stated above for the edge browser.  Since i am not a guru i will thank you again.  I will miss  out on all my new updates but thanks.
 

Re: Error while updating
« Reply #4 on: January 09, 2022, 08:24:44 AM »
 

robert2019

  • New to Forums
  • *
  • 3
    Posts
  • Reputation: 0
  • Linux Lite Member

  • Linux Lite: 5.6 64bit

  • CPU: Dual core AMD C-70 APU with Radeon HD Graphics 1000 MHz

  • MEMORY: 4Gb

  • VIDEO CARD: Advanced Micro Devices [AMD/ATI] Wrestler [Radeon HD 7290]

  • Kernel: 5.x
Hi jboscoe,

I had the same issue. You can try with:

curl -sSL  https://packages.microsoft.com/keys/microsoft.asc | sudo apt-key add

You should get an OK message in your terminal. Once done, run the Install Updates again.

It worked for me.
 

Re: Error while updating
« Reply #5 on: January 10, 2022, 05:43:20 PM »
 

jboscoe

  • New to Forums
  • *
  • 5
    Posts
  • Reputation: 0
thank you for your suggestion and i will try it when i am back on that machine.  you all please take care and thanks   Joe
 

Re: Error while updating
« Reply #6 on: January 10, 2022, 08:37:41 PM »
 

jboscoe

  • New to Forums
  • *
  • 5
    Posts
  • Reputation: 0
 :003: Thank you robert2019  for your assistance. I hope to be  able to better understand how things work the more I work with them.
But until then I thank you and these forums to further my quest to not brake them.  Thank ever so much as it did the trick.  Sincerely Joe
 

Re: Error while updating
« Reply #7 on: January 12, 2022, 04:47:25 AM »
 

robert2019

  • New to Forums
  • *
  • 3
    Posts
  • Reputation: 0
  • Linux Lite Member

  • Linux Lite: 5.6 64bit

  • CPU: Dual core AMD C-70 APU with Radeon HD Graphics 1000 MHz

  • MEMORY: 4Gb

  • VIDEO CARD: Advanced Micro Devices [AMD/ATI] Wrestler [Radeon HD 7290]

  • Kernel: 5.x
You're welcome!
I would  like to understand more about the meaning of codes like these too, exactly what  instructions we are telling our machines to follow. Arriving to the Linux world in 2019 via Linux Lite, there is still almost all to learn.
Regarding this problem of the missing Public Key, for example, what  the difference is should  the code has or not the term "-sSL". This Microsoft Page suggests it should include it https://docs.microsoft.com/en-us/windows-server/administration/linux-package-repository-for-microsoft-software, reason I used it on my end trying to fix my MS Edge update issue.
The error message "gpg: can't open '-': No such file or directory" (with or without -sSL  instruction) gave me the idea to try with removing the "-" symbol from the end, and luckily it worked.  :)
Stay safe and have a good 2022.
 

 

X Close Ad
X Close Ad

Download Linux Lite 5.8 RC1 today - See Release Announcements