You are Here:
Linux Lite 5.0 Final is now available for download and installation



Error msg everytime i try to install new software

Author (Read 10815 times)

0 Members and 1 Guest are viewing this topic.

Error msg everytime i try to install new software
« on: August 06, 2014, 04:53:38 PM »
 

jwwin

  • Guest
Hey,

Error warning (when ever i've tried to download and install a software package that is compatible with my version of Linux Lite 2.0)
Only one software management tool is allowed to run at the same time !
Please close the other application first eg: update manager, aptitude, or synaptic first

What is going on - I'm getting frustrated with linux (also cant get my brand new supposedly compatible - printer to work) cant load drivers !

Please help i'm very close to going back to windows - linux is not very user friendly. Speaking as a former windows user. I mean I've read all over the web (pre-switching) that Linux was a great place to go to for former Windows users. REALLY ??    :(
Last Edit: August 07, 2014, 01:28:58 AM by Valtam
 


Re: ERROR MSG EVERYTIME I TRY TO INSTALL NEW SOFTWARE
« Reply #1 on: August 06, 2014, 07:12:02 PM »
 

gold_finger

  • Documentation Writer
  • Platinum Level Poster
  • *****
  • 1095
    Posts
  • Country: us
  • Reputation: 325
  • Linux Lite Member

  • Linux Lite: 3.2 64bit

  • CPU: Intel Core2 Duo E7500 3.0GHz

  • MEMORY: 4Gb

  • VIDEO CARD: Intel 4 Series Integrated Graphics
Calm down.  Take a deep breath.

Going to suggest you do a few things before posting again.

1.  Read this:  Linux is Not Windows

2.  Read the Help Manual that's included in Linux Lite (Menu -> Favorites -> Help Manual), or here:  https://www.linuxliteos.com/manual/.

3.  When making a post for support (quoted from the Help Manual):
Quote
When posting for support, make your title descriptive as possible. Within the post, specify details of the problem, describe the procedure you followed that led to it, steps you tried in order to resolve the issue, and any error messages you may have encountered at various stages in the process. Also include information on your computer - model number, approximate age, CPU, RAM, etc. (The Create System Report tool is good for that.) The more info you provide the easier it will be for people to evaluate the situation and offer appropriate guidance.


Linux Lite is one of the easier versions of Linux for beginners to use.  However, that doesn't mean you can turn it on and expect it to work just like Windows.  Some operations are similar to what you already know, others are very different.  No matter what version of Linux you use, there will be a learning curve because Linux is different than what you are used to in Windows.  I'm not trying to discourage you at all here.  I just want you to know that Linux will require its users to read and lookup information along the way.  How much of that you need to do depends on how you use the computer.  If you mainly use the computer for Internet surfing, listening to music, watching videos, making documents/spreadsheets, etc. -- you will get used to the differences pretty quickly and not need to spend much time researching how to do things.  After that point, it's completely up to you how deep into learning Linux you want to go.  Many people use it for years without ever needing to learn "command line" stuff.  Others like to tinker with things and take it upon themselves to learn more of the inner workings.

Have a read through the Help Manual.  I have a feeling that alone will answer not only the questions you're asking now, but several others you might have as someone brand new to Linux.  When your done with that, bookmark the following two pages in your browser:

Linux Basics:  Useful Beginner Information

http://shengchieh.50webs.com/tuxslinks.html  (Nice web page of user shengchieh here on the forum.)

There are links to a lot of good info in those pages that you can refer to at your leisure.


After reading the Help Manual, if you are still having problems installing something, post back with more details on exactly what you were trying to install and how you tried to do it.  There are multiple ways to install packages (programs).  Your error message indicates that you may have had more than one program that handles installing packages open at the same time.  The system won't allow that.  Only one install method can be operating at a time.

The Hardware section of the Help Manual shows how to setup printers.  Try following procedure outlined there.  If still have problems, make a support post with details about the printer you have and what you tried to get it working along with any error messages you may have gotten.  (Would be best to make that a separate support post in the "Printing and Scanning" section of the forum.)


P.s.  Welcome to the world of Linux!  And welcome to the LL forums!   :D
Last Edit: August 06, 2014, 07:20:19 PM by gold_finger
Try Linux Beginner Search Engine for answers to Linux questions.
 

Re: Error msg everytime i try to install new software
« Reply #2 on: August 07, 2014, 01:57:50 AM »
 

Jerry

  • Linux Lite Creator
  • Administrator
  • Platinum Level Poster
  • *****
  • 7646
    Posts
  • Country: nz
  • Reputation: 722
  • Linux Lite Member
    • Linux Lite OS

  • Linux Lite: 5.0 64bit

  • CPU: Intel Xeon Dual CPU's E5645 2.4GHz 12 Cores

  • MEMORY: 16Gb

  • VIDEO CARD: nVidia GeForce GTX 1650

  • Kernel: 5.x
Welcome jwwin. I know you're frustrated but like gold_finger said, step back take a deep breath and start again. We are here to help you. You've just gone from one type of operating system to another with similarities, but not identical. Like anything new you learn in life, whether it be a new job, or your first born there will be an initial shock to the system. Take small steps :)
 

Re: Error msg everytime i try to install new software
« Reply #3 on: August 08, 2014, 11:46:31 AM »
 

jwwin

  • Guest
Thanks for your reply,


I shall try to read through the several sources (Help manual etc..) Hopefully it will work. I'm very busy and don't know when I'm going to have time. That's another fact of life. Time - one never has enough of it. And quite frankly I don't need this right now - I've been gliding along - happy with Windows (all I use it for is to read emails - buy on-line - write an occasional document etc.   I'm not a computer geek and don't want to be one. This is Bill Gates and Microsoft's fault - abandoning its loyal customer base. But I should have known they've pulled  s@#t  like this before.   >:(  And yes I'm not happy but it's really at Microsoft so don't take it personally. 
 

Re: Error msg everytime i try to install new software
« Reply #4 on: August 09, 2014, 10:52:15 PM »
 

shengchieh

  • Forum Regular
  • ***
  • 155
    Posts
  • Reputation: 46
  • Linux Lite Member
    • Tux's Links
>  Please close the other application first eg: update manager, aptitude, or synaptic first

This is so that they don't mess each other up - one superiority of linux distros over window., linux distros favor reliability over "window" convenience.  That's why you see linux distros servers have uptime in term of years
instead of days.

Sheng-Chieh

p.s Linux is a kernel, not an OS (technically).  That's why I use linux distro.
 

Re: Error msg everytime i try to install new software
« Reply #5 on: August 24, 2014, 05:56:50 PM »
 

jwwin

  • Guest
Okay got the printer problem solved - Linux (and an other - canon or any other third party)had no drivers. So I simply found a printer that had drivers written to work with Linux (HP PRINTERS) and installed a new printer. But still no go with installing new software (even though the new software is compatible with my Distro. I get the same error message as above (original error message). This time I dowloaded "Heimdall"

You wanted specifics - well here you are :

Heimdall is a command line tool and part of Heimdall Suite; a cross-platform open-source tool suite used to flash firmware (aka ROMs) onto Samsung Galaxy S devices.
Heimdall is the core binary in Heimdall Suite and is utilised by other Heimdall Suite binaries, such as Heimdall Frontend (the official Heimdall graphical user interface). 

The "package installer" had loaded it up and was ready to install (no problem so far) - but as soon s I entered my Administrator  Password and it (Package Installer)  began installing "Heimdall"  I got the same annoying window pops up saying

 quote :  ONLY ONE SOFTWARE MANAGEMENT TOOL IDS ALLOWED TO RUN AT ONE TIME !!!!!   Please close the other application  eg:  "Update Manager" Synaptic", or aptitude first. End quote.

One I've read the manuals etc and still can't figure out how to fix this problem

Two  I have looked for "Update Manager" Synaptic", or aptitude"  and cannot locate them to turn them off.

Now thats as specific as I can get (oh yes it doesn't matter if its "Heimdall" or Thor or "Odin" (He's only for windows by the way- I think Bill Gates bought him off) I still get the same Warning. Please help if you can I'm rreally trying to stick with Linux. :P
 

Re: Error msg everytime i try to install new software
« Reply #6 on: August 24, 2014, 05:58:29 PM »
 

Jerry

  • Linux Lite Creator
  • Administrator
  • Platinum Level Poster
  • *****
  • 7646
    Posts
  • Country: nz
  • Reputation: 722
  • Linux Lite Member
    • Linux Lite OS

  • Linux Lite: 5.0 64bit

  • CPU: Intel Xeon Dual CPU's E5645 2.4GHz 12 Cores

  • MEMORY: 16Gb

  • VIDEO CARD: nVidia GeForce GTX 1650

  • Kernel: 5.x
Can you please post a screenshot of this issue in action (the entire screen)
 

Re: Error msg everytime i try to install new software
« Reply #7 on: August 24, 2014, 09:12:28 PM »
 

gold_finger

  • Documentation Writer
  • Platinum Level Poster
  • *****
  • 1095
    Posts
  • Country: us
  • Reputation: 325
  • Linux Lite Member

  • Linux Lite: 3.2 64bit

  • CPU: Intel Core2 Duo E7500 3.0GHz

  • MEMORY: 4Gb

  • VIDEO CARD: Intel 4 Series Integrated Graphics
Glad you got the printer(s) sorted out.

The "package installer" had loaded it up and was ready to install (no problem so far) - but as soon s I entered my Administrator  Password and it (Package Installer)  began installing "Heimdall"  I got the same annoying window pops up saying

 quote :  ONLY ONE SOFTWARE MANAGEMENT TOOL IDS ALLOWED TO RUN AT ONE TIME !!!!!   Please close the other application  eg:  "Update Manager" Synaptic", or aptitude first. End quote.

Not really sure why you're getting that message.  Doesn't sound like you are using more than one program at same time.  From your description you said you were using the "package installer".  Did you download a .deb file and then try to install it with the "GDebi Package Installer"?  (That's what it sounds like you were doing, but I can't be sure.)  If so, a better way to install it would be through the Synaptic Package Manager which is opened with Menu -> System -> Install/Remove Programs.  Go ahead and open that, then type "heimdall" in the search box to find the program packages.


Click the boxes next to both packages and choose "Mark for installation".  Then hit the "Apply" button to carry out the install.  If there are any needed dependency packages, they will be listed for install also.

If that doesn't work, then post back with screenshot as Valtam asked.  (Instructions for posting screenshots are here.)
Try Linux Beginner Search Engine for answers to Linux questions.
 

Re: Error msg everytime i try to install new software
« Reply #8 on: August 25, 2014, 09:13:09 PM »
 

jwwin

  • Guest
Ok trying again - I thank you Goldfinger for that extremely informative reply on how to use Synaptic package Installer with a great screen shot. I tried it and it blew up also. Will try to send you a screen shot of that, First I'm going to try to send a screen shot of the original error message pertaining to Package Installer. Although after trying Synaptic Package Installer and getting a system error msg I'm beginning to think I've got a corrupt copy of Linux Lite. I'm semi  computer literate and these error messages indicate a deeper system issue. But I shall attempt to send Screen shots for you both.   Well if I've read the instructions correctly you, Valtam should see a screen shot of my desktop with the original error msg that started it all. Next - Goldfinger I shall attempt to send you a screen shot of the second error msg which makes me susopect I've a corrupt copy of Linux  lite but you are the experts maybe I'm just missing something. Here is second screen shot: . Thats it let me know what you think. And thanks for your help it is appreciated.  :)
 

Re: Error msg everytime i try to install new software
« Reply #9 on: August 25, 2014, 10:03:16 PM »
 

gold_finger

  • Documentation Writer
  • Platinum Level Poster
  • *****
  • 1095
    Posts
  • Country: us
  • Reputation: 325
  • Linux Lite Member

  • Linux Lite: 3.2 64bit

  • CPU: Intel Core2 Duo E7500 3.0GHz

  • MEMORY: 4Gb

  • VIDEO CARD: Intel 4 Series Integrated Graphics
Hi jwwin,

Only see one screenshot, but that's probably enough.  That error message looks like something that would be seen if an update or installation did not fully complete.  It may have been interrupted or something like that.  Try doing what the message asks and run that command.  You need to run it as root or it won't work, so start the command with the word "sudo" to do that.  Open a terminal and enter the following as per the message:
Code: [Select]
sudo dpkg --configure -a
After it completes, open Synaptic Package Manager and try to install heimdall again.  Hopefully it works now.

If it doesn't work, or you get another error message, report back with that and another screenshot if possible.

In the meantime, if you still have the original Linux Lite ISO file that you used to make your installation DVD/USB, run an md5sum check on it and make sure the number matches what is shown on the download page.  To check the md5sum from a Windows system (which is where I'm guessing you have it), use something like this tool:  http://www.winmd5.com/.
Try Linux Beginner Search Engine for answers to Linux questions.
 

Re: Error msg everytime i try to install new software
« Reply #10 on: August 25, 2014, 10:11:20 PM »
 

jwwin

  • Guest
Only one screen shot came through so I'm trying again to send the screen shot for Valtam - which shows the original error message I was getting trying to install using "package installer" as you can see it PI  wanted to install Heimdall and was starting to when the error message popped up and everything froze.

Screen shot : 
 

Re: Error msg everytime i try to install new software
« Reply #11 on: August 25, 2014, 10:25:08 PM »
 

jwwin

  • Guest
Hey Goldfinger - you must have replied to my prwevious msg while I was trying to send the missing screen shot. Anyway - did what you said to type into the terminal and got a msg sent back to me saying - well too much to type but maybe I can capture it in a screen shot - here it is.

I'm guessing I should choose " Install the package maintainers version"  Let me Know

Thanks  :)
 

Re: Error msg everytime i try to install new software
« Reply #12 on: August 25, 2014, 10:27:37 PM »
 

Jerry

  • Linux Lite Creator
  • Administrator
  • Platinum Level Poster
  • *****
  • 7646
    Posts
  • Country: nz
  • Reputation: 722
  • Linux Lite Member
    • Linux Lite OS

  • Linux Lite: 5.0 64bit

  • CPU: Intel Xeon Dual CPU's E5645 2.4GHz 12 Cores

  • MEMORY: 16Gb

  • VIDEO CARD: nVidia GeForce GTX 1650

  • Kernel: 5.x
jwwin, thank you for your screenshot. It confirms that you have 2 software installation tools open at the same time, Synaptic Package Manager and Package Installer (the smaller window open on your desktop). Only one of these can be open at one time. I recommend you close the Package Installer completely, then use Synaptic Package Manager to install heimdall or heimdall-flash-frontend as it is known.
 

Re: Error msg everytime i try to install new software
« Reply #13 on: August 25, 2014, 10:54:40 PM »
 

jwwin

  • Guest
Wel I resolved the problem with installing packages by installing the Update from the Linux Lite Package distributor (from the command line in the terminal - thank you Gold  Finger) and Im not allowing more than one installastion program open at once (thanks Valtam) All iss well on taht front - the heimdall software installed perfectly. Now when I go to run it I type in the name Heimdall in the search bar at bottom of menu and it comes up showing me "Run Heimdall" in a blue bar with a gear icon next to it. When place my cursor over it - my cursor changes into the look it always gets when its about to launch something - so I click on it fully expecting "heimdall" to launch - but I get nothing. So with that I say good nite . Look at it tommorow.  :P
 

Re: Error msg everytime i try to install new software
« Reply #14 on: August 25, 2014, 10:55:52 PM »
 

gold_finger

  • Documentation Writer
  • Platinum Level Poster
  • *****
  • 1095
    Posts
  • Country: us
  • Reputation: 325
  • Linux Lite Member

  • Linux Lite: 3.2 64bit

  • CPU: Intel Core2 Duo E7500 3.0GHz

  • MEMORY: 4Gb

  • VIDEO CARD: Intel 4 Series Integrated Graphics
jwwin,

Every once in a while during updates to the system, one or more configuration files might be part of the update.  That screenshot shows the question that pops up when that happens.  It's asking if you want to use the new config file or if you'd prefer to keep the one that is already on your system.  Whenever you are asked that for config files, always answer "NO" -- you don't want the new one; you want to keep the one that is already on your system.  So, just type "n" for "no" and hit <Enter> to continue.  If another one pops up asking the same thing, hit "n" again and <Enter>.

If you already answered it and picked something other than "No", post back and let us know.  We can change the one or two files back to their original state so you don't end up having problems caused by the change.

Once that is all done, your ability to install things should be fixed.  (Even if you picked wrong answer on the config file question, you should be able to install heimdall after running and completing that sudo dpkg --configure -a.  You don't need to wait for us to fix the config files before installing your software.)
Try Linux Beginner Search Engine for answers to Linux questions.
 


Tags:
 


Linux Lite 5.0 Final is now available for download and installation