You are Here:
Linux Lite 4.6 RC1 has been released. See the Release Announcements section for more information.



dpkg error preventing install or upgrade

Author (Read 9435 times)

0 Members and 4 Guests are viewing this topic.

dpkg error preventing install or upgrade
« on: November 08, 2016, 07:46:37 PM »
 

Masterjuggler

  • New to Forums
  • *
  • 11
    Posts
  • Country: us
  • Reputation: 0
  • Linux Lite Member

  • Linux Lite: 3.2 64bit
Since the release of Lite 3.2, I can't seem to upgrade or install anything at all. Some error while upgrading lite-software seems to be stopping it.

Code: [Select]
Setting up lite-software (2.0-0200-linuxlite) ...
sed: can't read /etc/X11/Xsession.d/98vboxadd-xclient: No such file or directory
dpkg: error processing package lite-software (--configure):
 subprocess installed post-installation script returned error exit status 2
Errors were encountered while processing:
 lite-software
E: Sub-process /usr/bin/dpkg returned an error code (1)


I'm still using 3.0 because I can't upgrade anything. Any suggestions? Thanks in advance.
 


Re: dpkg error preventing install or upgrade
« Reply #1 on: November 08, 2016, 07:56:05 PM »
 

Jerry

  • Linux Lite Creator
  • Administrator
  • Platinum Level Poster
  • *****
  • 6941
    Posts
  • Country: nz
  • Reputation: 643
  • Linux Lite Member
    • Linux Lite OS

  • Linux Lite: 3.8 64bit

  • CPU: Intel Xeon Dual CPU's E5645 2.4GHz 12 Cores

  • MEMORY: 16Gb

  • VIDEO CARD: nVidia GeForce GTX 960
Open a terminal and do:

Code: [Select]
sudo apt-get clean
Then go to Menu, System, Install/Remove Software. Search for lite-software and uninstall it, accept any dialogue box that appears. Then reinstall it.
 

Re: dpkg error preventing install or upgrade
« Reply #2 on: November 08, 2016, 10:53:56 PM »
 

Masterjuggler

  • New to Forums
  • *
  • 11
    Posts
  • Country: us
  • Reputation: 0
  • Linux Lite Member

  • Linux Lite: 3.2 64bit
I removed lite-software and tried installing again, same error. I removed it, gained the ability to upgrade everything else, tried installing it again, same error. I upgraded to Lite 3.2, and I'm still getting the same error. Lite-software opens successfully though, even after removing, so it has in fact installed.

I'm unsure if this is related, but for the past few weeks, I've been getting this error at the end of apt-get update:

Code: [Select]
Reading package lists... Done
Building dependency tree       
Reading state information... Done
All packages are up to date.
W: Invalid 'Date' entry in Release file /var/lib/apt/lists/partial/security.ubuntu.com_ubuntu_dists_xenial-security_InRelease
W: Invalid 'Date' entry in Release file /var/lib/apt/lists/partial/us.archive.ubuntu.com_ubuntu_dists_xenial-updates_InRelease
W: Invalid 'Date' entry in Release file /var/lib/apt/lists/partial/us.archive.ubuntu.com_ubuntu_dists_xenial-backports_InRelease
W: Invalid 'Date' entry in Release file /var/lib/apt/lists/ppa.launchpad.net_ubuntu-wine_ppa_ubuntu_dists_xenial_InRelease

I'm not getting these errors on another Lite 3.2 install I have on another computer. I've tried to research this update error before, but couldn't find anything that seemed to me to be relevant.
 

Re: dpkg error preventing install or upgrade
« Reply #3 on: November 08, 2016, 11:03:37 PM »
 

Jerry

  • Linux Lite Creator
  • Administrator
  • Platinum Level Poster
  • *****
  • 6941
    Posts
  • Country: nz
  • Reputation: 643
  • Linux Lite Member
    • Linux Lite OS

  • Linux Lite: 3.8 64bit

  • CPU: Intel Xeon Dual CPU's E5645 2.4GHz 12 Cores

  • MEMORY: 16Gb

  • VIDEO CARD: nVidia GeForce GTX 960
This is an unusual and rare error message. Have you added or removed any additional software and or repositories since the fresh install?
 

Re: dpkg error preventing install or upgrade
« Reply #4 on: November 08, 2016, 11:38:56 PM »
 

Masterjuggler

  • New to Forums
  • *
  • 11
    Posts
  • Country: us
  • Reputation: 0
  • Linux Lite Member

  • Linux Lite: 3.2 64bit
I have, but nothing that should have broken anything. I've added repos for wine, spacefm, systemback, virtualbox, and chrome.
 

Re: dpkg error preventing install or upgrade
« Reply #5 on: November 08, 2016, 11:40:34 PM »
 

Jerry

  • Linux Lite Creator
  • Administrator
  • Platinum Level Poster
  • *****
  • 6941
    Posts
  • Country: nz
  • Reputation: 643
  • Linux Lite Member
    • Linux Lite OS

  • Linux Lite: 3.8 64bit

  • CPU: Intel Xeon Dual CPU's E5645 2.4GHz 12 Cores

  • MEMORY: 16Gb

  • VIDEO CARD: nVidia GeForce GTX 960
You can try the Package System Repair utility in Lite Tweaks. Then do:

Code: [Select]
sudo apt-get update && sudo apt-get dist-upgrade
from the terminal.
 

Re: dpkg error preventing install or upgrade
« Reply #6 on: November 08, 2016, 11:55:39 PM »
 

Masterjuggler

  • New to Forums
  • *
  • 11
    Posts
  • Country: us
  • Reputation: 0
  • Linux Lite Member

  • Linux Lite: 3.2 64bit
Package system repair utility returns "There was an error while installing partialy installed packages!" More than likely due to lite-software.

No change to update or upgrade errors. Dist-upgrade gives the same output as upgrade.

If I need to, I'll just make a clean installation. I'd really rather not have to go through the hassle though, as I have been using this install since just after Lite 3.0 released.
 

Re: dpkg error preventing install or upgrade
« Reply #7 on: November 09, 2016, 12:02:18 AM »
 

Jerry

  • Linux Lite Creator
  • Administrator
  • Platinum Level Poster
  • *****
  • 6941
    Posts
  • Country: nz
  • Reputation: 643
  • Linux Lite Member
    • Linux Lite OS

  • Linux Lite: 3.8 64bit

  • CPU: Intel Xeon Dual CPU's E5645 2.4GHz 12 Cores

  • MEMORY: 16Gb

  • VIDEO CARD: nVidia GeForce GTX 960
I'd like to see all of the output from the terminal after running the command from my previous post. Thanks. Also consider that a 10 minute install of 3.2, followed by a Systemback set restore point after getting LL the way you want it, could be a better solution in the long run.
 

Re: dpkg error preventing install or upgrade
« Reply #8 on: November 09, 2016, 12:11:44 AM »
 

Masterjuggler

  • New to Forums
  • *
  • 11
    Posts
  • Country: us
  • Reputation: 0
  • Linux Lite Member

  • Linux Lite: 3.2 64bit
I removed lite-software and the package system repair was able to successfully complete. It did not fix the update errors, and installing lite-software returned the upgrade error.

I was refraining prom posting the full output as you don't have spoiler tags bbcode. Here is the full output:

~$ sudo apt-get update && sudo apt-get dist-upgrade
Hit:1 http://us.archive.ubuntu.com/ubuntu xenial InRelease
Get:2 http://us.archive.ubuntu.com/ubuntu xenial-updates InRelease [95.7 kB]   
Hit:3 http://download.virtualbox.org/virtualbox/debian xenial InRelease       
Ign:4 http://dl.google.com/linux/chrome/deb stable InRelease                   
Hit:5 http://repo.linuxliteos.com/linuxlite citrine InRelease                 
Hit:6 http://dl.google.com/linux/chrome/deb stable Release                     
Get:7 http://us.archive.ubuntu.com/ubuntu xenial-backports InRelease [92.2 kB]
Hit:8 http://archive.canonical.com/ubuntu xenial InRelease                     
Hit:9 http://ppa.launchpad.net/ubuntu-wine/ppa/ubuntu xenial InRelease         
Get:10 http://security.ubuntu.com/ubuntu xenial-security InRelease [94.5 kB]   
Hit:11 http://ppa.launchpad.net/danielrichter2007/grub-customizer/ubuntu xenial InRelease
Hit:12 http://archive.canonical.com xenial InRelease                           
Hit:13 http://ppa.launchpad.net/iconnor/zoneminder/ubuntu xenial InRelease     
Hit:15 http://ppa.launchpad.net/mati75/spacefm/ubuntu xenial InRelease         
Hit:14 http://screenshots.getdeb.net xenial-getdeb InRelease                   
Hit:16 http://ppa.launchpad.net/nemh/systemback/ubuntu xenial InRelease
Hit:17 http://ppa.launchpad.net/otto-kesselgulasch/gimp/ubuntu xenial InRelease
Hit:18 http://ppa.launchpad.net/webupd8team/java/ubuntu xenial InRelease
Fetched 282 kB in 6s (46.6 kB/s)                                               
Reading package lists... Done
W: Invalid 'Date' entry in Release file /var/lib/apt/lists/partial/us.archive.ubuntu.com_ubuntu_dists_xenial-updates_InRelease
W: Invalid 'Date' entry in Release file /var/lib/apt/lists/ppa.launchpad.net_ubuntu-wine_ppa_ubuntu_dists_xenial_InRelease
W: Invalid 'Date' entry in Release file /var/lib/apt/lists/partial/us.archive.ubuntu.com_ubuntu_dists_xenial-backports_InRelease
W: Invalid 'Date' entry in Release file /var/lib/apt/lists/partial/security.ubuntu.com_ubuntu_dists_xenial-security_InRelease
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Calculating upgrade... Done
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
1 not fully installed or removed.
After this operation, 0 B of additional disk space will be used.
Do you want to continue? [Y/n]
Setting up lite-software (2.0-0200-linuxlite) ...
sed: can't read /etc/X11/Xsession.d/98vboxadd-xclient: No such file or directory
dpkg: error processing package lite-software (--configure):
 subprocess installed post-installation script returned error exit status 2
Errors were encountered while processing:
 lite-software
E: Sub-process /usr/bin/dpkg returned an error code (1)
 

Re: dpkg error preventing install or upgrade
« Reply #9 on: November 09, 2016, 12:38:49 AM »
 

Jerry

  • Linux Lite Creator
  • Administrator
  • Platinum Level Poster
  • *****
  • 6941
    Posts
  • Country: nz
  • Reputation: 643
  • Linux Lite Member
    • Linux Lite OS

  • Linux Lite: 3.8 64bit

  • CPU: Intel Xeon Dual CPU's E5645 2.4GHz 12 Cores

  • MEMORY: 16Gb

  • VIDEO CARD: nVidia GeForce GTX 960
One thought is that you're getting the Lite Software error because you've added a VirtualBox and Wine repo when we already provide these softwares via Lite Software. The difference being that you are opting for a newer versions, I assume. If you don't mind, remove the VB and Wine repo, then in this exact order do:

- Remove VB and Wine via Install/Remove Software
- Remove Lite Software in Install/Remove Software
- Remove the VB and Wine repo from the terminal by running: software-properties-gtk (don't Reload when prompted)
- sudo rm -rf /var/lib/apt/lists/partial/*
- sudo rm -rf /var/lib/apt/lists/ppa.launchpad.net_ubuntu-wine_ppa_ubuntu_dists_xenial_InRelease
- Package System Repair utility in Lite Tweaks
- sudo apt-get clean && sudo apt-get update && sudo apt-get dist-upgrade
- Lite Software, Install, VirtualBox, Wine
Last Edit: November 09, 2016, 12:42:05 AM by Jerry
 

Re: dpkg error preventing install or upgrade
« Reply #10 on: November 09, 2016, 12:47:17 AM »
 

Jerry

  • Linux Lite Creator
  • Administrator
  • Platinum Level Poster
  • *****
  • 6941
    Posts
  • Country: nz
  • Reputation: 643
  • Linux Lite Member
    • Linux Lite OS

  • Linux Lite: 3.8 64bit

  • CPU: Intel Xeon Dual CPU's E5645 2.4GHz 12 Cores

  • MEMORY: 16Gb

  • VIDEO CARD: nVidia GeForce GTX 960
Note, we also already include the SystemBack repo. The only ones you should keep that you have added are for Chrome and Spacefm.
 

Re: dpkg error preventing install or upgrade
« Reply #11 on: November 09, 2016, 02:21:36 PM »
 

Masterjuggler

  • New to Forums
  • *
  • 11
    Posts
  • Country: us
  • Reputation: 0
  • Linux Lite Member

  • Linux Lite: 3.2 64bit
I followed your directions exactly. I actually didn't have virtualbox installed in the first place, only had the repo. After removing the unnecessary repos and running going through the checklist, I'm still getting one update error, and the same lite-software error.

Code: [Select]
~$ sudo apt-get clean && sudo apt-get update && sudo apt-get dist-upgrade
Hit:1 http://us.archive.ubuntu.com/ubuntu xenial InRelease
Hit:2 http://us.archive.ubuntu.com/ubuntu xenial-updates InRelease             
Ign:3 http://dl.google.com/linux/chrome/deb stable InRelease                   
Get:4 http://us.archive.ubuntu.com/ubuntu xenial-backports InRelease [92.2 kB]
Hit:5 http://dl.google.com/linux/chrome/deb stable Release                     
Hit:6 http://archive.canonical.com/ubuntu xenial InRelease                     
Hit:7 http://security.ubuntu.com/ubuntu xenial-security InRelease             
Hit:8 http://ppa.launchpad.net/danielrichter2007/grub-customizer/ubuntu xenial InRelease
Hit:10 http://repo.linuxliteos.com/linuxlite citrine InRelease                 
Hit:11 http://ppa.launchpad.net/mati75/spacefm/ubuntu xenial InRelease 
Hit:12 http://ppa.launchpad.net/otto-kesselgulasch/gimp/ubuntu xenial InRelease
Get:9 http://screenshots.getdeb.net xenial-getdeb InRelease [8,139 B]   
Hit:13 http://ppa.launchpad.net/webupd8team/java/ubuntu xenial InRelease       
Fetched 100 kB in 1s (50.6 kB/s)                   
Reading package lists... Done
W: Invalid 'Date' entry in Release file /var/lib/apt/lists/partial/us.archive.ubuntu.com_ubuntu_dists_xenial-backports_InRelease
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Calculating upgrade... Done
The following packages will be upgraded:
  adobe-flash-properties-gtk adobe-flashplugin linux-libc-dev
3 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
1 not fully installed or removed.
Need to get 11.3 MB of archives.
After this operation, 18.4 kB of additional disk space will be used.
Do you want to continue? [Y/n]
Get:1 http://us.archive.ubuntu.com/ubuntu xenial-updates/main amd64 linux-libc-dev amd64 4.4.0-47.68 [842 kB]
Get:2 http://archive.canonical.com/ubuntu xenial/partner amd64 adobe-flash-properties-gtk amd64 1:20161108.1-0ubuntu0.16.04.1 [113 kB]
Get:3 http://archive.canonical.com/ubuntu xenial/partner amd64 adobe-flashplugin amd64 1:20161108.1-0ubuntu0.16.04.1 [10.3 MB]
Fetched 11.3 MB in 6s (1,650 kB/s)                                             
Setting up lite-software (2.0-0200-linuxlite) ...
sed: can't read /etc/X11/Xsession.d/98vboxadd-xclient: No such file or directory
dpkg: error processing package lite-software (--configure):
 subprocess installed post-installation script returned error exit status 2
Errors were encountered while processing:
 lite-software
E: Sub-process /usr/bin/dpkg returned an error code (1)

If I need to, I'll just reinstall Lite 3.2, though I'd probably simply remove lite-software and continue using this installation if it came down to it, because I personally haven't used it since I installed Linux Lite. I would like to try to figure this out though just for the sake of knowing what went wrong, and if it was something dumb I did.
Last Edit: November 09, 2016, 02:26:51 PM by Masterjuggler
 

Re: dpkg error preventing install or upgrade
« Reply #12 on: November 09, 2016, 02:26:17 PM »
 

Jerry

  • Linux Lite Creator
  • Administrator
  • Platinum Level Poster
  • *****
  • 6941
    Posts
  • Country: nz
  • Reputation: 643
  • Linux Lite Member
    • Linux Lite OS

  • Linux Lite: 3.8 64bit

  • CPU: Intel Xeon Dual CPU's E5645 2.4GHz 12 Cores

  • MEMORY: 16Gb

  • VIDEO CARD: nVidia GeForce GTX 960
Try: sudo apt-get install -f
 

Re: dpkg error preventing install or upgrade
« Reply #13 on: November 09, 2016, 11:41:43 PM »
 

Masterjuggler

  • New to Forums
  • *
  • 11
    Posts
  • Country: us
  • Reputation: 0
  • Linux Lite Member

  • Linux Lite: 3.2 64bit
Nope, no dice.

Code: [Select]
$ sudo apt-get install -f
Reading package lists... Done
Building dependency tree       
Reading state information... Done
0 upgraded, 0 newly installed, 0 to remove and 26 not upgraded.
1 not fully installed or removed.
After this operation, 0 B of additional disk space will be used.
Setting up lite-software (2.0-0200-linuxlite) ...
sed: can't read /etc/X11/Xsession.d/98vboxadd-xclient: No such file or directory
dpkg: error processing package lite-software (--configure):
 subprocess installed post-installation script returned error exit status 2
Errors were encountered while processing:
 lite-software
E: Sub-process /usr/bin/dpkg returned an error code (1)
Last Edit: November 09, 2016, 11:45:04 PM by Masterjuggler
 

Re: dpkg error preventing install or upgrade
« Reply #14 on: November 10, 2016, 12:34:44 AM »
 

Jerry

  • Linux Lite Creator
  • Administrator
  • Platinum Level Poster
  • *****
  • 6941
    Posts
  • Country: nz
  • Reputation: 643
  • Linux Lite Member
    • Linux Lite OS

  • Linux Lite: 3.8 64bit

  • CPU: Intel Xeon Dual CPU's E5645 2.4GHz 12 Cores

  • MEMORY: 16Gb

  • VIDEO CARD: nVidia GeForce GTX 960
Try:

Code: [Select]
sudo leafpad /etc/X11/Xsession.d/98vboxadd-xclient
add the following and save the file:

Code: [Select]
#!/bin/sh
## @file
# Start the Guest Additions X11 Client
#

#
# Copyright (C) 2007-2012 Oracle Corporation
#
# This file is part of VirtualBox Open Source Edition (OSE), as
# available from [url]http://www.virtualbox.org[/url]. This file is free software;
# you can redistribute it and/or modify it under the terms of the GNU
# General Public License (GPL) as published by the Free Software
# Foundation, in version 2 as it comes in the "COPYING" file of the
# VirtualBox OSE distribution. VirtualBox OSE is distributed in the
# hope that it will be useful, but WITHOUT ANY WARRANTY of any kind.
#

# Sanity check: if non-writeable PID-files are present in the user home
# directory VBoxClient will fail to start.
for i in $HOME/.vboxclient-*.pid; do
    test -w $i || rm -f $i
done

if ! test -c /dev/vboxguest 2>/dev/null; then
   # Do not start if the kernel module is not present.
   notify-send "VBoxClient: the VirtualBox kernel service is not running.  Exiting."
elif test -z "${SSH_CONNECTION}"; then
   # This script can also be triggered by a connection over SSH, which is not
   # what we had in mind, so we do not start VBoxClient in that case.  We do
   # not use "exit" here as this script is "source"d, not executed.
  /usr/bin/VBoxClient --clipboard || true
  /usr/bin/VBoxClient --checkhostversion || true
  /usr/bin/VBoxClient --display || true
  /usr/bin/VBoxClient --seamless || true
  /usr/bin/VBoxClient --draganddrop || true
fi

then try updates again.
 


Tags:
 


Linux Lite 4.6 RC1 has been released. See the Release Announcements section for more information.