Linux Lite Forums

Software - Support => Installing Software => Topic started by: ThisIsMeta on August 02, 2020, 01:37:56 AM

Title: cannot update linux lite
Post by: ThisIsMeta on August 02, 2020, 01:37:56 AM
I need help with this one, I've looked around on the net and can't find any solutions

===========================
Install Updates Error log
===========================
Install Updates could not fetch the package cache information lists.
Go to https://www.linuxliteos.com/forums/ and paste the log below into a new or existing thread for assistance.

============ Log ===========

Hit:1 http://repo.linuxliteos.com/linuxlite emerald InRelease
Hit:2 https://repo.steampowered.com/steam stable InRelease
Hit:3 http://archive.canonical.com/ubuntu focal InRelease
Hit:4 http://us.archive.ubuntu.com/ubuntu focal InRelease
Hit:5 https://deb.opera.com/opera-stable stable InRelease
Get:6 http://us.archive.ubuntu.com/ubuntu focal-updates InRelease [111 kB]
Hit:7 http://ppa.launchpad.net/appgrid/stable/ubuntu focal InRelease
Get:8 http://security.ubuntu.com/ubuntu focal-security InRelease [107 kB]
Get:9 http://us.archive.ubuntu.com/ubuntu focal-backports InRelease [98.3 kB]
Ign:10 http://ppa.launchpad.net/libretro/gcc-for-libretro/ubuntu focal InRelease
Hit:11 http://ppa.launchpad.net/libretro/stable/ubuntu focal InRelease
Err:12 http://ppa.launchpad.net/libretro/gcc-for-libretro/ubuntu focal Release
  404  Not Found [IP: 91.189.95.83 80]
Reading package lists...
E: The repository 'http://ppa.launchpad.net/libretro/gcc-for-libretro/ubuntu focal Release' does not have a Release file.
Title: Re: cannot update linux lite
Post by: stevef on August 02, 2020, 02:02:29 AM
Your machine is using some software that has a PPA (Personal Package Archive) in your update list.  PPA aren't part of the supported software repositories.  Unfortunately, if there is a problem with a listed PPA it stops the update process working because the machine cannot find everything on the list.

To remove a failing PPA from the list and allow the rest of the update to work check the manual at

https://www.linuxliteos.com/manual/software.html#pparem

and remove the offending PPA as described there.
Title: Re: cannot update linux lite
Post by: ThisIsMeta on August 02, 2020, 06:08:50 AM
Thank you! it seems to have solved the problem.
Title: Re: cannot update linux lite
Post by: stevef on August 02, 2020, 08:56:56 AM
You are welcome.

As I understand it, removing a PPA from the sources list is a workaround to allow the update process to complete to ensure that other packages get their updates. But it means you will not get any updates from that source in the future.

If you need (and trust) the software source you may want to check periodically to see if the PPA is put back on line by reversing the change you made.