You are Here:
Linux Lite 5.0 Final is now available for download and installation



[ SOLVED ] Cannot install software

Author (Read 1439 times)

0 Members and 1 Guest are viewing this topic.

Cannot install software
« on: September 05, 2016, 07:59:26 AM »
 

paul1149

  • PayPal Supporter
  • I come here a lot
  • *****
  • 316
    Posts
  • Country: us
  • Reputation: 42
  • Enjoying Linux

  • Linux Lite: 3.6 64bit

  • CPU: C2D

  • MEMORY: 6Gb

  • VIDEO CARD: nVidia
Hi folks,


I've run up against a problem in LL 3.0 x64. I went to install the latest version of Bleachbit, and the installer told me there is an older version in the repository. I Closed that message, but the installer would not go on, saying another installer was already running. This happened even upon a fresh boot with nothing else done in the session.


So I opened up Synaptic and it told me there was an error, and to run dpkg --configure -a . It ran, but with errors. I then opened Synaptic and it said there were broken packages that had to be remedied. Turns out the broken package was linux-generic 4.4.0.36.38, which sounds pretty important to me.


I attempted to reinstall the package, but got Internal error. No file name for linux-generic:amd64. A retrybrought the same error.


I don't know if the Bleachbit install error is tied to this other one, but I suspect so. Is there a solution to this?


Thank you.
Last Edit: September 11, 2016, 02:53:58 PM by paul1149
 


Re: Cannot install software
« Reply #1 on: September 05, 2016, 10:25:59 AM »
 

torreydale

  • PayPal Supporter
  • Platinum Level Poster
  • *****
  • 1549
    Posts
  • Country: us
  • Reputation: 254
  • * Forum Moderator *

  • Linux Lite: 4.8 64bit

  • CPU: Intel Core i5-5300U (-HT-MCP-)

  • MEMORY: 8Gb

  • VIDEO CARD: Intel Broadwell-U Integrated Graphics

  • Kernel: 4.x
Part of me wants to say the answer is to use Lite Tweaks (Menu > System > Lite Tweaks) instead of Bleachbit, and the other part of me says to never kick a man when he's down.  So I'd be curious to see what happens if you ran the following in a terminal:

Code: [Select]
sudo apt-get install linux-generic
and/or if in Synaptic Package Manager you selected Reload, Mark all Upgrades, and Apply to view what was available for install before installing it.
Want to thank me?  Click my [Thank] link.
 

Re: Cannot install software
« Reply #2 on: September 05, 2016, 10:48:56 AM »
 

paul1149

  • PayPal Supporter
  • I come here a lot
  • *****
  • 316
    Posts
  • Country: us
  • Reputation: 42
  • Enjoying Linux

  • Linux Lite: 3.6 64bit

  • CPU: C2D

  • MEMORY: 6Gb

  • VIDEO CARD: nVidia
Awesome. I was unaware of that "Mark all upgrades" function. It worked beautifully, and then Bleachbit installed without any problem.

Thanks much!
 

Re: Cannot install software
« Reply #3 on: September 11, 2016, 02:52:01 PM »
 

demiurge

  • New to Forums
  • *
  • 5
    Posts
  • Country: us
  • Reputation: 0
  • Linux Lite Member

  • Linux Lite: 2.8 32bit

  • CPU: pentium4 3.0 Ghz

  • MEMORY: 2Gb
please mark your question as solved
 


Tags:
 


Linux Lite 5.0 Final is now available for download and installation