Linux Lite Forums

Software - Support => Installing Software => Topic started by: Monkeyman on July 17, 2016, 08:00:34 PM

Title: Can't get .exe drivers to work in Wine
Post by: Monkeyman on July 17, 2016, 08:00:34 PM
Just installed a new GPU and PSU.  Both have and/or need drivers/specific software that I'd like to install.  I can come up with .exe (Windows) files but can't open them (in Wine).  The ZIP file for the GPU ( http://www.newegg.com/Product/Product.aspx?Item=N82E16814125792 ) extracts in it's own folder but shows an error when I try running the .exe file.  The ZIP file for the PSU ( http://www.newegg.com/Product/Product.aspx?Item=N82E16817139138 ) adds yet another .exe file but when I try to open that it says "Microsoft .NET framework" is required.  Can I assume (since I'm not running Windows) that there's no way around this?  This one isn't critical but would be very helpful (enabling me to control the PSU fan).

Any help/work arounds would be appreciated.
Title: Re: Can't get .exe drivers to work in Wine
Post by: torreydale on July 17, 2016, 11:08:18 PM
You might want to give this a gander:
https://www.linux.com/news/my-hardware-linux-compatible-find-out-here
Title: Re: Can't get .exe drivers to work in Wine
Post by: Monkeyman on July 18, 2016, 04:16:20 PM
Thanks.  TBH, I'm half tempted to go back to Windows.  I can do what needs to be done a bit easier as I'm not terribly smart.
Title: Re: Can't get .exe drivers to work in Wine
Post by: torreydale on July 18, 2016, 05:07:34 PM
Perhaps consider these links as resources:
http://support.amd.com/en-us/download/linux
http://support.amd.com/en-us/download/desktop?os=Ubuntu+x86+64
Title: Re: Can't get .exe drivers to work in Wine
Post by: Monkeyman on July 18, 2016, 07:07:02 PM
Thanks but I get "same version already installed" and no change in vid card performance.  It was worth a try.
Title: Re: Can't get .exe drivers to work in Wine
Post by: Wirezfree on July 18, 2016, 08:14:08 PM
Hi,

Is the card installed.??
Are you trying to install the R9-390 drivers via Wine to use in Wine/Windows.? or you want to use directly in LL.??

Is there any additional drivers showing if you go Menu > Drivers(Install Drivers)


A quick Google shows Ubuntu 16.04, therefore LL3.0 kernel 4.4 includes additional AMD Support without the need for proprietary drivers.


Regarding Fan Control,


You can try:
Code: [Select]
sudo apt-get install libsensors4 lm-sensors psensor hddtempThen:
Code: [Select]
sudo sensors-detectLet it see if it can detect any/all your Mobo sensors, it really depends on Mobo.
I can see fan speeds on some, some not...


Open psensors that will give you an idea...
Again, it seems to not always give a clear indication on CPU Cores/CPU...
Also, some things duplicate, some values seem static... It's not a LL issue


GL
Title: Re: Can't get .exe drivers to work in Wine
Post by: trinidad on July 19, 2016, 07:36:53 AM
The psu fan may not need config in Deb, as its power is continuous, and sensor controls are linked to itself, however others will, and some psu have boosted case cooling optional. The other fans should have support, but you may need to disable or change acpi settings from your bios, AMI? to manually configure settings.

https://wiki.archlinux.org/index.php/fan_speed_control

The files you have are windows files because some boards shipped with windows8 had special capacities that needed to be considered, such as quick boot, quick return from hibernate, etc. which bypassed or nulled some mobo acpi settings.

My guess is the fans will not be a problem on 2.8 or 3.0, but you will have to post the gpu in the bios for Deb to find it.

TC