You are Here:
Linux Lite 4.6 Final has been released. See the Release Announcements section for more information.



Can't get .exe drivers to work in Wine

Author (Read 1715 times)

0 Members and 1 Guest are viewing this topic.

Can't get .exe drivers to work in Wine
« on: July 17, 2016, 08:00:34 PM »
 

Monkeyman

  • Forum Regular
  • ***
  • 237
    Posts
  • Country: us
  • Reputation: 14
  • Jesus Freak

  • Linux Lite: 2.8 64bit

  • CPU: AMD Phenom II (old skool!)

  • MEMORY: 4Gb

  • VIDEO CARD: GeForce 450
Just installed a new GPU and PSU.  Both have and/or need drivers/specific software that I'd like to install.  I can come up with .exe (Windows) files but can't open them (in Wine).  The ZIP file for the GPU ( http://www.newegg.com/Product/Product.aspx?Item=N82E16814125792 ) extracts in it's own folder but shows an error when I try running the .exe file.  The ZIP file for the PSU ( http://www.newegg.com/Product/Product.aspx?Item=N82E16817139138 ) adds yet another .exe file but when I try to open that it says "Microsoft .NET framework" is required.  Can I assume (since I'm not running Windows) that there's no way around this?  This one isn't critical but would be very helpful (enabling me to control the PSU fan).

Any help/work arounds would be appreciated.
 


Re: Can't get .exe drivers to work in Wine
« Reply #1 on: July 17, 2016, 11:08:18 PM »
 

torreydale

  • PayPal Supporter
  • Platinum Level Poster
  • *****
  • 1482
    Posts
  • Country: us
  • Reputation: 242
  • * Forum Moderator *

  • Linux Lite: 4.6 64bit

  • CPU: Intel Core i5-5300U (-HT-MCP-)

  • MEMORY: 8Gb

  • VIDEO CARD: Intel Broadwell-U Integrated Graphics
Want to thank me?  Click my [Thank] link.
 

Re: Can't get .exe drivers to work in Wine
« Reply #2 on: July 18, 2016, 04:16:20 PM »
 

Monkeyman

  • Forum Regular
  • ***
  • 237
    Posts
  • Country: us
  • Reputation: 14
  • Jesus Freak

  • Linux Lite: 2.8 64bit

  • CPU: AMD Phenom II (old skool!)

  • MEMORY: 4Gb

  • VIDEO CARD: GeForce 450
Thanks.  TBH, I'm half tempted to go back to Windows.  I can do what needs to be done a bit easier as I'm not terribly smart.
 

Re: Can't get .exe drivers to work in Wine
« Reply #3 on: July 18, 2016, 05:07:34 PM »
 

torreydale

  • PayPal Supporter
  • Platinum Level Poster
  • *****
  • 1482
    Posts
  • Country: us
  • Reputation: 242
  • * Forum Moderator *

  • Linux Lite: 4.6 64bit

  • CPU: Intel Core i5-5300U (-HT-MCP-)

  • MEMORY: 8Gb

  • VIDEO CARD: Intel Broadwell-U Integrated Graphics
Want to thank me?  Click my [Thank] link.
 

Re: Can't get .exe drivers to work in Wine
« Reply #4 on: July 18, 2016, 07:07:02 PM »
 

Monkeyman

  • Forum Regular
  • ***
  • 237
    Posts
  • Country: us
  • Reputation: 14
  • Jesus Freak

  • Linux Lite: 2.8 64bit

  • CPU: AMD Phenom II (old skool!)

  • MEMORY: 4Gb

  • VIDEO CARD: GeForce 450
Thanks but I get "same version already installed" and no change in vid card performance.  It was worth a try.
 

Re: Can't get .exe drivers to work in Wine
« Reply #5 on: July 18, 2016, 08:14:08 PM »
 

Wirezfree

  • PayPal Supporter
  • Platinum Level Poster
  • *****
  • 1484
    Posts
  • Country: gb
  • Reputation: 404
  • Linux Lite "Advocate"

  • Linux Lite: 2.8 64bit

  • CPU: i7-4790S

  • MEMORY: 16Gb

  • VIDEO CARD: Intel HD4600 (Integrated)
Hi,

Is the card installed.??
Are you trying to install the R9-390 drivers via Wine to use in Wine/Windows.? or you want to use directly in LL.??

Is there any additional drivers showing if you go Menu > Drivers(Install Drivers)


A quick Google shows Ubuntu 16.04, therefore LL3.0 kernel 4.4 includes additional AMD Support without the need for proprietary drivers.


Regarding Fan Control,


You can try:
Code: [Select]
sudo apt-get install libsensors4 lm-sensors psensor hddtempThen:
Code: [Select]
sudo sensors-detectLet it see if it can detect any/all your Mobo sensors, it really depends on Mobo.
I can see fan speeds on some, some not...


Open psensors that will give you an idea...
Again, it seems to not always give a clear indication on CPU Cores/CPU...
Also, some things duplicate, some values seem static... It's not a LL issue


GL
Upgrades WIP 2.6 to 2.8 - (6 X 2.6 to 2.8 completed on: 20/02/16 All O.K )
Linux Lite 3.0 Humming on a ASRock N3070 Mobo ~ btrfs RAID 10 Install on 4 Disks :)

Computers Early days:
ZX Spectrum(1982) , HP-150 MS-DOS(1983) , Amstrad CPC464(1984) ,  BBC Micro B+64(1985) , My First PC HP-Vectra(1987)
 

Re: Can't get .exe drivers to work in Wine
« Reply #6 on: July 19, 2016, 07:36:53 AM »
 

trinidad

  • Gold Level Poster
  • *******
  • 994
    Posts
  • Country: us
  • Reputation: 178
  • Linux Lite Member
    • dbts-analytics.com

  • Linux Lite: 4.4 64bit

  • CPU: AMD A8 5500 4 cores

  • MEMORY: 8Gb

  • VIDEO CARD: AMD/ATI Radeon HD 7560D
The psu fan may not need config in Deb, as its power is continuous, and sensor controls are linked to itself, however others will, and some psu have boosted case cooling optional. The other fans should have support, but you may need to disable or change acpi settings from your bios, AMI? to manually configure settings.

https://wiki.archlinux.org/index.php/fan_speed_control

The files you have are windows files because some boards shipped with windows8 had special capacities that needed to be considered, such as quick boot, quick return from hibernate, etc. which bypassed or nulled some mobo acpi settings.

My guess is the fans will not be a problem on 2.8 or 3.0, but you will have to post the gpu in the bios for Deb to find it.

TC 
All opinions expressed and all advice given by Trinidad Cruz on this forum are his responsibility alone and do not necessarily reflect the views or methods of the developers of Linux Lite. He is a citizen of the United States where it is acceptable to occasionally be uninformed and inept as long as you pay your taxes.
 


Tags:
 


Linux Lite 4.6 Final has been released. See the Release Announcements section for more information.