Linux Lite Forums

Software - Support => Installing Software => Topic started by: bitsnpcs on February 28, 2015, 10:45:37 AM

Post by: bitsnpcs on February 28, 2015, 10:45:37 AM
I used LinSSID a while back in LL2 and it worked very well for scanning what wifi was about near to me.
Today when I try to use it for the first time in LL2.2, it does not appear to be working and I am unsure why, or how to solve this ?
This is what occurs -
1/ the program GUI does not open when clicked.
2/ a box pops up on the desktop instead that is like so -
    "password required for iwlist scan:"
Below this it reads -
"First Shot:"
and below this it has a space to type password
Below this it has cancel and okay buttons.
3/ if cancel is clicked a new box pops up reading "password fail"
4/ if something silly such as 1 character is entered it pops up a box as per #3 then as per #2 but reading "second shot".
5/ I looked up iwlist and it says it is a command for scanning wifi.

I am trying to test from home what set ups work best, and also experiment how a variety of combinations compare, and if I can connect to the any of the many free public access wifi that have no password. Later in the year I will also try to be using wifi when out/mobile sometimes.

In this instance the new kit I am trying to test is -
1/ a small wifi n dongle with 5dbi external antenna.
2/ an Alfa 7dbi panel antenna attached to my Alfa Awuso36h, I know this adapter works fine as it is what I have used in my previous exploring, I have also retried it using its 5dbi omni, and also a Yagi directional I have and the same occurs in LinSSID, in all tries, which is why I guessed it may be a software issue not hardware.
Title: Re: LinSSID
Post by: Scott on February 28, 2015, 11:15:24 AM
Hi Bitsnpcs,

I'm not familiar with LinSSID software but I have one idea regarding:
3/ if cancel is clicked a new box pops up reading "password fail"

Maybe it's not working due to lost password authorization?
>Either the admin password associated with adding a new wifi entry to the network manager/LinSSID or
>The wifi password itself.

This is just a guess. With the network manager occassionally I need to remove the offending entry, reboot, then add it again.

Have you tried the SourceForge page for the LinSSID project? (
Title: Re: LinSSID
Post by: bitsnpcs on February 28, 2015, 03:26:57 PM
Hello Scott,

I am unsure. It didn't have any previous password authentication for wifi, or wifi password as I do not have wifi at home, and have never set a password for this.
Yes I have had a look at the Sourceforge page.

Since my initial post I have also tried a program called "wifi-radar" which I found in Synaptic. This also will not run or open its GUI, it also opens this pop up box for a password.

Edit: I've got it working now, the cause of the error ME  :-[ , your post about authentication helped  :) ... the password it needs is the root password for the program to run, it's really odd as I didn't need to do this the last time I used it, I thought maybe it's a program update/change, but looking at this website ( which was wrote over a year before my last use it says it needs the root password so I must have had a dizzy moment. (or a special version of the program before it was updated,  ;) this is what I'll tell myself for a while lol)

If anyone is interested in the results, the dongle isn't very powerful from inside the house, it does receive 11 signals but at -110.
The Alfa 7dbi panel antenna, it finds the signals super fast and -25 thru -40.

Is it possible to determine an approximate distance reached for signals in LinSSID or other scanners when at home ?
I am getting a BU-353-4 gps pod for mobile use.
Title: Re: LinSSID & wifi-radar
Post by: Scott on February 28, 2015, 06:22:47 PM
It looks like the password thing is a known issue. I was reading about it in this thread....
Title: Re: LinSSID & wifi-radar
Post by: bitsnpcs on February 28, 2015, 06:39:56 PM
Thank You Scott. :)
It is fixed now, I edited my above post.
Title: Re: [SOLVED] LinSSID
Post by: N4RPS on March 01, 2015, 12:16:44 AM

Whenever I use LinSSID, it asks me for the sudo password. If memory serves me, I think it has something to do with permissions needed to use the 'iw' command...

Title: Re: [SOLVED] LinSSID
Post by: bitsnpcs on March 01, 2015, 08:48:04 AM
Hello Rob,

you're correct.
I don't know how I forgot this, I had only used it in one session before testing the Awuso36h, its antenna and a Yagi worked.