You are Here:
Install Updates Gimp Error - see Security & Bug Fixes Section Sticky



[SOLVED] Error when installing additional software (LL 2.2)

Author (Read 7306 times)

0 Members and 2 Guests are viewing this topic.

Re: install additional software 2.2
« Reply #15 on: December 04, 2014, 03:56:10 AM »
 

Jerry

  • Linux Lite Creator
  • Administrator
  • Platinum Level Poster
  • *****
  • 7074
    Posts
  • Country: nz
  • Reputation: 662
  • Linux Lite Member
    • Linux Lite OS

  • Linux Lite: 3.8 64bit

  • CPU: Intel Xeon Dual CPU's E5645 2.4GHz 12 Cores

  • MEMORY: 16Gb

  • VIDEO CARD: nVidia GeForce GTX 960
I'm available for Teamviewer in the next hour or so if you like TMG1961
 


Re: install additional software 2.2
« Reply #16 on: December 04, 2014, 04:03:49 AM »
 

TMG1961

  • PayPal Supporter
  • Gold Level Poster
  • *****
  • 563
    Posts
  • Country: nl
  • Reputation: 88
  • Linux Lite Member

  • Linux Lite: 4.4 64bit

  • CPU: Intel(R) Core(TM) i3-7020U

  • MEMORY: 8Gb

  • VIDEO CARD: Intel(R) HD Graphics 620
I'm available for Teamviewer in the next hour or so if you like TMG1961

I'm available for Teamviewer in the next hour or so if you like TMG1961

did send you a pm
Life on earth is expensive but it does include a free trip around the sun.
 

Re: install additional software 2.2
« Reply #17 on: December 04, 2014, 05:09:12 AM »
 

Jerry

  • Linux Lite Creator
  • Administrator
  • Platinum Level Poster
  • *****
  • 7074
    Posts
  • Country: nz
  • Reputation: 662
  • Linux Lite Member
    • Linux Lite OS

  • Linux Lite: 3.8 64bit

  • CPU: Intel Xeon Dual CPU's E5645 2.4GHz 12 Cores

  • MEMORY: 16Gb

  • VIDEO CARD: nVidia GeForce GTX 960
Ok folks, I have found the issue here. If you install another language, Install Additional Software will ask for Updates each time, and show everything as installed. So we need to fix this. Thank you for the bug report and keep an eye on the Forums for a fix. Cheers :)
 

Re: install additional software 2.2
« Reply #18 on: December 04, 2014, 06:52:39 AM »
 

TMG1961

  • PayPal Supporter
  • Gold Level Poster
  • *****
  • 563
    Posts
  • Country: nl
  • Reputation: 88
  • Linux Lite Member

  • Linux Lite: 4.4 64bit

  • CPU: Intel(R) Core(TM) i3-7020U

  • MEMORY: 8Gb

  • VIDEO CARD: Intel(R) HD Graphics 620
As agreed earlier I installed LL2.2 32 bit, installed additional software, kept default language, set up mail account and added weather indicator. Did a few reboots and up to now all is working ok
Life on earth is expensive but it does include a free trip around the sun.
 

Re: install additional software 2.2
« Reply #19 on: December 04, 2014, 07:09:24 AM »
 

Wirezfree

  • PayPal Supporter
  • Platinum Level Poster
  • *****
  • 1484
    Posts
  • Country: gb
  • Reputation: 404
  • Linux Lite "Advocate"

  • Linux Lite: 2.8 64bit

  • CPU: i7-4790S

  • MEMORY: 16Gb

  • VIDEO CARD: Intel HD4600 (Integrated)
Now this is what I call support....

TMG1961...
Great work for persevering, and working with Jerry...
Some people may have just give up and moved on to another distro out of frustration.

Jerry...
Hat's off to you for the support, not sure how many other Distro-Devs would have gone that extra mile.

Dave
Upgrades WIP 2.6 to 2.8 - (6 X 2.6 to 2.8 completed on: 20/02/16 All O.K )
Linux Lite 3.0 Humming on a ASRock N3070 Mobo ~ btrfs RAID 10 Install on 4 Disks :)

Computers Early days:
ZX Spectrum(1982) , HP-150 MS-DOS(1983) , Amstrad CPC464(1984) ,  BBC Micro B+64(1985) , My First PC HP-Vectra(1987)
 

Re: install additional software 2.2
« Reply #20 on: December 04, 2014, 09:20:34 AM »
 

sysdrum

  • Saying the wrong things at the right time.
  • Occasional Poster
  • **
  • 83
    Posts
  • Country: us
  • Reputation: 12
  • That's personal.

  • Linux Lite: 3.8 64bit

  • CPU: Intel Core i5-6400

  • MEMORY: 16Gb

  • VIDEO CARD: Nvidia 1050 Ti
Interesting so
Code: [Select]
sudo apt-get install -f should have thrown an error if there was a broken language dependency. Do we have any weird output?
 

Re: install additional software 2.2
« Reply #21 on: December 04, 2014, 09:25:05 AM »
 

TMG1961

  • PayPal Supporter
  • Gold Level Poster
  • *****
  • 563
    Posts
  • Country: nl
  • Reputation: 88
  • Linux Lite Member

  • Linux Lite: 4.4 64bit

  • CPU: Intel(R) Core(TM) i3-7020U

  • MEMORY: 8Gb

  • VIDEO CARD: Intel(R) HD Graphics 620
Interesting so
Code: [Select]
sudo apt-get install -f should have thrown an error if there was a broken language dependency. Do we have any weird output?

No, gave no errors
Life on earth is expensive but it does include a free trip around the sun.
 

Re: install additional software 2.2
« Reply #22 on: December 04, 2014, 10:20:58 AM »
 

iwar

  • Occasional Poster
  • **
  • 60
    Posts
  • Reputation: 0
  • Linux Lite Member
what is your time right now here its 16:20

ok!
 did not see page 2 when i posted
Last Edit: December 04, 2014, 10:24:43 AM by iwar
 

Re: install additional software 2.2
« Reply #23 on: December 04, 2014, 11:48:36 AM »
 

Wirezfree

  • PayPal Supporter
  • Platinum Level Poster
  • *****
  • 1484
    Posts
  • Country: gb
  • Reputation: 404
  • Linux Lite "Advocate"

  • Linux Lite: 2.8 64bit

  • CPU: i7-4790S

  • MEMORY: 16Gb

  • VIDEO CARD: Intel HD4600 (Integrated)
Hi iwar,

I'm sure Jerry is in New Zealand:
http://www.timeanddate.com/worldclock/new-zealand/auckland
Upgrades WIP 2.6 to 2.8 - (6 X 2.6 to 2.8 completed on: 20/02/16 All O.K )
Linux Lite 3.0 Humming on a ASRock N3070 Mobo ~ btrfs RAID 10 Install on 4 Disks :)

Computers Early days:
ZX Spectrum(1982) , HP-150 MS-DOS(1983) , Amstrad CPC464(1984) ,  BBC Micro B+64(1985) , My First PC HP-Vectra(1987)
 

Re: install additional software 2.2
« Reply #24 on: December 04, 2014, 12:17:46 PM »
 

TMG1961

  • PayPal Supporter
  • Gold Level Poster
  • *****
  • 563
    Posts
  • Country: nl
  • Reputation: 88
  • Linux Lite Member

  • Linux Lite: 4.4 64bit

  • CPU: Intel(R) Core(TM) i3-7020U

  • MEMORY: 8Gb

  • VIDEO CARD: Intel(R) HD Graphics 620
what is your time right now here its 16:20

ok!
 did not see page 2 when i posted

we are in the same timezone
Life on earth is expensive but it does include a free trip around the sun.
 

Re: install additional software 2.2
« Reply #25 on: December 04, 2014, 01:25:40 PM »
 

iwar

  • Occasional Poster
  • **
  • 60
    Posts
  • Reputation: 0
  • Linux Lite Member
Yes TMG1961 but Jerry is not in the same zon
 

Re: install additional software 2.2
« Reply #26 on: December 04, 2014, 02:57:26 PM »
 

TMG1961

  • PayPal Supporter
  • Gold Level Poster
  • *****
  • 563
    Posts
  • Country: nl
  • Reputation: 88
  • Linux Lite Member

  • Linux Lite: 4.4 64bit

  • CPU: Intel(R) Core(TM) i3-7020U

  • MEMORY: 8Gb

  • VIDEO CARD: Intel(R) HD Graphics 620
Yes TMG1961 but Jerry is not in the same zon

No i think he is just getting out of bed at this moment..guess he is about 12 hours ahead of us
Life on earth is expensive but it does include a free trip around the sun.
 

Re: install additional software 2.2
« Reply #27 on: December 04, 2014, 03:26:10 PM »
 

sysdrum

  • Saying the wrong things at the right time.
  • Occasional Poster
  • **
  • 83
    Posts
  • Country: us
  • Reputation: 12
  • That's personal.

  • Linux Lite: 3.8 64bit

  • CPU: Intel Core i5-6400

  • MEMORY: 16Gb

  • VIDEO CARD: Nvidia 1050 Ti

So why is a grep command?
Code: [Select]
test_appletrailers1=(`apt-cache policy totem-mozilla | grep "Installed:"`)Before this command?
Code: [Select]
if [ "${PIPESTATUS[0]}" -ne "0" ]; then
                    if zenity --question --title=Update --text="You must update package lists before using this tool\nDo you want to update?"
                    then
                                    sudo apt-get update | zenity --progress --text="Updating package lists..." --title="Please wait" --pulsate --auto-close
                                     if [ "${PIPESTATUS[0]}" -ne "0" ]; then
                                                zenity --error --title="Error" --text="Updating package lists has failed."
                                                exit
                                     fi
         
                    else                            exit


In the script it makes a grep call before a zenity call, could the grep cause a fault if there is an error in the grep?


I pulled the code from both the Git and in usr/scripts/lite-software on a current 32 and 64.
I am not sure if that could be the problem but when I removed it the error went away on the 32 bit and 64 bit when another installed language was present. But I am not sure that is the complete issue.

Last Edit: December 04, 2014, 03:36:17 PM by sysdrum
 

Re: install additional software 2.2
« Reply #28 on: December 05, 2014, 03:53:01 AM »
 

TMG1961

  • PayPal Supporter
  • Gold Level Poster
  • *****
  • 563
    Posts
  • Country: nl
  • Reputation: 88
  • Linux Lite Member

  • Linux Lite: 4.4 64bit

  • CPU: Intel(R) Core(TM) i3-7020U

  • MEMORY: 8Gb

  • VIDEO CARD: Intel(R) HD Graphics 620
Should i change the default language to Dutch to see if the error pops up? Or do you want to take a look yourself Jerry?
Life on earth is expensive but it does include a free trip around the sun.
 

Re: install additional software 2.2
« Reply #29 on: December 05, 2014, 04:11:52 PM »
 

TMG1961

  • PayPal Supporter
  • Gold Level Poster
  • *****
  • 563
    Posts
  • Country: nl
  • Reputation: 88
  • Linux Lite Member

  • Linux Lite: 4.4 64bit

  • CPU: Intel(R) Core(TM) i3-7020U

  • MEMORY: 8Gb

  • VIDEO CARD: Intel(R) HD Graphics 620
Thought i give it a try. Changed language to Dutch, logged out and back in again and tried to install additional software and got the pop up that i needed to update first. Changed the language back to English and logged out and in again and no pop up when i tried to install additional software.
Life on earth is expensive but it does include a free trip around the sun.
 


Tags:
 


Install Updates Gimp Error - see Security & Bug Fixes Section Sticky