Software - Support > Installing Linux Lite

USB Persistence for LL v6.0

<< < (2/2)

The laptop was connected to a WiFi network for these. For the following, I disabled WiFi networking and disabled networking (both through the system tray icon checkboxes), then rebooted:

--- Code: --- linux  ~  systemd-analyze blame
4min 41.327s systemd-tmpfiles-clean.service
4min 24.085s ua-timer.service
2min 40.984s networking.service
1min 37.879s gpu-manager.service
1min 35.142s blueman-mechanism.service
1min 30.997s networkd-dispatcher.service
1min 30.235s nmbd.service
1min 29.378s polkit.service
1min 25.028s avahi-daemon.service
1min 24.980s bluetooth.service
1min 24.681s thermald.service
1min 24.680s systemd-logind.service
1min 24.399s wpa_supplicant.service
     53.798s resolvconf-pull-resolved.service
     48.431s systemd-journald.service
     42.951s rsyslog.service
     30.083s secureboot-db.service
     22.869s lm-sensors.service
     20.079s WolfLandBuilder-firstboot.service
     19.186s packagekit.service
     16.389s update-notifier-download.service
     15.435s rc-local.service
     14.815s ModemManager.service

--- End code ---

--- Code: @4min 28.131s
└─ @4min 28.131s
  └─smbd.service @4min 27.181s +949ms
    └─ @2min 56.938s
      └─ @2min 56.938s
        └─NetworkManager.service @1min 51.675s +8.277s
          └─dbus.service @16.478s
            └─ @16.421s
              └─ @16.421s
                └─uuidd.socket @16.421s
                  └─ @16.182s
                    └─systemd-update-utmp.service @16.107s +5ms
                      └─systemd-tmpfiles-setup.service @15.932s +172ms
                        └─ @15.857s
                          └─run-user-990-gvfs.mount @3min 12.451s
                            └─run-user-990.mount @2min 57.107s
                              └─ @11.914s
                                └─systemd-tmpfiles-setup-dev.service @11.738s +>
                                  └─systemd-sysusers.service @2.849s +8.887s
                                    └─systemd-remount-fs.service @2.763s +73ms

--- End code ---

It is more than just the boot process, however: for instance, launching Chrome took over 5 minutes. My installation is fresh, except for installing updates and the NVidia proprietary drivers 515.

Would it help if I ran the same commands with the same drive and computer, but with Linux Lite v5.8?

Thank you for your replies!

Do you use wifi or ethernet?

Thank you for you reply. It does not seem like one specific service is the problem:

--- Code: ---linux  ~  systemd-analyze blame
6min 20.360s networking.service
3min 20.178s rc-local.service
1min 55.957s gpu-manager.service
1min 35.868s nmbd.service
1min 33.907s blueman-mechanism.service
1min 30.049s smbd.service
1min 28.598s networkd-dispatcher.service
1min 16.578s systemd-resolved.service
1min 10.434s NetworkManager.service
     53.107s rsyslog.service
     47.916s packagekit.service
     45.693s update-notifier-download.service
     35.826s bluetooth.service
     32.628s secureboot-db.service
     32.242s systemd-udev-settle.service
     31.989s dev-sda4.device
     31.712s cups.service
     31.026s dev-loop0.device
     29.983s systemd-journal-flush.service
     29.139s NetworkManager-wait-online.service
     28.943s WolfLandBuilder-firstboot.service
     28.567s alsa-restore.service
     28.560s casper-md5check.service
--- End code ---

--- Code: --- linux  ~  systemd-analyze critical-chain
The time when unit became active or started is printed after the "@" character.
The time the unit took to start is printed after the "+" character. @10min 16.217s
└─ @10min 16.217s
  └─plymouth-quit-wait.service @10min 16.216s +1ms
    └─rc-local.service @6min 56.037s +3min 20.178s
      └─ @6min 56.031s
        └─ @6min 56.031s
          └─wpa_supplicant.service @4min 5.645s +2ms
            └─dbus.service @1min 10.133s
              └─ @1min 7.212s
                └─ @1min 7.212s
                  └─uuidd.socket @1min 7.212s
                    └─ @1min 5.702s
                      └─systemd-journald.service @9min 53.578s +16.198s
                        └─systemd-journald.socket @1.309s
                          └─-.mount @1.298s
                            └─-.slice @1.298s

--- End code ---

And this is a benchmark of the usb-data partition:

I'm not sure what that bottom spike at the beginning is, perhaps the boot process wasn't totally over when I launched the benchmark.

Use systemd analyze blame to check boot.

Greetings, Jerry & all!

I've recently installed a persistent Linux Lite v6.0 on a USB 2.0 thumb drive recently, using this tutorial. I had v5.8 on it before and it worked great! But with v6.0... it appears to be much, much slower, to the point of not being really usable. I then tried it again with a USB 3.0 drive, and I cannot see much of an improvement on this 10th gen i5 laptop:

* a solid 15 minutes boot time
* prompts for unresponsive applications when all I did was click the X to close them
* ~1h15 to download ~800 MB of updates on a 40 MBps connection, and 16% install progress after another hourMy thoughts are currently:

* Was there a change from version 5 to 6 that could explain such a difference?
* There's new options when using mkusb since the tutorial was made. Could one of them make the USB drive slower for a persistence purpose?
* Am I doing something wrong or having unrealistic expectations?I tested my USB thumb drive before using mkusb on it. On my desktop Linux Lite v6.0 installation, it took about 10 seconds to copy 1 GB of files to the FAT32 system that was on it then. Also, the laptop's USB port I'm using has 'SS' right next to it.

Any help would be very welcome! Thank you for reading and please have a nice day.


[0] Message Index

[*] Previous page

Go to full version