You are Here:
Linux Lite 6.6 FINAL Released - Support for 22 Languages Added - See Release Announcement Section



Time and date is not working properly

Author (Read 9983 times)

0 Members and 1 Guest are viewing this topic.

Re: Time and date is not working properly
« Reply #10 on: June 11, 2023, 12:21:47 AM »
 

Muhammad Umar Farooq

  • New to Forums
  • *
  • 36
    Posts
  • Reputation: 0
    • View Profile
Dear Sir,

Thanks a lot  of you for teaching me for resolution of time discrepancy. 

 

Re: Time and date is not working properly
« Reply #9 on: June 10, 2023, 08:41:50 AM »
 

stevef

  • Global Moderator
  • Gold Level Poster
  • *****
  • 749
    Posts
  • Reputation: 141
  • Linux Lite Member
    • View Profile

  • CPU: Intel Core i5-4460

  • MEMORY: 16Gb

  • Kernel: 5.x
At the moment, the BIOS clock looks like it is set to local time.
Adjust the BIOS clock so that it shows UTC time instead of local time.

The link will show what UTC time is if you need to check.

Once BIOS clock matches UTC, the Linux system will factor in the timezone setting and you should see the correct time for your region when the system is booted.
clueless
 

Re: Time and date is not working properly
« Reply #8 on: June 10, 2023, 05:58:20 AM »
 

Muhammad Umar Farooq

  • New to Forums
  • *
  • 36
    Posts
  • Reputation: 0
    • View Profile
Dear sir,

I have checked my bios setting there is no option RTC OR UTC except date and time. Secondly, I could not add UTC because I did not know much much more iT solution. Kindly, guide me if I can do at my end by scripting command line etc.

Or there is only solution for me to before start my routine work to adjust time manually in system and go on.
 

Re: Time and date is not working properly
« Reply #7 on: June 08, 2023, 03:34:39 AM »
 

stevef

  • Global Moderator
  • Gold Level Poster
  • *****
  • 749
    Posts
  • Reputation: 141
  • Linux Lite Member
    • View Profile

  • CPU: Intel Core i5-4460

  • MEMORY: 16Gb

  • Kernel: 5.x
Your system is set to interpret the BIOS clock as UTC and is offsetting the system clock for the time zone which means your system clock shows as incorrect.

Try setting your BIOS clock to UTC.

You can get UTC from sites like this.

https://www.utctime.net/
clueless
 

Re: Time and date is not working properly
« Reply #6 on: June 08, 2023, 01:29:36 AM »
 

Muhammad Umar Farooq

  • New to Forums
  • *
  • 36
    Posts
  • Reputation: 0
    • View Profile
Dear Sir/Madam,

I had already set local time in Bios and that is working normally. Now i have applied command according to your suggestion  and got the following message;-
"file:///home/linuxlite-umar/Desktop/Screenshot_2023-06-08_02-07-21.png
 
Hope, the above file may assist you to understand my problem.
Welcome to Linux Lite 6.4 linuxlite-umar
 
Thursday 08 June 2023, 03:26:40
Memory Usage: 1259/3834MB (32.84%)
Disk Usage: 19/292GB (7%)
Support - https://www.linuxliteos.com/forums/ (Right click, Open Link)
 
 linuxlite-umar  ~  timedatectl
               Local time: Thu 2023-06-08 03:26:56 PKT
           Universal time: Wed 2023-06-07 22:26:56 UTC
                 RTC time: Wed 2023-06-07 22:26:56
                Time zone: Asia/Karachi (PKT, +0500)
System clock synchronized: no
              NTP service: n/a
          RTC in local TZ: no
 linuxlite-umar  ~  
 

Re: Time and date is not working properly
« Reply #5 on: June 08, 2023, 01:27:43 AM »
 

stevef

  • Global Moderator
  • Gold Level Poster
  • *****
  • 749
    Posts
  • Reputation: 141
  • Linux Lite Member
    • View Profile

  • CPU: Intel Core i5-4460

  • MEMORY: 16Gb

  • Kernel: 5.x
Quote
I had already set local time in Bios and that is working normally.

This may be the problem because Linux may be expecting the BIOS RTC to be UTC and will apply an offset depending on what you set the timezone to be.

We need to see the output of the command and know what the BIOS clock is set to and your local time to be sure.
clueless
 

Re: Time and date is not working properly
« Reply #4 on: June 08, 2023, 01:12:50 AM »
 

stevef

  • Global Moderator
  • Gold Level Poster
  • *****
  • 749
    Posts
  • Reputation: 141
  • Linux Lite Member
    • View Profile

  • CPU: Intel Core i5-4460

  • MEMORY: 16Gb

  • Kernel: 5.x
That file is on your computer, so only you can see it.

To post the text into this forum, follow these instructions.
From the terminal session, highlight the text showing the command and the output, click 'edit' then 'copy'.

On this forum, click reply, then in the reply window click the insert code icon.  This is the  '#' symbol which you should see in the row above all the yellow icons above the reply window.

This should insert the words code and /code enclosed in square brackets in your reply.
Right click exactly between the two tags then paste. This should insert the text between the code tags.

Please tell us the actual time at your location when you make the reply..
clueless
 

Re: Time and date is not working properly
« Reply #3 on: June 08, 2023, 12:40:49 AM »
 

Muhammad Umar Farooq

  • New to Forums
  • *
  • 36
    Posts
  • Reputation: 0
    • View Profile
Dear Sir/Madam,

I had already set local time in Bios and that is working normally. Now i have applied command according to your suggestion  and got the following message;-
"file:///home/linuxlite-umar/Desktop/Screenshot_2023-06-08_02-07-21.png
 
Hope, the above file may assist you to understand my problem.
 

Re: Time and date is not working properly
« Reply #2 on: June 07, 2023, 10:00:46 AM »
 

stevef

  • Global Moderator
  • Gold Level Poster
  • *****
  • 749
    Posts
  • Reputation: 141
  • Linux Lite Member
    • View Profile

  • CPU: Intel Core i5-4460

  • MEMORY: 16Gb

  • Kernel: 5.x
If you can access the BIOS on your machine, next time you boot up, go to BIOS settings and note what time the hardware clock is set to.  Then let the machine boot up normally.  Open a terminal (by pressing Ctrl Alt and T together) and run this command.

Code: [Select]
timedatectl
Post back with the actual time (at your location), what the BIOS time is set at and the output of the command shown above.
clueless
 

Time and date is not working properly
« Reply #1 on: June 07, 2023, 08:37:26 AM »
 

Muhammad Umar Farooq

  • New to Forums
  • *
  • 36
    Posts
  • Reputation: 0
    • View Profile
Dear Sir/Madam,

I have installed Linux Lite 6.4 on my Lenovo Thinkpad Edge S520 and facing updates Errors which is being controlled by using time set manually. But on restart my time zone Asia/Karachi is not matching  with system. I will appreciate if someone can resolve this or guide me how to correct this problem.

Thanks with in anticipation,

« Last Edit: June 11, 2023, 01:42:01 AM by stevef »
 

 

-->
X Close Ad

Linux Lite 6.6 FINAL Released - Support for 22 Languages Added - See Release Announcement Section