Software - Support > Installing Linux Lite

SCP wont work



Running Linuxlite since two days. Works fine except SCP. SSH works, but when transmitting files to the LinuxLite host with SCP I only get a welcome message.

Syntax: scp file [email protected]:~
Output: Welcome to Linux Lite 4.0 ola
..nothing ends up on the other side.

I googled and found a lot pointing at the welcome banner interfering with scp, but no luck with getting rid of the banner (or the problem). SCP is quite common and trivial so I'm surprised that it's not working on a basic setup.

All help appreciated!

..seems like I found a workaround. Commenting out the msg at the end of the .bashrc (home/USER/.bashrc) solved it. That also get rid of the banner in ssh login but I can live with that. (Or maybe do a custom one in sshd.conf?). If anyone have a different solution, please reply.

/home/USER/.bashrc now looks like this

--- Code: ---# enable bash completion in interactive shells
if ! shopt -oq posix; then
  if [ -f /usr/share/bash-completion/bash_completion ]; then
    . /usr/share/bash-completion/bash_completion
  elif [ -f /etc/bash_completion ]; then
    . /etc/bash_completion

alias usage='du -sk * | sort -n | perl -ne '\''($s,$f)=split(m{\t});for (qw(K M G)) {if($s<1024) {printf("%.1f",$s);print "$_\t$f"; last};$s=$s/1024}'\'
alias ls="ls --color"

# Powerline
if [ -f /usr/share/powerline/bindings/bash/ ]; then
    source /usr/share/powerline/bindings/bash/

# Linux Lite Custom Terminal
LLVER=$(awk '{print}' /etc/llver)

#echo -e "Welcome to $LLVER ${USER}"
#echo " "
#date "+%A %d %B %Y, %T"
#free -m | awk 'NR==2{printf "Memory Usage: %s/%sMB (%.2f%%)\n", $3,$2,$3*100/$2 }'
#df -h | awk '$NF=="/"{printf "Disk Usage: %d/%dGB (%s)\n", $3,$2,$5}'
#echo "Support - (Right click, Open Link)"
#echo " "

--- End code ---

Thank you, although your post is nearly 4 years old your work around worked for me.  :)


[0] Message Index

Go to full version