You are Here:
Linux Lite 4.6 RC1 has been released. See the Release Announcements section for more information.



errors during update [SOLVED]

Author (Read 613 times)

0 Members and 2 Guests are viewing this topic.

errors during update [SOLVED]
« on: January 20, 2019, 02:50:28 PM »
 

Keith Buckner

  • New to Forums
  • *
  • 3
    Posts
  • Country: us
  • Reputation: 0

  • Linux Lite: 3.8 32bit

  • CPU: Intel P4 @ 2.70GHz

  • MEMORY: 4Gb

  • VIDEO CARD: nVidia GeForce 8400GS/PCIe/: 1920x1080:
Just installed 4.2 on TOshiba Satellite laptop.
Seems to run fine but I get errors during update wheather terminal update or synaptic.
sudo apt-get upgrade
Reading package lists... Done
Building dependency tree       
Reading state information... Done
You might want to run 'apt --fix-broken install' to correct these.
The following packages have unmet dependencies:
 openjdk-11-jdk : Depends: openjdk-11-jdk-headless (= 10.0.2+13-1ubuntu0.18.04.4) but 10.0.2+13-1ubuntu0.18.04.2 is installed
 openjdk-11-jdk-headless : Depends: openjdk-11-jre-headless (= 10.0.2+13-1ubuntu0.18.04.2) but 10.0.2+13-1ubuntu0.18.04.4 is installed
E: Unmet dependencies. Try 'apt --fix-broken install' with no packages (or specify a solution).
Last Edit: January 26, 2019, 11:49:33 AM by Keith Buckner
Mint 19.1 x64 Tessa-Dell-PowerEdge T310-Xeon X3430 4 Cores 2.40GHz-16GB-GeForce GT730 2GB
Mint 19.1 x64 Tessa-ASUSTek CM5571-Intel Dual Core ES5400 2.7GHz-8GB-GeForce 8400 1GB
Lite 3.8 x86-DEll Dimension 4600-Intel Pentium 4  2.80GHz-4GB-GeForce FX 5200 1GB
Mint 19 x64 Tara-ASRock K8NF4GAMD-Athlon64 Processor 2800+-2GB-GeForce GTS 450 2GB
Bodhi 3.2.1 x64-Acer Aspire 5000 Laptop-AMD Turion 64ML-30 1600MHz-1GB-SIS661
Lite 4.2 x64-Toshiba Laptop-AMD 2.2GHz-1GB
 


Re: errors during update
« Reply #1 on: January 20, 2019, 08:55:25 PM »
 

Artim

  • Lazy Slacker
  • PayPal Supporter
  • I come here a lot
  • *****
  • 317
    Posts
  • Country: us
  • Reputation: 43
  • Enough Already!
    • Confessions of a Technophobe

  • Linux Lite: 4.4 64bit

  • CPU: Intel(R) Core(TM)2 Duo CPU T7300 @ 2.00GHz

  • MEMORY: 3Gb

  • VIDEO CARD: Mobile GM965/GL960 Integrated Graphics Controller
You can open a terminal and type,
Code: [Select]
sudo apt --fix broken installThen your password when prompted.  It's normal for your password to not be visible while you are typing it, just type it and hit ENTER.  Then watch the magic!  When it's finished you'll see the colorful command prompt again, and just close that window.
Synaptic Package Manager (Menu -> System -> Add/Remove Software) has a nice graphical option to fix broken packages as well.
 

Re: errors during update
« Reply #2 on: January 20, 2019, 10:54:43 PM »
 

Keith Buckner

  • New to Forums
  • *
  • 3
    Posts
  • Country: us
  • Reputation: 0

  • Linux Lite: 3.8 32bit

  • CPU: Intel P4 @ 2.70GHz

  • MEMORY: 4Gb

  • VIDEO CARD: nVidia GeForce 8400GS/PCIe/: 1920x1080:
I tryied that as hinted in terminal, I get this.
sudo apt --fix broken install
E: Command line option --fix is not understood in combination with the other options.
Last Edit: January 20, 2019, 11:11:48 PM by Keith Buckner
Mint 19.1 x64 Tessa-Dell-PowerEdge T310-Xeon X3430 4 Cores 2.40GHz-16GB-GeForce GT730 2GB
Mint 19.1 x64 Tessa-ASUSTek CM5571-Intel Dual Core ES5400 2.7GHz-8GB-GeForce 8400 1GB
Lite 3.8 x86-DEll Dimension 4600-Intel Pentium 4  2.80GHz-4GB-GeForce FX 5200 1GB
Mint 19 x64 Tara-ASRock K8NF4GAMD-Athlon64 Processor 2800+-2GB-GeForce GTS 450 2GB
Bodhi 3.2.1 x64-Acer Aspire 5000 Laptop-AMD Turion 64ML-30 1600MHz-1GB-SIS661
Lite 4.2 x64-Toshiba Laptop-AMD 2.2GHz-1GB
 

Re: errors during update
« Reply #3 on: January 20, 2019, 11:41:31 PM »
 

Jerry

  • Linux Lite Creator
  • Administrator
  • Platinum Level Poster
  • *****
  • 6936
    Posts
  • Country: nz
  • Reputation: 642
  • Linux Lite Member
    • Linux Lite OS

  • Linux Lite: 3.8 64bit

  • CPU: Intel Xeon Dual CPU's E5645 2.4GHz 12 Cores

  • MEMORY: 16Gb

  • VIDEO CARD: nVidia GeForce GTX 960
Missing a hyphen:

Code: [Select]
sudo apt --fix-broken install
 


Tags:
 


Linux Lite 4.6 RC1 has been released. See the Release Announcements section for more information.