You are Here:
Linux Lite 7.0 RC1 Released - See Release Announcement Section



not booting with grub2

Author (Read 21504 times)

0 Members and 1 Guest are viewing this topic.

Re: not booting with grub2
« Reply #24 on: May 30, 2015, 03:24:50 AM »
 

transadd

  • New to Forums
  • *
  • 10
    Posts
  • Reputation: 3
  • Linux Lite Member
    • View Profile

  • CPU: athalon 64 x2

  • MEMORY: 3Gb

  • VIDEO CARD: nVidia 7300
As suggested I started a new thread for this "Linux Lite Grub2 fails"
 

Re: not booting with grub2
« Reply #23 on: December 05, 2014, 07:28:39 PM »
 

altman

  • Gold Level Poster
  • *******
  • 739
    Posts
  • Reputation: 43
  • Linux Lite Member
    • View Profile
Thanks altman   :)

I've used Rescatux in the past and it is a useful program. In this case, Grub is working fine for the other 4 distros in the menu. It's only when I choose LL that I am getting the filename error. I've read that if I change Grub control to LL, the issue will go away but I'm not prepared to do that at this point.

No problem , lets see what will result of future fix on your side .
HP DV7 i7 2670QM 500.1GB 8GB Ram Dual-Boot LL2.4 Beta / Extix 15.1.1 64-bit 
Dell Inspiron 1720 CrunchBang 11

Duckduckgo ( for now )
 

Re: not booting with grub2
« Reply #22 on: December 05, 2014, 06:21:30 PM »
 

gold_finger

  • Documentation Writer
  • Platinum Level Poster
  • *****
  • 1094
    Posts
  • Reputation: 325
  • Linux Lite Member
    • View Profile

  • CPU: Intel Core2 Duo E7500 3.0GHz

  • MEMORY: 4Gb

  • VIDEO CARD: Intel 4 Series Integrated Graphics
It's just a case of general principle really. There shouldn't be an issue with making any OS in charge of booting.

I tend to agree.

Don't remember the specifics, but something was changed to make dual-booting with Windows easier, or the boot menu choices more obvious, or something like that.  Big target audience for LL is new users coming from Windows and that was reason for change.  Since I haven't dual-booted with Windows in many years I have no idea what real difference the change made, but I don't remember anything particularly difficult about the setup before.

EDIT:  Just noticed that earlier in this thread I posted a link to what Jerry (aka Valtam) wrote about this.  You could try fix he suggested there if you want to keep current preferred OS booting.  https://www.linuxliteos.com/forums/index.php?topic=480.msg2431#msg2431
« Last Edit: December 05, 2014, 06:32:55 PM by gold_finger »
Try Linux Beginner Search Engine for answers to Linux questions.
 

Re: not booting with grub2
« Reply #21 on: December 05, 2014, 12:33:59 PM »
 

jordan

  • Guest
Are you hesitating to due that because you are unsure that it will work?  I don't remember what the change to LL system was (as previously described elsewhere by Jerry) that causes the error message when another OS is in charge of booting, but making LL in charge of boot process should allow booting of all OS's.

It's just a case of general principle really. There shouldn't be an issue with making any OS in charge of booting. In my case, it's usually Point Linux (Debian Wheezy based) and at times it's Sparky. But, since it doesn't really matter, I'll go ahead and let LL handle Grub.

Thanks for your reply.
 

Re: not booting with grub2
« Reply #20 on: December 05, 2014, 11:26:41 AM »
 

gold_finger

  • Documentation Writer
  • Platinum Level Poster
  • *****
  • 1094
    Posts
  • Reputation: 325
  • Linux Lite Member
    • View Profile

  • CPU: Intel Core2 Duo E7500 3.0GHz

  • MEMORY: 4Gb

  • VIDEO CARD: Intel 4 Series Integrated Graphics
I've read that if I change Grub control to LL, the issue will go away but I'm not prepared to do that at this point.

Are you hesitating to due that because you are unsure that it will work?  I don't remember what the change to LL system was (as previously described elsewhere by Jerry) that causes the error message when another OS is in charge of booting, but making LL in charge of boot process should allow booting of all OS's.

If you'd like to try, can provide instructions and also give instructions to make a backup copy of current MBR so if attempt to switch control fails you can easily restore prior boot process.


If you'd rather not have LL in control for some other reason, please let us know what the other OS's are and which one is currently in control of booting.  Maybe one of us can provide alternate solution to add LL boot option to it.
Try Linux Beginner Search Engine for answers to Linux questions.
 

Re: not booting with grub2
« Reply #19 on: December 05, 2014, 10:10:11 AM »
 

jordan

  • Guest
Thanks altman   :)

I've used Rescatux in the past and it is a useful program. In this case, Grub is working fine for the other 4 distros in the menu. It's only when I choose LL that I am getting the filename error. I've read that if I change Grub control to LL, the issue will go away but I'm not prepared to do that at this point.
 

Re: not booting with grub2
« Reply #18 on: December 04, 2014, 04:43:58 PM »
 

altman

  • Gold Level Poster
  • *******
  • 739
    Posts
  • Reputation: 43
  • Linux Lite Member
    • View Profile
One thing that I use when having Grub issues is Rescatux , download latest , burn it on an ISO , reboot and try to fix-update grub from it . It worked on my end .
HP DV7 i7 2670QM 500.1GB 8GB Ram Dual-Boot LL2.4 Beta / Extix 15.1.1 64-bit 
Dell Inspiron 1720 CrunchBang 11

Duckduckgo ( for now )
 

Re: not booting with grub2
« Reply #17 on: December 03, 2014, 11:32:06 AM »
 

jordan

  • Guest
I tried LL 2.0 when it was released and received the an error, "unexpected entry, filename incorrect" (or something similar) when choosing Linux Lite from my Grub menu which includes 4 other Linux distros and no Windows. Also, I am letting another distro control Grub.

I just yesterday installed LL 2.2 and received the identical error. Any simple (that's a relative term I know) solutions beyond allowing LL to control Grub?

Thanks in advance!  :)
« Last Edit: December 03, 2014, 11:33:39 AM by jordan »
 

Re: not booting with grub2
« Reply #16 on: June 29, 2014, 07:00:50 PM »
 

gold_finger

  • Documentation Writer
  • Platinum Level Poster
  • *****
  • 1094
    Posts
  • Reputation: 325
  • Linux Lite Member
    • View Profile

  • CPU: Intel Core2 Duo E7500 3.0GHz

  • MEMORY: 4Gb

  • VIDEO CARD: Intel 4 Series Integrated Graphics
I know I'm still learning Linux and understand what you guys are talking about, but.
LL is aimed at Windoze people to tempt them to move over to Linux and so works great at dual booting with XP or 7.
So for the intended audience it works.  I for one am very pleased with it.

Sorry Robert -- I somehow missed your post under this topic.

You are absolutely right.  It is working as it should for the target audience -- newcomers from Windows.  As Valtam explained in above referenced link, he made a slight change to eliminate an issue that had caused some confusion in the past.

I haven't bothered trying to alter grub just to keep another distro in charge of booting.  Instead, I just put Linux Lite in charge of booting and everything then works fine.  I don't really care which distro is handling the boot process, so it's no big deal.
Try Linux Beginner Search Engine for answers to Linux questions.
 

Re: not booting with grub2
« Reply #15 on: June 17, 2014, 11:08:52 AM »
 

robert

  • New to Forums
  • *
  • 45
    Posts
  • Reputation: 5
  • Linux Lite Member
    • View Profile

  • MEMORY: 2Gb
I know I'm still learning Linux and understand what you guys are talking about, but.
LL is aimed at Windoze people to tempt them to move over to Linux and so works great at dual booting with XP or 7.
So for the intended audience it works.  I for one am very pleased with it.
 

Re: not booting with grub2
« Reply #14 on: June 16, 2014, 08:56:18 PM »
 

davesurrey

  • Guest
Thanks gold_finger. I tried and couldn't get it to work as I've reported over there.
 

Re: not booting with grub2
« Reply #13 on: June 16, 2014, 01:24:16 PM »
 

gold_finger

  • Documentation Writer
  • Platinum Level Poster
  • *****
  • 1094
    Posts
  • Reputation: 325
  • Linux Lite Member
    • View Profile

  • CPU: Intel Core2 Duo E7500 3.0GHz

  • MEMORY: 4Gb

  • VIDEO CARD: Intel 4 Series Integrated Graphics
Just in case people here haven't seen, Valtam responded to this issue here:  https://www.linuxliteos.com/forums/index.php?topic=480.msg2431#msg2431.
Try Linux Beginner Search Engine for answers to Linux questions.
 

Re: not booting with grub2
« Reply #12 on: June 15, 2014, 09:42:20 AM »
 

davesurrey999

  • Guest
Hi Kirk,
Thanks for the reply.
For the record as of today I've now tried this on 3 different boxes, with 2 burns from 2 downloads and with grub2 in the mbr of Lubuntu 14.04, Linux Mint 17 and OpenMandriva 2014-kde and so I am convinced the issue is with LL 2.0.
I have done a manual entry into grub2 's 40_custom file as follows:

menuentry "Linux KLite 2.0 on sda2" {
set root=(hd0,2)
linux  (hd0,2)/boot/vmlinuz-3.13.0-24-generic  root=/dev/sda2
initrd  (hd0,2)/boot/initrd.img-3.13.0-24-generic
}
EOF

and it boots well.  :)

I hope one of the devs can sort this out one day.
Hopefully this thread will help others.
Dave
« Last Edit: June 15, 2014, 09:46:45 AM by davesurrey999 »
 

Re: not booting with grub2
« Reply #11 on: June 15, 2014, 07:31:43 AM »
 

Kirkx

  • Occasional Poster
  • **
  • 51
    Posts
  • Reputation: 10
  • Linux Lite Member
    • View Profile

  • CPU: Athlon 64 3500+ 2.2 GHz

  • MEMORY: 4Gb

  • VIDEO CARD: GeForce 8500 GT / Nvidia 340.76
In case it helps, I boot my Linux Lite v2.0 from Grub4Dos w/o any problems. I guess this way you boot the kernel directly, bypassing the file /boot/grub/grub.cfg. Here is my menu.lst from Grub4Dos:

## Grub4Dos Boot Menu

color white/blue blue/yellow red/yellow red/yellow
# timeout 30
# default 0

# title Windows XP
# chainloader (hd0,0)/ntldr

title Linux Lite (core.img)
kernel (hd0,6)/boot/grub/i386-pc/core.img

title Linux Lite (vmlinuz)
root (hd0,6)
# kernel /boot/vmlinuz-3.13.0-24-generic root=UUID=b5c7940e-453b-4eed-8d87-bb992069026c ro  splash quiet $vt_handoff
kernel /boot/vmlinuz-3.13.0-24-generic root=UUID=b5c7940e-453b-4eed-8d87-bb992069026c ro
initrd /boot/initrd.img-3.13.0-24-generic

title Reboot
reboot

title Halt
halt

Partition (hd0,6) in Grub4Dos translates to /dev/sda7 in LL.

I didn't want to have my original MBR overwritten by Grub2 so I installed it at the root partition of LL. When you look at my menu.lst you can see that I can boot to LL using either core.img or vmlinuz. I also got rid of the boot splash screen by removing the parameter "splash quiet $vt_handoff".
LL 2.4, Xubuntu 14.04.2, Debian 8, Manjaro
 

Re: not booting with grub2
« Reply #10 on: June 14, 2014, 05:22:25 PM »
 

gold_finger

  • Documentation Writer
  • Platinum Level Poster
  • *****
  • 1094
    Posts
  • Reputation: 325
  • Linux Lite Member
    • View Profile

  • CPU: Intel Core2 Duo E7500 3.0GHz

  • MEMORY: 4Gb

  • VIDEO CARD: Intel 4 Series Integrated Graphics
Okay, I don't know what the solution is but found where the problem is.  I made copies of the following files in Mint 16 (that is in control of booting) after installing LL 2.0 Final which did not boot:

/boot/grub/grub.conf
/etc/default/grub
/etc/grub.d/ (all files in this directory)

Then I re-installed LL 2.0 Beta and made copies of the exact same files in Mint 16 (which now successfully boots LL again).

I did file comparisons of the two /boot/grub/grub.conf files and found many differences.  The differences show up in the section where /etc/grub.d/30_os-prober is called and adds the entries for LL.  The two 30_os-prober file copies are identical, so what ever it is reading from the two versions of LL and entering into /boot/grub/grub.conf is different.

I've attached copies of both grub.conf files to this post.  Below is just an outline of the differences I found between the two.

Lines #200 & 201:
    Working LL 2.0 BETA -- grub.conf has this:
    linux /boot/vmlinuz-3.13.0-24-generic root=UUID=47878fc3-f171-4697-bbd8-fc706765b2bc ro quiet splash $vt_handoff
   initrd /boot/initrd.img-3.13.0-24-generic

   
   Non-working LL 2.0 Final -- grub.conf has only this:
   linux





Line #204 (BETA) vs. line #203 (Final)
    Working Beta (#204) reads:
    menuentry 'Ubuntu (on /dev/sda5)' --class gnu-linux --class gnu --class os $menuentry_id_option 'osprober-gnulinux-/boot/vmlinuz-3.13.0-24-generic--47878fc3-f171-4697-bbd8-fc706765b2bc' {

   
    Non-working Final (#203) reads:
    menuentry 'Description (on /dev/sda5)' --class gnu-linux --class gnu --class os $menuentry_id_option 'osprober-gnulinux---cd8fe027-9341-47d4-ae8f-d9cafc421c1d' {





Line #213 (BETA) vs. line #212 (Final):  similar diff. to lines 200 & 201 above.




Line #216 (BETA) vs. line #214 (Final)
    Working Beta reads:
    menuentry 'Ubuntu, with Linux 3.13.0-24-generic (on /dev/sda5)' --class gnu-linux --class gnu --class os $menuentry_id_option 'osprober-gnulinux-/boot/vmlinuz-3.13.0-24-generic--47878fc3-f171-4697-bbd8-fc706765b2bc' {

   
    Non-working Final reads:
    menuentry '/boot/initrd.img-3.13.0-24-generic (on /dev/sda5)' --class gnu-linux --class gnu --class os $menuentry_id_option 'osprober-gnulinux-root=UUID=cd8fe027-9341-47d4-ae8f-d9cafc421c1d^ro^quiet^splash^$vt_handoff--cd8fe027-9341-47d4-ae8f-d9cafc421c1d' {





Line #225 & 226 (BETA) vs. line #223 (Final)
    Working Beta reads:
    linux /boot/vmlinuz-3.13.0-24-generic root=UUID=47878fc3-f171-4697-bbd8-fc706765b2bc ro quiet splash $vt_handoff
      initrd /boot/initrd.img-3.13.0-24-generic

      
   Non-working Final reads:
   linux root=UUID=cd8fe027-9341-47d4-ae8f-d9cafc421c1d^ro^quiet^splash^$vt_handoff





Line #228 (BETA) vs. line #225 (Final)
    Working Beta reads:
    menuentry 'Ubuntu, with Linux 3.13.0-24-generic (recovery mode) (on /dev/sda5)' --class gnu-linux --class gnu --class os $menuentry_id_option 'osprober-gnulinux-/boot/vmlinuz-3.13.0-24-generic-root=UUID=47878fc3-f171-4697-bbd8-fc706765b2bc ro recovery nomodeset-47878fc3-f171-4697-bbd8-fc706765b2bc' {

   
    Non-working Final reads:
    menuentry 'Description (on /dev/sda5)' --class gnu-linux --class gnu --class os $menuentry_id_option 'osprober-gnulinux---cd8fe027-9341-47d4-ae8f-d9cafc421c1d' {





Lines #237 - 240 (BETA) vs. lines #234 - 269 (Final)
    Working Beta reads:
    linux /boot/vmlinuz-3.13.0-24-generic root=UUID=47878fc3-f171-4697-bbd8-fc706765b2bc ro recovery nomodeset
      initrd /boot/initrd.img-3.13.0-24-generic
   }
}


    Non-working Final reads:
    linux 
   }
   menuentry '/boot/initrd.img-3.13.0-24-generic (on /dev/sda5)' --class gnu-linux --class gnu --class os $menuentry_id_option 'osprober-gnulinux-root=UUID=cd8fe027-9341-47d4-ae8f-d9cafc421c1d^ro^quiet^splash^$vt_handoff--cd8fe027-9341-47d4-ae8f-d9cafc421c1d' {
      insmod part_msdos
      insmod ext2
      set root='hd0,msdos5'
      if [ x$feature_platform_search_hint = xy ]; then
        search --no-floppy --fs-uuid --set=root --hint-bios=hd0,msdos5 --hint-efi=hd0,msdos5 --hint-baremetal=ahci0,msdos5  cd8fe027-9341-47d4-ae8f-d9cafc421c1d
      else
        search --no-floppy --fs-uuid --set=root cd8fe027-9341-47d4-ae8f-d9cafc421c1d
      fi
      linux root=UUID=cd8fe027-9341-47d4-ae8f-d9cafc421c1d^ro^quiet^splash^$vt_handoff
   }
   menuentry 'Description (on /dev/sda5)' --class gnu-linux --class gnu --class os $menuentry_id_option 'osprober-gnulinux---cd8fe027-9341-47d4-ae8f-d9cafc421c1d' {
      insmod part_msdos
      insmod ext2
      set root='hd0,msdos5'
      if [ x$feature_platform_search_hint = xy ]; then
        search --no-floppy --fs-uuid --set=root --hint-bios=hd0,msdos5 --hint-efi=hd0,msdos5 --hint-baremetal=ahci0,msdos5  cd8fe027-9341-47d4-ae8f-d9cafc421c1d
      else
        search --no-floppy --fs-uuid --set=root cd8fe027-9341-47d4-ae8f-d9cafc421c1d
      fi
      linux 
   }
   menuentry '/boot/initrd.img-3.13.0-24-generic (on /dev/sda5)' --class gnu-linux --class gnu --class os $menuentry_id_option 'osprober-gnulinux-root=UUID=cd8fe027-9341-47d4-ae8f-d9cafc421c1d^ro^recovery^nomodeset--cd8fe027-9341-47d4-ae8f-d9cafc421c1d' {
      insmod part_msdos
      insmod ext2
      set root='hd0,msdos5'
      if [ x$feature_platform_search_hint = xy ]; then
        search --no-floppy --fs-uuid --set=root --hint-bios=hd0,msdos5 --hint-efi=hd0,msdos5 --hint-baremetal=ahci0,msdos5  cd8fe027-9341-47d4-ae8f-d9cafc421c1d
      else
        search --no-floppy --fs-uuid --set=root cd8fe027-9341-47d4-ae8f-d9cafc421c1d
      fi
      linux root=UUID=cd8fe027-9341-47d4-ae8f-d9cafc421c1d^ro^recovery^nomodeset
   }
}


[attachment deleted by admin, more than 25 days old]
Try Linux Beginner Search Engine for answers to Linux questions.
 

 

-->
X Close Ad

Linux Lite 7.0 RC1 Released - See Release Announcement Section