Linux Lite Forums

Software - Support => Installing Linux Lite => Topic started by: mtrerise on June 22, 2018, 12:35:20 PM

Title: Linux Lite 4.0 ISO not booting from USB drive
Post by: mtrerise on June 22, 2018, 12:35:20 PM
Hello Linux Lite forum,
I have been running the 3.x series on my computer for the past year and would like to upgrade from version 3.8 to 4.0. Version 3.8 is currently running fine but would like to upgrade to the new Ubuntu base + LL features. I recently downloaded the ISO using the torrent from the Linux Lite website. I have verified the md5 checksum of the file and ran the command 'file linux-lite-4.0-64bit.iso' which shows the ISO file is bootable. I have tried using both etcher and dd to try writing the ISO image to two different USB drives which complete successfully each time. The dd command I used was 'sudo dd if=linux-lite-4.0-64bit.iso of=/dev/sdc bs=4M' which did appear to work fine. Each time I boot to the USB drive, it shows the Linux Lite 4.0 boot screen with the available boot options, I leave the default boot option then after a few seconds it drops to a Busybox screen and stops so it never gets any further than this let alone to the live desktop. I have tested both of my USB drives with etcher and the same dd command with the xubuntu 18.04 ISO and it boots fine into the live desktop. I really want to stay with Linux Lite and get upgraded to v4.0. I am attaching three screenshots, in a .zip file, showing the md5 checksum verification, file output of the ISO, dd output after writing the image to the USB drive and finally where I end up at busybox. Please help figuring out what may be causing this to occur.
Thanks much, Mark
Title: Re: Linux Lite 4.0 ISO not booting from USB drive
Post by: Paul74 on June 23, 2018, 03:23:27 AM

I used Etcher to create my 4 GB USB key containing LL 4.0 64 bits and everything working perfectly.
But.....I use it only on an Old PC with a Legacy BIOS not UEFI.
Title: Re: Linux Lite 4.0 ISO not booting from USB drive
Post by: TMG1961 on June 23, 2018, 03:35:27 AM
Not sure if it even make sense but have you tried formatting the usb drive as fat32 and with only on partition on it? Removing all partitions first and then crate a new one. I use this as a guide line (i keep forgetting the commands) Its at the bottom of the page. (

Then use etcher to create the bootable usb drive with LL 4.0
Title: Re: Linux Lite 4.0 ISO not booting from USB drive
Post by: mtrerise on June 24, 2018, 01:30:12 AM
Thank you, Paul74 & TMG1961!

@Paul74, my PC is an older BIOS based system too, Dell Optiplex 380, with no UEFI on this system.
@TMG1961, I followed your advice and all of the steps completed fine with removing previous partitioning and creating a new partition, then formatting the USB drive as fat32. I followed the steps from the attached link to do this, which worked fine. I then used Etcher to write the Linux Lite 4.0 ISO to the USB drive and this completed successfully.
This time I decided to try booting from the USB drive using the second option down, I believe it was called "Safe Mode" and this time it showed the actual culprit of my problem.

BusyBox v1.27.2 (Ubuntu 1:1.27.2-ubuntu3) built in shell (ash)
Enter 'help' for a list of built-in commands.

(initramfs) Begin: Running /scripts/casper-premount ... done.
stdin: Not a typewriter
mount: mounting /dev/loop0 on //filesystem.squashfs failed: No such device
Can not mount /dev/loop0 (/cdrom/casper/filesystem.squashfs) on //filesystem.squashfs

So I think that there must be some sort of problem with the two USB drives I have. I will try a different one and see how it goes.

Thank you for the thoughts and suggestions I really appreciate it!
Title: Re: Linux Lite 4.0 ISO not booting from USB drive
Post by: trinidad on June 25, 2018, 08:51:59 AM
For Linux: (Use your 3.x OS) Since it's only a 4gig drive no need to write a partition. Use disk tools or gparted to zero the drive and then format to fat32. Right click on the downloaded ISO and select "write to disk" Select your USB drive and *rewrite the downloaded ISO to it. I have yet to understand why this is such a constant problem for users who already have Ubuntu or Debian Linux running, and/or while running Ubuntu or Debian Linux one would need extra software (Etcher, Unetbootin, etc.) to write Ubuntu or Debian Linux ISOs to USBs with. The write to disk function is available in the GUI from right click in Linux file managers (Thunar in this case). Puzzles me why other methods and software are so often used by Linux users. It's been so long I can't even remember when I started writing ISOs to USBs in Debian this way, maybe circa Deb 7, but I haven't had a failure for years and often re-used (zeroed and reformatted) USBs, and I've also done it in Ubuntu that way for a few years now too. I don't think its luck.

Title: Re: Linux Lite 4.0 ISO not booting from USB drive
Post by: glin22 on July 22, 2018, 02:08:46 AM
Hi, I read this thread about not being able to boot LL4.0 from USB, this is exactly what I encountered when trying to help a friend of mine install LL4.0 on his laptop. Even though I burnt a copy of LL4.0 on his USB drive using Etcher, it just would not show up in the boot menu so I could then install it for him. I burnt a different Linux distro  to see if that did the same thing, no ! it came right up. So, I am assuming this other distro doesn't have issues with the UEFI mode.

He has a Galago Pro with Ubuntu 18.04 on it but I'd really like to see him being able to use LL4.0 instead of that. But I don't know if a Galago pro has a choice where you can choose Legacy mode or if one is forced to use UEFI only.

Are there any workarounds ? Or does the Galago Pro force UEFI mode ? I'd really hope there is some way to get LL4.0 on his laptop, it'd be a shame if he can't do that.

Thanks for any ideas, or suggestions,

Title: Re: Linux Lite 4.0 ISO not booting from USB drive
Post by: mtrerise on July 22, 2018, 10:23:46 PM
It's been about a month since I've posted an update on this thread and thought it would be good to do now. I really appreciate everyone's input, thoughts and advice regarding this. Unfortunately, I still have not been able to get past this issue. Interestingly, I found the same exact issue occurs with some other Ubuntu 18.04 based distributions like Peppermint 9, however Linux Mint 19, mainline Ubuntu, Ubuntu Mate and Xubuntu 18.04 all booted from USB and worked fine. I am wondering if there is something related to booting the new LL4.0 ISO on a legacy BIOS based mainboard, like mine, vs. UEFI based systems, where some legacy BIOS systems may not work. Since this was my main computer, I couldn't continue being down for days and troubleshooting why Linux Lite 4.0 would not boot up and let me install it, so I have moved on to a different distribution for now. I am still a fan of Linux Lite but for now I'm just not able to run it.

@trinidad, thank you for your suggestions, I did try exactly as you said, the writing of the LL4.0 ISO completed successfully directly from within Thunar, unfortunately I ended up with the same results. For disclosure purposes, I tried using Etcher etc. because after encountering this issue using my normal method of using dd, fdisk and wipefs not working, I decided I needed to possibly find a different way and to see if I could determine what was causing the issue. I found the suggestion on Linux Lite's website of trying Etcher to create a bootable ISO to install from.

@glin22, unfortunately I wasn't able to get past this issue with Linux Lite 4.0 for now, so I am using a new distro for now. I am a little curious of the new ISO and legacy BIOS based systems vs. UEFI systems and if there is something related to this causing problems. In my case I have a legacy BIOS based system, which I even updated my BIOS to the latest available version from the manufacturer. One thing I didn't try was using a brand new USB flash drive so that may be worth a shot. Unfortunately, I don't have any other suggestions on how to fix this.

Thanks again everyone!

Title: Re: Linux Lite 4.0 ISO not booting from USB drive
Post by: Paul74 on July 31, 2018, 02:41:04 AM

May I'm a little bit late to reply to this post....

I installed LL 4.0 on a Dell Optiflex 760 (Vista machine previously !!!) with an ald BIOS. And I used the same USB key I used for another install.
I didn't change BIOS, just suppressed UEFI entry to use Legacy.
I connected a 120 GB SSD and a PCI-E card, without anqy problem.
LL 4.0 installation was very straight forward, in less than 15 minutes, LL 4.0 was booting on the SSD.

But......I try to use this ame USB key to install LL 4.0 on an ASUS PC (previously with Win7) and was unable to boot from !
I had to change some BIOS option to completely remove UEFI and it takes some time to achieve.

So, if you cannnot boot using USB key, first issue is to ran thru BIOS options.

Title: Re: Linux Lite 4.0 ISO not booting from USB drive
Post by: kpanic on August 20, 2018, 06:51:54 PM
Hi @mtrerise ,

Try dd again but without 'bs=4M'