Software - Support > Installing Linux Lite

Lenovo IdeaPad-3-15IIL05 No touchpad

(1/4) > >>

Hi trinidad
                 Great news.....   The touch pad is now working....  A big thank you for that link...
Here is the solution to the problem....

Open a Terminal window (Ctrl-Alt-T), then copy-and-paste the following three command-lines, one by one...

Code: Select all

G=/etc/default/grub;sudo cp $G{,.`date +%F.%s`} # add "i8042.nopnp=1 pci=nocrs"
sed 's/i8042.nopnp=1 pci=nocrs//' $G|tr -s ' '|sudo dd of=$G 2>/dev/null
sudo sed -i 's/GRUB_CMDLINE_LINUX_DEFAULT="/&i8042.nopnp=1 pci=nocrs /' $G&&sudo update-grub

Reboot your laptop.

I also want to thank all the other people who have tried to sort this Bug/problem......
Much gratitude and appreciation to all
Now i can fully enjoy the outstanding Linux Lite OS


A little more info for you. Read through the second link to understand that this is hardware bug with Lenovo caused by its use of an archaic PS/2 chip to handle input devices. Turning off multiplex detection may solve it for you.


Hi Mountain Giant
                                   After i read both your suggestions to try.....   I downloaded them both....    Unfortunately both of them again did not work with the touchpad ... But works perfectly with a mouse...
As a shot in the dark....  I also even tried the Puppy Linux......   Again no touch pad....   But it did say.....  "synaptics not found" 
I have not given up.....   There is an solution out there...


Mountain Giant:
Try Fedora and OpenSuSe tubleweed. You tested debian and arch, so that is 2 unique linux distro left.

Hi WytWun
                 I have also tried Manjaro which is Arch based.....   Sadly the touch pad did not work.....
I am positive there is a solution to this....It is just finding it.....  There must be others out there with same laptop running Linux OS not using a mouse all the time..
For many many years i have used Linux Lite on many Lenovo laptops which have very stable and reliable.... 
Thank you for your comments how to solve this......   Looking forward to tagging this as solved on this forum to help others...



[0] Message Index

[#] Next page

Go to full version