You are Here:
Linux Lite 6.6 FINAL Released - Support for 22 Languages Added - See Release Announcement Section



Install updates Pub Key

Author (Read 4706 times)

0 Members and 1 Guest are viewing this topic.

Re: Install updates Pub Key
« Reply #8 on: March 15, 2022, 06:07:44 PM »
 

firenice03

  • Rockin' the FREE World
  • Global Moderator
  • Platinum Level Poster
  • *****
  • 1848
    Posts
  • Reputation: 284
  • Linux Lite Member
    • View Profile

  • CPU: AMD E2//Atom X5//AMD Phenom II X2

  • MEMORY: 4Gb

  • VIDEO CARD: AMD Mullin Radeon R2//Intel//AMD/ATI RS880

  • Kernel: 5.x
@triwiwer


The previous page suggests: https://www.duinsoft.nl/packages.php?t=en


RepositoryThe repository provides a Debian package with the script and the same support files as in the support tarball. Setting things up is a bit more work, but the script will be properly integrated in your system. Additional advantages: a possibly installed out-of-date sun-java6 installation will be removed completely and if you keep the software source in your list, you will automatically receive updates of the script. The procedure:
  • put the line
    deb https://duinsoft.nl/pkg debs all
    in the file /etc/apt/sources.list, either using Software Sources from your System Menu or by editing the file in an editor (as root)
    or:
    put this line in a file named (e.g.) duinsoft.list in the directory /etc/apt/sources.list.d
  • import the gpg key with the command (all on one line but with a space before https)
    sudo wget -P /etc/apt/trusted.gpg.d/ https://duinsoft.nl/pkg/duinsoft.key.asc
  • enter the commands (two lines)
    sudo apt-get update
    sudo apt-get install update-sun-jre
    or use Synaptic to install the package
  • installation of the Runtime Environment will follow automatically
Using the script apt-add-repository -available for Ubuntu- is not advisable because that script makes a few incorrect assumptions.
The key server keys.gnupg.net mentioned above is just an example. You can use any reliable key server. If the apt-key command produces an error, try one of the servers from this page. (Above Link)

So I'd assume..
Code: [Select]
sudo apt-key adv --keyserver pgp.surfnet.nl --recv-keys E18CE6625CB26B26

Code: [Select]
sudo apt-key adv --keyserver OTHER_from_LIST --recv-keys E18CE6625CB26B26
LL4.8 UEFI 64 bit ASUS E402W - AMD E2 (Quad) 1.5Ghz  - 4GB - AMD Mullins Radeon R2
LL5.8 UEFI 64 bit Test UEFI Kangaroo (Mobile Desktop) - Atom X5-Z8500 1.44Ghz - 2GB - Intel HD Graphics
LL4.8 64 bit HP 6005- AMD Phenom II X2 - 8GB - AMD/ATI RS880 (HD4200)
LL3.8 32 bit Dell Inspiron Mini - Atom N270 1.6Ghz - 1GB - Intel Mobile 945GSE Express  -- Shelved
BACK LL5.8 64 bit Dell Optiplex 160 (Thin) - Atom 230 1.6Ghz - 4GB-SiS 771/671 PCIE VGA - Print Server
Running Linux Lite since LL2.2
 

Re: Install updates Pub Key
« Reply #7 on: March 15, 2022, 05:37:35 PM »
 

triwiwer

  • New to Forums
  • *
  • 4
    Posts
  • Reputation: 0
  • Linux Lite Member
    • View Profile
@firenice03  thanks for the link. Do you have by any chance a line i can enter in terminal that would change the server?

Thanks again.
 

Re: Install updates Pub Key
« Reply #6 on: March 15, 2022, 05:31:54 PM »
 

firenice03

  • Rockin' the FREE World
  • Global Moderator
  • Platinum Level Poster
  • *****
  • 1848
    Posts
  • Reputation: 284
  • Linux Lite Member
    • View Profile

  • CPU: AMD E2//Atom X5//AMD Phenom II X2

  • MEMORY: 4Gb

  • VIDEO CARD: AMD Mullin Radeon R2//Intel//AMD/ATI RS880

  • Kernel: 5.x
@triwiwer

See update..
UPDATE..
See this link for other key servers vs. keyserver.ubuntu.com
https://www.duinsoft.nl/keyservers.php?t=en
LL4.8 UEFI 64 bit ASUS E402W - AMD E2 (Quad) 1.5Ghz  - 4GB - AMD Mullins Radeon R2
LL5.8 UEFI 64 bit Test UEFI Kangaroo (Mobile Desktop) - Atom X5-Z8500 1.44Ghz - 2GB - Intel HD Graphics
LL4.8 64 bit HP 6005- AMD Phenom II X2 - 8GB - AMD/ATI RS880 (HD4200)
LL3.8 32 bit Dell Inspiron Mini - Atom N270 1.6Ghz - 1GB - Intel Mobile 945GSE Express  -- Shelved
BACK LL5.8 64 bit Dell Optiplex 160 (Thin) - Atom 230 1.6Ghz - 4GB-SiS 771/671 PCIE VGA - Print Server
Running Linux Lite since LL2.2
 

Re: Install updates Pub Key
« Reply #5 on: March 15, 2022, 05:29:37 PM »
 

triwiwer

  • New to Forums
  • *
  • 4
    Posts
  • Reputation: 0
  • Linux Lite Member
    • View Profile
@firenice03
I'm a private user. And i don't run firewall.
I might tried few things found on google, but nothing helped. So maybe i made things worse.  :022: :022:
Thanks for helping!

« Last Edit: March 15, 2022, 05:31:15 PM by triwiwer »
 

Re: Install updates Pub Key
« Reply #4 on: March 15, 2022, 05:22:40 PM »
 

firenice03

  • Rockin' the FREE World
  • Global Moderator
  • Platinum Level Poster
  • *****
  • 1848
    Posts
  • Reputation: 284
  • Linux Lite Member
    • View Profile

  • CPU: AMD E2//Atom X5//AMD Phenom II X2

  • MEMORY: 4Gb

  • VIDEO CARD: AMD Mullin Radeon R2//Intel//AMD/ATI RS880

  • Kernel: 5.x
@triwiwer

Also looks like a couple other errors once the key is accepted..
Remove the "old Ubuntu" repo
Code: [Select]
Err:10 http://old-releases.ubuntu.com/ubuntu focal-security Release
  404  Not Found [IP: 91.189.91.124 80]


and
The multiple repos configured multiple times


Code: [Select]
is configured multiple times in /etc/apt/sources.list

You could be able to edit the /etc/apt/sources.list as administrator (file manager)

- I'll check the key - are you on a corporate network or behind a firewall?




UPDATE..
See this link for other key servers vs. keyserver.ubuntu.com
https://www.duinsoft.nl/keyservers.php?t=en
« Last Edit: March 15, 2022, 05:31:04 PM by firenice03 »
LL4.8 UEFI 64 bit ASUS E402W - AMD E2 (Quad) 1.5Ghz  - 4GB - AMD Mullins Radeon R2
LL5.8 UEFI 64 bit Test UEFI Kangaroo (Mobile Desktop) - Atom X5-Z8500 1.44Ghz - 2GB - Intel HD Graphics
LL4.8 64 bit HP 6005- AMD Phenom II X2 - 8GB - AMD/ATI RS880 (HD4200)
LL3.8 32 bit Dell Inspiron Mini - Atom N270 1.6Ghz - 1GB - Intel Mobile 945GSE Express  -- Shelved
BACK LL5.8 64 bit Dell Optiplex 160 (Thin) - Atom 230 1.6Ghz - 4GB-SiS 771/671 PCIE VGA - Print Server
Running Linux Lite since LL2.2
 

Re: Install updates Pub Key
« Reply #3 on: March 15, 2022, 05:08:08 PM »
 

triwiwer

  • New to Forums
  • *
  • 4
    Posts
  • Reputation: 0
  • Linux Lite Member
    • View Profile
Thanks, but i tried that and what i get is:

pollypocket  ~  sudo apt-key adv --keyserver keyserver.ubuntu.com --recv-keys E18CE6625CB26B26
Executing: /tmp/apt-key-gpghome.G10W497IRA/gpg.1.sh --keyserver keyserver.ubuntu.com --recv-keys E18CE6625CB26B26
gpg: key E18CE6625CB26B26: "Duinsoft Packages <[email protected]>" not changed
gpg: Total number processed: 1
gpg:              unchanged: 1


and error still shows when i run update.

Im kind of new to linux.
 :dft009: :dft009:
 

Re: Install updates Pub Key
« Reply #2 on: March 15, 2022, 04:41:51 PM »
 

firenice03

  • Rockin' the FREE World
  • Global Moderator
  • Platinum Level Poster
  • *****
  • 1848
    Posts
  • Reputation: 284
  • Linux Lite Member
    • View Profile

  • CPU: AMD E2//Atom X5//AMD Phenom II X2

  • MEMORY: 4Gb

  • VIDEO CARD: AMD Mullin Radeon R2//Intel//AMD/ATI RS880

  • Kernel: 5.x
@triwiwer
Split Topic

Yours is a different error - different solution..
the No_Pubkey error can be resolved as follows..

Open Terminal paste the following:

Code: [Select]
sudo apt-key adv --keyserver keyserver.ubuntu.com --recv-keys E18CE6625CB26B26
LL4.8 UEFI 64 bit ASUS E402W - AMD E2 (Quad) 1.5Ghz  - 4GB - AMD Mullins Radeon R2
LL5.8 UEFI 64 bit Test UEFI Kangaroo (Mobile Desktop) - Atom X5-Z8500 1.44Ghz - 2GB - Intel HD Graphics
LL4.8 64 bit HP 6005- AMD Phenom II X2 - 8GB - AMD/ATI RS880 (HD4200)
LL3.8 32 bit Dell Inspiron Mini - Atom N270 1.6Ghz - 1GB - Intel Mobile 945GSE Express  -- Shelved
BACK LL5.8 64 bit Dell Optiplex 160 (Thin) - Atom 230 1.6Ghz - 4GB-SiS 771/671 PCIE VGA - Print Server
Running Linux Lite since LL2.2
 

Install updates Pub Key
« Reply #1 on: March 15, 2022, 03:53:28 PM »
 

triwiwer

  • New to Forums
  • *
  • 4
    Posts
  • Reputation: 0
  • Linux Lite Member
    • View Profile
I tried the method on other tread, but i still get error.


===========================
Install Updates Error log
===========================
Install Updates could not fetch the package cache information lists.
Go to https://www.linuxliteos.com/forums/ and paste the log below into a new or existing thread for assistance.

============ Log ===========

Err:1 http://us.old-releases.ubuntu.com/ubuntu focal InRelease
  Could not resolve 'us.old-releases.ubuntu.com'
Err:2 http://us.old-releases.ubuntu.com/ubuntu focal-updates InRelease
  Could not resolve 'us.old-releases.ubuntu.com'
Err:3 http://us.old-releases.ubuntu.com/ubuntu focal-backports InRelease
  Could not resolve 'us.old-releases.ubuntu.com'
Hit:5 https://linux.teamviewer.com/deb stable InRelease
Hit:6 https://brave-browser-apt-release.s3.brave.com stable InRelease
Hit:7 http://archive.canonical.com/ubuntu focal InRelease
Ign:8 http://old-releases.ubuntu.com/ubuntu focal-security InRelease
Hit:9 http://repo.linuxliteos.com/linuxlite emerald InRelease
Get:4 https://www.duinsoft.nl/pkg debs InRelease [12,7 kB]
Err:10 http://old-releases.ubuntu.com/ubuntu focal-security Release
  404  Not Found [IP: 91.189.91.124 80]
Err:4 https://www.duinsoft.nl/pkg debs InRelease
  The following signatures couldn't be verified because the public key is not available: NO_PUBKEY E18CE6625CB26B26
Reading package lists...
E: The repository 'http://old-releases.ubuntu.com/ubuntu focal-security Release' does not have a Release file.
W: GPG error: https://www.duinsoft.nl/pkg debs InRelease: The following signatures couldn't be verified because the public key is not available: NO_PUBKEY E18CE6625CB26B26
E: The repository 'http://www.duinsoft.nl/pkg debs InRelease' is not signed.
W: Target Packages (all/binary-amd64/Packages) is configured multiple times in /etc/apt/sources.list:55 and /etc/apt/sources.list:56
W: Target Packages (all/binary-i386/Packages) is configured multiple times in /etc/apt/sources.list:55 and /etc/apt/sources.list:56
W: Target Packages (all/binary-all/Packages) is configured multiple times in /etc/apt/sources.list:55 and /etc/apt/sources.list:56
W: Target Translations (all/i18n/Translation-en_US) is configured multiple times in /etc/apt/sources.list:55 and /etc/apt/sources.list:56
W: Target Translations (all/i18n/Translation-en) is configured multiple times in /etc/apt/sources.list:55 and /etc/apt/sources.list:56
W: Target CNF (all/cnf/Commands-amd64) is configured multiple times in /etc/apt/sources.list:55 and /etc/apt/sources.list:56
W: Target CNF (all/cnf/Commands-all) is configured multiple times in /etc/apt/sources.list:55 and /etc/apt/sources.list:56
« Last Edit: March 22, 2022, 06:22:31 PM by firenice03 »
 

 

-->
X Close Ad

Linux Lite 6.6 FINAL Released - Support for 22 Languages Added - See Release Announcement Section