Software - Support > Installing Linux Lite

How to install LL but keep /home

(1/2) > >>

llmojo:
Hello everyone

My laptop runs Linux Mint right now. On one partition is the OS(30gib) on an other is /home(200gib)

As a backup i made copies on my homefolder to an external SSD drive and  created a bootable USB-Stick with LinuxLite

What i want is to delite the OS partition and install linux lite insted
How can i keep the home partition?

firenice03:
@llmojo
If as you show have /home on a separate partition, when installing LL choose the "Something Else" option.
You would reformat root "/" but leave /home as is.

The caveat - is you'll possibly be reusing some files from 2 OS's ... You could run into problems - I would move these files to another folder - specifically any files with a "." in front of the name, that are in your home directory... thus allowing LL to create as needed...

llmojo:
Hello firenice03

I tried it as you have written. After the installationi removed the  LiveUSBstick. After a reboot only a hardwaretest runs and at the end it says:

--- Quote ---No bootable devices were found! Possible causes could be a corrupt OS image or a boot device is not enabled in BIOS setup
--- End quote ---

the Laptop is a DellPrecision5510. If i press F2 while it boots it opens the ? UEFI or BIOS mode. It is not written there
wat mod it is.

At Settings -> General -> Boot Sequence ther is a Boot List Option switch with Legacy and UEFI
standard is UEFI. on the right side is a button "Add Boot Option". if i press it says
--- Quote ---File System Not Found!
--- End quote ---

I changed it to Legacy mode and it boots currect. But me /home is emty.

So it worked but not as i expected

firenice03:
So did LL install as BIOS? sound like it may and the old os was UEFI...

Makes sence why home isn't there if so...
I'm not at my pc but don't think its end of the world.

Boot up LL so its working.. confirm if bios or uefi, there are instruction on how to confirm.
 Also post the output of lsblk to ensure its not attached as it may need mounted

firenice03:
@llmojo

If you're unsure how to confirm which BIOS LL is installed to (UEFI or Legacy BIOS) you can run the following command - it looks for the telltale efi directory..

--- Code: ---[ -d /sys/firmware/efi ] && echo "EFI boot on HDD" || echo "Legacy boot on HDD"
--- End code ---

Again we'll want to confirm whether /home is attached..

--- Code: ---lsblk
--- End code ---

You could 'ls /home' to ensure its a blank/empty directory - it may not have gotten recognized - it may have needed the label "/home" reused or reentered at time of install...

You can also use gparted to view partitions. As we'll need the filesystem.. "/sdX#" i.e. /sda2 or /sdb1 etc..


IF...everything is seen by the OS or attached - then it should be easily mounted to LL ...
IF... the partition isn't seen by LL or cannot be mounted, it may be installed to the opposing BIOS - I don't see this being the case - as its not the OS and its not booting...


I really see that the problem being during the install the home partition didnt have the "/home" label (my guess)..


 

Navigation

[0] Message Index

[#] Next page

Go to full version