You are Here:
Linux Lite 4.4 Final has been released. See the Release Announcements section for more information.



[ SOLVED ] Error while installing updates

Author (Read 11318 times)

0 Members and 2 Guests are viewing this topic.

Error while installing updates
« on: March 11, 2016, 10:14:54 AM »
 

ayman

  • New to Forums
  • *
  • 11
    Posts
  • Country: 00
  • Reputation: 2
  • Linux Lite Member

  • Linux Lite: 3.2 64bit

  • CPU: Intel(R) Pentium(R) CPU 2020M @ 2.40GHz

  • MEMORY: 4Gb

  • VIDEO CARD: Intel Corporation 3rd Gen Core processor Graphics Controller Sound Card:
Error message while in installing updates
Message
" couldn't fetch the package cache information lists."

any advise ?
Last Edit: March 26, 2016, 07:02:00 PM by Jerry
 


Re: Error while installing updates
« Reply #1 on: March 11, 2016, 10:31:37 AM »
 

torreydale

  • PayPal Supporter
  • Platinum Level Poster
  • *****
  • 1457
    Posts
  • Country: us
  • Reputation: 231
  • * Forum Moderator *

  • Linux Lite: 4.4 64bit

  • CPU: Intel Core i5-5300U (-HT-MCP-)

  • MEMORY: 8Gb

  • VIDEO CARD: Intel Broadwell-U Integrated Graphics
Last Edit: March 11, 2016, 10:35:25 AM by torreydale
Want to thank me?  Click my [Thank] link.
 

Re: Error while installing updates
« Reply #2 on: March 12, 2016, 03:21:51 AM »
 

dmitry

  • New to Forums
  • *
  • 17
    Posts
  • Country: ru
  • Reputation: 3
  • Linux Lite Member

  • Linux Lite: 3.2 64bit

  • CPU: Intel Pentium N3700

  • MEMORY: 4Gb

  • VIDEO CARD: Intel HD Graphics
Error message while in installing updates
Message
" couldn't fetch the package cache information lists."

any advise ?

The same situation in Install update & Lite Software. "couldn't fetch the package cache information lists." Google Chrome not installed. apt-get update & apt-get upgrade works.
 

Re: Error while installing updates
« Reply #3 on: March 12, 2016, 10:07:45 AM »
 

paul1149

  • PayPal Supporter
  • I come here a lot
  • *****
  • 316
    Posts
  • Country: us
  • Reputation: 42
  • Enjoying Linux

  • Linux Lite: 3.6 64bit

  • CPU: C2D

  • MEMORY: 6Gb

  • VIDEO CARD: nVidia
I just had this too on one unit. I went to Synaptics and found a broken package - libreoffice gtk3. I removed the package completely, then did a 'sudo apt-get clean && apt-get install', and that seems to have fixed the problem. Subsequently I was able to upgrade both LL and LO.
 

Re: Error while installing updates
« Reply #4 on: March 12, 2016, 12:49:10 PM »
 

ihinkican

  • New to Forums
  • *
  • 11
    Posts
  • Reputation: 2
  • Linux Lite Member

  • Linux Lite: 2.6 64bit

  • CPU: dell-e521

  • MEMORY: 3Gb

  • VIDEO CARD: wha
My solution to install updates error " couldn't fetch the package cache information lists  " is to

open the package manager ( menu/system/install/remove software ) and click reload.

It will give error but list the problematic sources. note the sources. click settings/repositories/other software, scroll down and uncheck the problem sources then reload.

this should be successful, then try menu favorites/install updates and then try /system/ lite software

for me it was google chrome, google talkplus and another linux lite trusty?I can not recall
 

Re: Error while installing updates
« Reply #5 on: March 12, 2016, 01:12:30 PM »
 

dmitry

  • New to Forums
  • *
  • 17
    Posts
  • Country: ru
  • Reputation: 3
  • Linux Lite Member

  • Linux Lite: 3.2 64bit

  • CPU: Intel Pentium N3700

  • MEMORY: 4Gb

  • VIDEO CARD: Intel HD Graphics
My solution to install updates error " couldn't fetch the package cache information lists  " is to

open the package manager ( menu/system/install/remove software ) and click reload.

It will give error but list the problematic sources. note the sources. click settings/repositories/other software, scroll down and uncheck the problem sources then reload.

this should be successful, then try menu favorites/install updates and then try /system/ lite software

for me it was google chrome, google talkplus and another linux lite trusty?I can not recall

Thanks! Now all OK! [Solved]
 

Re: Error while installing updates
« Reply #6 on: March 12, 2016, 02:12:10 PM »
 

tomt

  • PayPal Supporter
  • Forum Regular
  • *****
  • 129
    Posts
  • Country: us
  • Reputation: 13

  • Linux Lite: 3.4 64bit

  • MEMORY: 8Gb
I had the same problem on a fresh install. I could not even install updates after the installation was finished. I tried to install from Lite software, did not work. Install updates did not work. The way I solved it was to click on Firefox and download Google Chrome and install, then scroll down the menu and click on "preferred applications" and selected 
Chrome or Chromium does not matter whether you have Chrome or Chromium, they are both the same based browser.
I then rebooted and was able to do all of the above.
 

Re: Error while installing updates
« Reply #7 on: May 02, 2016, 02:52:12 PM »
 

Ray H

  • New to Forums
  • *
  • 5
    Posts
  • Reputation: 0
  • Linux Lite Member

  • Linux Lite: 2.8 32bit
My solution to install updates error " couldn't fetch the package cache information lists  " is to

open the package manager ( menu/system/install/remove software ) and click reload.

It will give error but list the problematic sources. note the sources. click settings/repositories/other software, scroll down and uncheck the problem sources then reload.

this should be successful, then try menu favorites/install updates and then try /system/ lite software

for me it was google chrome, google talkplus and another linux lite trusty?I can not recall

Thanks ihinkican,

after installing LL for the first time I got that error message when I tried to run updates.  Followed your instructions, (I had the 'google' ones listed as problems) and everything worked fine after that, got all the updates. :)
 

Re: Error while installing updates
« Reply #8 on: July 28, 2016, 04:30:50 AM »
 

Bepo

  • New to Forums
  • *
  • 2
    Posts
  • Country: 00
  • Reputation: 1
  • Linux Lite Member

  • Linux Lite: 3.0 64bit

  • CPU: Intel Core i5-6300U

  • MEMORY: 2Gb
Just want to give my two pence to the solution. :-)

I couldn't open Synaptic. I had to login as superuser to the Terminal and run
Code: [Select]
dkpg --configure -a
After that I was able to update.
 

Re: Error while installing updates
« Reply #9 on: March 13, 2017, 12:02:00 PM »
 

ayman

  • New to Forums
  • *
  • 11
    Posts
  • Country: 00
  • Reputation: 2
  • Linux Lite Member

  • Linux Lite: 3.2 64bit

  • CPU: Intel(R) Pentium(R) CPU 2020M @ 2.40GHz

  • MEMORY: 4Gb

  • VIDEO CARD: Intel Corporation 3rd Gen Core processor Graphics Controller Sound Card:
My solution to install updates error " couldn't fetch the package cache information lists  " is to

open the package manager ( menu/system/install/remove software ) and click reload.

It will give error but list the problematic sources. note the sources. click settings/repositories/other software, scroll down and uncheck the problem sources then reload.

this should be successful, then try menu favorites/install updates and then try /system/ lite software

for me it was google chrome, google talkplus and another linux lite trusty?I can not recall
 

Re: Error while installing updates
« Reply #10 on: March 13, 2017, 12:02:44 PM »
 

ayman

  • New to Forums
  • *
  • 11
    Posts
  • Country: 00
  • Reputation: 2
  • Linux Lite Member

  • Linux Lite: 3.2 64bit

  • CPU: Intel(R) Pentium(R) CPU 2020M @ 2.40GHz

  • MEMORY: 4Gb

  • VIDEO CARD: Intel Corporation 3rd Gen Core processor Graphics Controller Sound Card:
Works fine thank you
 

Re: Error while installing updates
« Reply #11 on: April 03, 2017, 01:07:05 AM »
 

mdavies5

  • New to Forums
  • *
  • 11
    Posts
  • Country: au
  • Reputation: 0
  • Linux Lite Member

  • Linux Lite: 3.4 64bit

  • CPU: Intel I5 5200U Quad Core 2.2GHz

  • MEMORY: 12Gb

  • VIDEO CARD: Intel 5500
I had the same problem. It was caused because the repository ../linuxlite/xenial could not be reached. In Synaptic I unchecked this repository and refreshed the lists ok. The update then worked. I just wonder if I am missing out on something from any specific Linux Lite software?
 

Re: Error while installing updates
« Reply #12 on: April 03, 2017, 01:12:53 AM »
 

ralphy

  • PayPal Supporter
  • Gold Level Poster
  • *****
  • 740
    Posts
  • Country: us
  • Reputation: 114
  • Linux Lite Developer

  • Linux Lite: 3.8 64bit
I had the same problem. It was caused because the repository ../linuxlite/xenial could not be reached. In Synaptic I unchecked this repository and refreshed the lists ok. The update then worked. I just wonder if I am missing out on something from any specific Linux Lite software?

Could you please post the complete URL of the repository you unchecked?
https://unlockforus.com

Sorry for seeming stupid and preferring Linux - I just don't know any better.

 

Re: Error while installing updates
« Reply #13 on: April 03, 2017, 07:58:44 PM »
 

mdavies5

  • New to Forums
  • *
  • 11
    Posts
  • Country: au
  • Reputation: 0
  • Linux Lite Member

  • Linux Lite: 3.4 64bit

  • CPU: Intel I5 5200U Quad Core 2.2GHz

  • MEMORY: 12Gb

  • VIDEO CARD: Intel 5500
The URL is: deb http://repo.linuxliteos.com/linuxlite/ xenial main and is found in /etc/apt/sources.list.d/linuxlite.list/linuxlite.list.
It is included as part of the original setup and is enabled by default.
I found this same problem in the rc release.
 

Re: Error while installing updates
« Reply #14 on: April 03, 2017, 10:36:49 PM »
 

ralphy

  • PayPal Supporter
  • Gold Level Poster
  • *****
  • 740
    Posts
  • Country: us
  • Reputation: 114
  • Linux Lite Developer

  • Linux Lite: 3.8 64bit
The URL is: deb http://repo.linuxliteos.com/linuxlite/ xenial main and is found in /etc/apt/sources.list.d/linuxlite.list/linuxlite.list.
It is included as part of the original setup and is enabled by default.
I found this same problem in the rc release.

Thank you for sharing  :)

The file: /etc/apt/sources.list.d/linuxlite.list/linuxlite.list does not exist by default but I believe you mean:

deb http://repo.linuxliteos.com/linuxlite/ citrine main ... and it is found in /etc/apt/sources.list.d/linuxlite.list

First, let me recommend for you to enable that repo again. That's Linux Lite main repository. If you can't reach the mirror for whatever reason (as it happened to you already) you should consider a closer mirror to your location: https://www.linuxliteos.com/manual/software.html#literepos

If I'm correct this confirms my suspicions that some users have had issues connecting to master server thus causing updates to throw the error. I have spent quite some time looking at the code to try to find out if there was something in it that could have caused the issue and my conclusions pointed to connectivity issue to the repo.

I thought about including some additional checks to the updater but I'm not sure how efficient will that make it. It happens that the connection may be OK at the time the check runs and experience problems while the updater is later running.

But your reply was valuable :) so thanks again!
https://unlockforus.com

Sorry for seeming stupid and preferring Linux - I just don't know any better.

 


Tags:
 


Linux Lite 4.4 Final has been released. See the Release Announcements section for more information.