You are Here:
Linux Lite 4.2 Final has been released. See the Release Announcements Section.



[ SOLVED ] Error when booting: Diskfilter writes not supported

Author (Read 2885 times)

0 Members and 9 Guests are viewing this topic.

Error when booting: Diskfilter writes not supported
« on: June 07, 2018, 01:05:09 AM »
 

whateverthing

  • Occasional Poster
  • **
  • 86
    Posts
  • Country: us
  • Reputation: 21
  • design enthusiast
    • My Tumblr: KarHutWhat

  • Linux Lite: 4.0 64bit

  • CPU: Core 2 Duo P8600

  • MEMORY: 2Gb

  • VIDEO CARD: Intel GMA X4500
Hi -- I installed LL4.0 a few days ago, onto the same old laptop I was using with LL3.8 before. Now when I boot, I see an error screen that says:
"Error: diskfilter writes are not supported.
 Press any key to continue..."

I've done some Googling, and it apparently comes from GRUB. It seems to have something to do with drive partitions? I definitely don't understand the problem or the answer.
https://askubuntu.com/questions/468466/diskfilter-writes-are-not-supported-what-triggers-this-error/498281#498281

It would be nice to get rid of the error. Any help would be appreciated! Should the installation process have made different partitioning choices?
Last Edit: June 21, 2018, 11:38:39 AM by whateverthing
=Karl=
 


Re: Error when booting: Diskfilter writes not supported
« Reply #1 on: June 11, 2018, 02:52:20 PM »
 

kpanic

  • PayPal Supporter
  • Forum Regular
  • *****
  • 162
    Posts
  • Country: fi
  • Reputation: 65
  • Linux Lite Member

  • Linux Lite: 4.0 64bit

  • CPU: Core i5 M450

  • MEMORY: 8Gb

  • VIDEO CARD: Nvidia GT216
Hi,

Since you installed 4.0 just a few days ago, you probably don't have much important data in there yet?
If you have, can you store it temporarely to a USB stick for example?
This is because I suggest that you make a fresh new installation of LL 4.0.

When you begin the new installation, don't start the actual installation yet, just let the live OS be in the RAM
and open a terminal. In the terminal, use gdisk to repartition your HD. If you have just one HD and LL will be
the only OS in it, then just create two partitions with gdisk:

NOTE: If you make a mistake/typo in any of the following, you may always
           press CTRL+C and start again.

Code: [Select]
sudo su
Code: [Select]
gdisk /dev/sda
Now, make sure you have all of your important data backed up somewhere, in an USB stick
or external HD or such, since the data will be lost from your HD when you repartition it!

Next you see:
Code: [Select]
Command (? for help):
Press key 'o' (and ENTER), to create a new empty GPT partition table.

Finally create two new partitions: /dev/sda1 and /dev/sda2.

Press key 'n' to create a new partition.
Code: [Select]
Command (? for help): n
Now, the first partition will be your root partition, so create it
almost as big as the disk is, but leave at least 16777216 sectors unallocated for swap.
And create the second partition (for swap) the same way you created the first one:

Press key 'n' to create a new partition.
Code: [Select]
Command (? for help): n
Now you may allocate the rest of the disk for swap and accept the
defaults by pressing ENTER a few times.

This is a little detail but it makes sense to change the swap partition's ( /dev/sda2 )
type, so command:
Code: [Select]
Command (? for help): t
          Partition number (1-2): 2
          Hex code or GUID (L to show codes, Enter = 8300): 8200

(And why not change the root partition's type also (if you use 64bit kernel).

Code: [Select]
Command (? for help): t
          Partition number (1-2): 1
          Hex code or GUID (L to show codes, Enter = 8300): 8304

Let's also toggle the root partition's legacy boot attribute:

Code: [Select]
Command (? for help): x
Expert command (? for help): a
          Partition number (1-2): 1
          Toggle which attribute field (0-63, 64 or <Enter> to exit): 2

If you got the message: "Have disabled the 'legacy BIOS bootable' attribute",
then toggle again, by pressing '2' again.

Finally write the new partition table to disk by pressing 'w'
Code: [Select]
Command (? for help): w
Ignore the warnings.

Now you are ready to create the filesystem and swap.
Command:

Code: [Select]
partprobe /dev/sdaThen:
Code: [Select]
mkfs.ext4 -t ext4 -m 3 -L root /dev/sda1Then:
Code: [Select]
tune2fs -c 10 -e remount-ro /dev/sda1Then initialize the swap partition:
Code: [Select]
mkswap -L swap /dev/sda2
Now you can exit the terminal and click the Install button.
When the installer comes to the partitioning, just edit the 2 entries
and DO NOT choose the 'format' option', since you already did it.
Just mount /dev/sda1 to /
and choose /dev/sda2 to be the swap partition.

Then just finish the installation.

I prefer to do this partitioning before the actual installation, since
you can fine-tune every little detail for the filesystem(s), which is
usually not possible to do when the graphical installer lets you do it.

And it may save you from a lot of time/harm, what some hardware unfortunately
may cause.

Please ask if I may be of any help?

Have fun :)

Last Edit: July 12, 2018, 10:00:15 PM by kpanic
 

Re: Error when booting: Diskfilter writes not supported
« Reply #2 on: June 12, 2018, 12:10:07 AM »
 

whateverthing

  • Occasional Poster
  • **
  • 86
    Posts
  • Country: us
  • Reputation: 21
  • design enthusiast
    • My Tumblr: KarHutWhat

  • Linux Lite: 4.0 64bit

  • CPU: Core 2 Duo P8600

  • MEMORY: 2Gb

  • VIDEO CARD: Intel GMA X4500
Wow @kpanic thank you for the detailed instructions! I could pretty easily re-install, so I'll give this a try.
=Karl=
 

Re: Error when booting: Diskfilter writes not supported
« Reply #3 on: June 12, 2018, 01:11:49 AM »
 

whateverthing

  • Occasional Poster
  • **
  • 86
    Posts
  • Country: us
  • Reputation: 21
  • design enthusiast
    • My Tumblr: KarHutWhat

  • Linux Lite: 4.0 64bit

  • CPU: Core 2 Duo P8600

  • MEMORY: 2Gb

  • VIDEO CARD: Intel GMA X4500
Well, I got to the step where I create the first partition, and am not sure what option to choose here:

Code: [Select]
Warning! Main partition table overlaps the first partition by 34 blocks!
You will need to delete this partition or resize it in another utility.

Command (? for help): o
This option deletes all partitions and creates a new protective MBR.
Proceed? (Y/N): y

Command (? for help): n
Partition number (1-128, default 1):
First sector (34-30548014, default = 2048) or {+-}size{KMGTP}: 

Should I take the default value?

Also, is that warning a problem?
=Karl=
 

Re: Error when booting: Diskfilter writes not supported
« Reply #4 on: June 14, 2018, 10:06:14 PM »
 

kpanic

  • PayPal Supporter
  • Forum Regular
  • *****
  • 162
    Posts
  • Country: fi
  • Reputation: 65
  • Linux Lite Member

  • Linux Lite: 4.0 64bit

  • CPU: Core i5 M450

  • MEMORY: 8Gb

  • VIDEO CARD: Nvidia GT216
Well, I got to the step where I create the first partition, and am not sure what option to choose here:

Code: [Select]
Warning! Main partition table overlaps the first partition by 34 blocks!
You will need to delete this partition or resize it in another utility.

Command (? for help): o
This option deletes all partitions and creates a new protective MBR.
Proceed? (Y/N): y

Command (? for help): n
Partition number (1-128, default 1):
First sector (34-30548014, default = 2048) or {+-}size{KMGTP}: 

Should I take the default value?

Also, is that warning a problem?

Hi,

That warning is quite common and you may ignore it since you are creating a new partition table anyway :)

- kpanic
 

Re: Error when booting: Diskfilter writes not supported
« Reply #5 on: June 14, 2018, 10:16:15 PM »
 

kpanic

  • PayPal Supporter
  • Forum Regular
  • *****
  • 162
    Posts
  • Country: fi
  • Reputation: 65
  • Linux Lite Member

  • Linux Lite: 4.0 64bit

  • CPU: Core i5 M450

  • MEMORY: 8Gb

  • VIDEO CARD: Nvidia GT216
...and yes, you can choose the default value, which is 2048.

Can you tell me how many sectors there are ( gdisk tells this when you start it ) on your hard drive?
 

Re: Error when booting: Diskfilter writes not supported
« Reply #6 on: June 15, 2018, 01:27:43 PM »
 

kpanic

  • PayPal Supporter
  • Forum Regular
  • *****
  • 162
    Posts
  • Country: fi
  • Reputation: 65
  • Linux Lite Member

  • Linux Lite: 4.0 64bit

  • CPU: Core i5 M450

  • MEMORY: 8Gb

  • VIDEO CARD: Nvidia GT216
...and yes, you can choose the default value, which is 2048.

Can you tell me how many sectors there are ( gdisk tells this when you start it ) on your hard drive?

Sorry, my mistake. When you launch 'gdisk /dev/sda', you need to press 'p' and ENTER to get
the amount of sectors in the hard drive / ssd.
 

Re: Error when booting: Diskfilter writes not supported
« Reply #7 on: June 16, 2018, 06:18:04 PM »
 

whateverthing

  • Occasional Poster
  • **
  • 86
    Posts
  • Country: us
  • Reputation: 21
  • design enthusiast
    • My Tumblr: KarHutWhat

  • Linux Lite: 4.0 64bit

  • CPU: Core 2 Duo P8600

  • MEMORY: 2Gb

  • VIDEO CARD: Intel GMA X4500
@kpanic ... It reports End sector 312580095, Size 149.0 GiB.

But I'm seeing all the discussion about swap partition, that Ubuntu 18.04 uses a swap file instead. So is there a different partition plan we should consider? What about a boot partition? I don't have a good understanding partition planning, and I see many options recommended, like this (which also suggests using a swap partition):
https://www.linuxtechi.com/ubuntu-18-04-lts-desktop-installation-guide-screenshots/

And this discussion says the OS will use a swap partition if it finds one:
https://ubuntuforums.org/showthread.php?t=2390779

But is a swap file a more efficient use of drive space, since it can vary in size as needed? I don't really know the issue, I'm just guessing.

Thanks for continuing to help with advice here!
=Karl=
 

Re: Error when booting: Diskfilter writes not supported
« Reply #8 on: June 17, 2018, 02:24:29 AM »
 

kpanic

  • PayPal Supporter
  • Forum Regular
  • *****
  • 162
    Posts
  • Country: fi
  • Reputation: 65
  • Linux Lite Member

  • Linux Lite: 4.0 64bit

  • CPU: Core i5 M450

  • MEMORY: 8Gb

  • VIDEO CARD: Nvidia GT216
@whateverthing, that's the power of Linux, things can be done in many ways. Sometimes though, this power may cause
some confusion. The reason why I prefer a swap partition instead of a swap file is, that if the Linux begins to swap, it always
makes the computer a bit ( or more ) slower. When you use a swap file, then the ext4 file system driver must do extra work
since the swap file is in the ext4 formatted partition and so it makes things even slower compared to, if you use a swap
partition, which is not formatted as ext4.

The file system driver is one of the most important parts of the Linux kernel and ext4 is very sophisticated file system and
requires a decent amount of resources from the CPU too - which is not the case with swap partition, which is much easier
for the kernel to maintain. So, it's faster and - as a bonus - it does not fragment the file system at all.

You may create many partitions, including the /boot partition but you don't need a separate /boot  partition. The boot loader
can load the kernel from the root ( / ) partition as well.

Since your HD seems to be about 149 Gb, I recommend that you create a 145Gb root partition and 4Gb swap should be enough. Here is how to do it:

First boot the installation media.

Then make sure, that LL will not auto-mount your new partitions:
Go: 'Menu' -> 'Settings' -> 'Removable Drives and Media'
And under "Removable Storage" make sure that every button is unchecked
and then close the settings.

Then open the terminal, become root and run gdisk:
Code: [Select]
sudo su  (This should be done, so that you won't need to type 'sudo' all the time...)
Code: [Select]
gdisk /dev/sda
Create empty partition table
Code: [Select]
Command (? for help): o
Create the root partition
Code: [Select]
Command (? for help): n
Accept the default partition number 1 and the default first sector 2048 by
pressing ENTER two times.

Then it asks the last sector, type '+145G' and press ENTER
Code: [Select]
Last sector (2048-312580095, default = 312580095) or {+-}size{KMGTP}: +145G
Then it asks the partitions type code, choose 8304 and press ENTER
Code: [Select]
Hex code or GUID (L to show codes, Enter = 8300): 8304
Then create swap (the second partition)
Code: [Select]
Command (? for help): n
Then it asks again the first sector and the size. This time you may choose
the defaults by pressing ENTER three times until it asks again the partitions
type code. Choose 8200 and press ENTER.

Code: [Select]
Hex code or GUID (L to show codes, Enter = 8300): 8200
Then toggle the legacy boot flag. Press 'x'
Code: [Select]
Command (? for help): x
Then 'a'
Code: [Select]
Expert command (? for help): a
Then '1'
Code: [Select]
Partition number (1-2): 1
Then '2' followed by two ENTERs
Code: [Select]
Toggle which attribute field (0-63, 64 or <Enter> to exit): 2
Now you can check how your partition layout looks like, press 'p'
Code: [Select]
Expert command (? for help): p
You should see the two partitions.
Finally write the new layout to disk, by pressing 'w' and ENTER.

Code: [Select]
Expert command (? for help): w
(Ignore the warning)

Then make sure the kernel sees the new layout by commanding
Code: [Select]
partprobe /dev/sda
Then create the ext4 filesystem
Code: [Select]
mkfs.ext4 -t ext4 -m 2 -L root /dev/sda1(Sometimes it takes some time, so please don't interrupt...)

Then create the swap
Code: [Select]
mkswap -L swap /dev/sda2
Then some fine-tuning
Code: [Select]
tune2fs -c 10 -e remount-ro -O ^dir_nlink,^huge_file /dev/sda1
Now you are ready and may exit the terminal and begin the installation.
And again, when the installer comes to the partitioning, just edit the two partition
entries. Set the /dev/sda1 partition to be ext4 and mount it to /

And set the /dev/sda2 to be the swap partition.

Do NOT check the 'format' option, since it's done already.
Then just finish the installation.

And finally as I said. Things can be done in many different ways. You may ignore these instructions
if you don't feel comfortable using the terminal - then the graphical installer does everything for you.
However, with the graphical installer you are not able to be so precise.

I hope this helps :)
Last Edit: July 12, 2018, 09:57:52 PM by kpanic
 

Re: Error when booting: Diskfilter writes not supported
« Reply #9 on: June 17, 2018, 06:06:46 PM »
 

whateverthing

  • Occasional Poster
  • **
  • 86
    Posts
  • Country: us
  • Reputation: 21
  • design enthusiast
    • My Tumblr: KarHutWhat

  • Linux Lite: 4.0 64bit

  • CPU: Core 2 Duo P8600

  • MEMORY: 2Gb

  • VIDEO CARD: Intel GMA X4500
I got a ways through it, but it failed at the mkfs command:

Code: [Select]
linux  ~  sudo partprobe /dev/sda
 linux  ~  sudo mkfs.ext4 -t ext4 -m 2 -L root /dev/sda1
mke2fs 1.44.1 (24-Mar-2018)
/dev/sda1 contains a LVM2_member file system
Proceed anyway? (y,N) y
/dev/sda1 is apparently in use by the system; will not make a filesystem here!
 linux  ~ 
=Karl=
 

Re: Error when booting: Diskfilter writes not supported
« Reply #10 on: June 17, 2018, 10:23:42 PM »
 

kpanic

  • PayPal Supporter
  • Forum Regular
  • *****
  • 162
    Posts
  • Country: fi
  • Reputation: 65
  • Linux Lite Member

  • Linux Lite: 4.0 64bit

  • CPU: Core i5 M450

  • MEMORY: 8Gb

  • VIDEO CARD: Nvidia GT216
@whateverthing, did you remember to disable the automounter?

'Menu' -> 'Settings' -> 'Removable Drives and Media'
And under "Removable Storage" make sure that every button is unchecked
and then close the settings.

Also, when you create these partitions and file systems, you may as well
do it as root: just command
Code: [Select]
sudo su
...in case you are not root already for some reason.

If this does not work, then try:
Code: [Select]
umount /dev/sda1 && mkfs.ext4 -t ext4 -m 2 -L root /dev/sda1
If even this does not work, then try:
Code: [Select]
umount /dev/sda1 && wipefs -a /dev/sda1 && mkfs.ext4 -t ext4 -m 2 -L root /dev/sda1
Hopefully this helps. Just a few steps left to  do :)
Last Edit: June 17, 2018, 11:01:07 PM by kpanic
 

Re: Error when booting: Diskfilter writes not supported
« Reply #11 on: June 18, 2018, 01:00:35 AM »
 

whateverthing

  • Occasional Poster
  • **
  • 86
    Posts
  • Country: us
  • Reputation: 21
  • design enthusiast
    • My Tumblr: KarHutWhat

  • Linux Lite: 4.0 64bit

  • CPU: Core 2 Duo P8600

  • MEMORY: 2Gb

  • VIDEO CARD: Intel GMA X4500
I'm sure I did:
'Menu' -> 'Settings' -> 'Removable Drives and Media'
...and unchecked all Removable Storage boxes.

And after the error I checked to make sure, and they were still unchecked.
=Karl=
 

Re: Error when booting: Diskfilter writes not supported
« Reply #12 on: June 18, 2018, 01:28:06 AM »
 

kpanic

  • PayPal Supporter
  • Forum Regular
  • *****
  • 162
    Posts
  • Country: fi
  • Reputation: 65
  • Linux Lite Member

  • Linux Lite: 4.0 64bit

  • CPU: Core i5 M450

  • MEMORY: 8Gb

  • VIDEO CARD: Nvidia GT216
@whateverthing, ok good.

Please try those two methods, which I wrote
 

Re: Error when booting: Diskfilter writes not supported
« Reply #13 on: June 18, 2018, 01:58:25 AM »
 

whateverthing

  • Occasional Poster
  • **
  • 86
    Posts
  • Country: us
  • Reputation: 21
  • design enthusiast
    • My Tumblr: KarHutWhat

  • Linux Lite: 4.0 64bit

  • CPU: Core 2 Duo P8600

  • MEMORY: 2Gb

  • VIDEO CARD: Intel GMA X4500
I just tried them both. Both times it said it's not mounted, but both times it said it was in use and could not execute the commands.
Code: [Select]
linux  ~  sudo umount /dev/sda1 && mkfs.ext4 -t ext4 -m 2 -L root /dev/sda1
umount: /dev/sda1: not mounted.
 linux  ~  sudo mkfs.ext4 -t ext4 -m 2 -L root /dev/sda1
mke2fs 1.44.1 (24-Mar-2018)
/dev/sda1 contains a LVM2_member file system
Proceed anyway? (y,N) y
/dev/sda1 is apparently in use by the system; will not make a filesystem here!
 linux  ~  sudo umount /dev/sda1 && wipefs -a /dev/sda1 && mkfs.ext4 -t ext4 -m 2 -L root /dev/sda1
umount: /dev/sda1: not mounted.
 linux  ~  sudo mkfs.ext4 -t ext4 -m 2 -L root /dev/sda1
mke2fs 1.44.1 (24-Mar-2018)
/dev/sda1 contains a LVM2_member file system
Proceed anyway? (y,N) y
/dev/sda1 is apparently in use by the system; will not make a filesystem here!
=Karl=
 

Re: Error when booting: Diskfilter writes not supported
« Reply #14 on: June 18, 2018, 02:31:43 AM »
 

kpanic

  • PayPal Supporter
  • Forum Regular
  • *****
  • 162
    Posts
  • Country: fi
  • Reputation: 65
  • Linux Lite Member

  • Linux Lite: 4.0 64bit

  • CPU: Core i5 M450

  • MEMORY: 8Gb

  • VIDEO CARD: Nvidia GT216
This is strange. Please try to boot into Safe Mode and try again.

If it succeeds in Safe Mode, then boot back to normal mode
 


Tags: boot error grub 
 


Linux Lite 4.2 Final has been released. See the Release Announcements Section.