Software - Support > Installing Linux Lite

BootDevice Not Found - acer aspire s7

<< < (4/4)

Yes, also my English is not really goob tsu02.

That's probably the main issue of tsu02, probably some sector of his disk are damaged.

I recommend you tsu02 try to use Windows 10 to fix that because of his graphical intefax. If you have one cd try to find that option: Here is a link

After that  :computer

Don't forget when you press the button F2 or another to watch the BIOS Setup of your computer, don't forget to choose your USB memory to boot first. The one that said the brand of you memory stick ,not UEFI plus the name of that memory stick...

Şerban S.:

--- Quote from: tsu02 on April 12, 2024, 09:05:41 AM ---[...] When i restart it without they key, i have a black screen with the mention "BootDevice Not Found"[...]
UEFI is enabled
secure boot is disabled [...]

--- End quote ---

This message means at least two things:
1. The destination drive is damaged. This means it has bad sectors.
2. The drive has an MSDOS type partition. This always leads to errors since your machine has UEFI firmware.
In either case, you need to diagnose the disk.
For that, you need a tool that does that.
The tool is called GPartEd Live, meaning that you have to go to the site, download the ISO image, burn it on an USB stick, then boot it.


After the booting process finishes, you will be in front of the GPartEd window.
It will tell you about the drive's partitions, types, sizes and the rest.
It will also tell you the type of partition.
Select from the Menu View > Device information.
It can be either "MSDOS" or "GPT" (UEFI, Global Partitioning Table.)
If the drive is MSDOS partitioned, than you have to delete all, until all space says "Unpartitioned" or "Unallocated".
Now choose from the menu Device > Create partition. Choose the GPT type, then "Apply".
If you know how to go from here, than do it. Create and format the partitions, starting with the FAT32 boot partition and then the others.
If you are unfamiliar, then stop the computer, insert the boot drive (Linux Lite) and reinstall, with the default option.
Let the installer do the rest. Just follow the on-screen instructions.

Keep us updated.

Best regards, Șerban.


Thanks for your answer Edimion
(i'm a beginner on Linux and my english is not perfect...)

So ! I checked the data integrity of my Linux ISO and it's all right, the same result of letters and numbers.

I had tried only with Rufus, i tried with Balena Etcher this time and no problem to create my bootable USB key.

I started my laptop where i want to install Linux with the key. However just before the screen where you can choose to boot live linux or direct install LL, i have an error message "file \boot not found". I tried to install LL 6.6 after a check for file corruption but after a reboot, same problem as before, "bootdevice not found". Not really a surprise...


-You forget to mention if you checked the data integrity of that file (Linux Lite 6.6) before you created your Live USB
To check that it's not mention in the Tutorial of Linux Lite...
I think you can do this by putting your Linux live installation in your PC. But if I read well, you "said" you tried different ways, perhaps you have another computer where you live...

If you have another computer to try different options to install Linux Lite. If that's windows Balena Etcher is a reliable way to create that Live USB, NEVER try it with Rufus. Rufus is known to cause problems.
But to check the data integrity of what you downloaded is different than with Linux

with Windows
Press Windows+R to open the Run box
Type powershell and click OK
The Windows PowerShell window will open
Run the following command:
Get-FileHash C:\file\path\my_file.exe -Algorithm SHA256
+++Replace C:\file\path\my_file.exe  with the path where is your Linux ISO ,perhaps on D:\ ...

To check that on Linux
I know when someone made a "\" partition and a "home" different partition by default the terminal will open with the name you put that profile of Linux, with the UEFI automatic installation I think it's the same. So if you put a name : Computer_of_me that's where it'll open the terminal..

So your ISO (Linux OS) in linux environment must be in the Download folder. Just cut it and put it the main folder (the Computer_of_me) if you moved that ISO you just have to type in the terminal:
sha256sum linux-lite-6.6-64bit.iso
(then Enter)
Copy that result of letters, number, etc in a text editor and compare each one with this:
the official sha256 signature of data integrity in the main website of Linux Lite 6.6

-But it's possible all of your USB could be damaged at first but all of them it's not probably true
First try to check the data integrity of your ISO before copy them in your USB(if that was your problem at first) and then this community will try to help you with other issues.


I'm trying to install linux lite on a 2012 Acer Aspire S7,

I followed the install tutorial : downloading ios, writting the iso on a usb stick, booting with usb stick, booting on live system then installing linux lite following the instruction

Linus will be the only operation system, so i installed using ''erase disk and install linux'' option.
After finishing the install, the only option is to restart the pc but it boots directly on my usb key.

When i restart it without they key, i have a black screen with the mention "BootDevice Not Found"

UEFI is enabled
secure boot is disabled

i tryed reinstalling linux lite with different options, i tryed to use another usb key, with/without internet etc

I can't really know if the issue is from the bios or the key or a bad installation ...

If anyone know a fix !
Thanks a lot for your help !


[0] Message Index

[*] Previous page

Go to full version