Hardware - Support > Hard Drives and SSDs

The dreaded read-only problem

(1/2) > >>

Plugged in a different drive and I can write to it under Linux Lite with no trouble. I looked at it in the Disks accessory, and its options are identical with the way my problem drive was before I changed it to the specs in your link yesterday. And also put the "problem" drive in a usb dock and stuck it on my Windows machine, where it still appears to work perfectly; that is, I can read and write and delete with no trouble.

This is perplexing. The drive works fine with Windows, but can't be written to in Linux. I've tried the options suggested in the Installation page and they don't seem to have worked. What could be going on here?

I would sure like to resolve this problem!

EDIT: thinking the best thing to do is format the damn thing.

I copied all the settings in that instruction page, changed the Disks options to match them, and rebooted. As before, the drive let me copy one file to it and then said NO to anything else I try. If I click on the desktop icon and check properties there, it now says the owner is root and every one of the option pulldowns is grayed out. If I open it as root in a file manager, I still can't do anything to it.

That link talks about getting a disk to mount. This one already does that, it just won't let me write to it. And it was working fine yesterday, so something changed. I will try the Disks app again later (no luck there yesterday, though) when the usb dock is not being used to backup my Windows partition; right now I can't insert the funky disk. More later.

EDIT: just inserted it again and it let me write to it once. I have changed literally nothing since yesterday. I wonder if the disk itself is getting wonky. This is certainly not consistent behavior! It let me copy a file to it, but it won't let me delete the file once it's copied. This seems strange. And now once again it says the disk is read-only.

Going into Disks, I see that compared to the mount options shown in your link (users,noexec,nosuid), mine says nosuid,nodev,nofail,x-gvfs-show. Is this important? I left it the way it is until I know more about what I'm messing with. After saving the Disks changes the drive is still mounted but still also read-only.

The Manual has all you need for this task.


Why did it quote me instead of modifying the message? And after telling me the forum is unavailable twice, too. Hiccups in everything tonight!


[0] Message Index

[#] Next page

Go to full version