Hardware - Support > Hard Drives and SSDs

Cannot mount or eject external USB hard drive


Your profile says 2gig of RAM. If that is the case it's unrealistic to try and solve this issue which can be mitigated with swap and cache settings on bigger RAM systems. If you read the post all the way through the mitigation was to turn off swap completely, though other caching process controls can be tweaked as well, but your 2gig of RAM limits the amount of performance boost you may get without swap and cache limiting. You can try with swap off, but your system may go OOM.

PS, GUI disappears because your video card is configured above base memory, rather than below and you have memory limitations during big file transfers.

Things to try: Reboot your base system and use Lite Tweaks  to clear all memory and caches, then turn swap off and try the copy process. If your BIOS offers video card settings choose below rather than above.


The HDD should mount on its own... It'll attach to /media I believe...
If you hard manually mounting it - via the mount command, can you unmount via umount?

Also, you may be getting the cannot eject in use message if there is something open to it, file manager or another application: Backup, Viewer, Reader, etc etc...

If you cant eject, for what ever - you can shutdown the pc, that should close out any open/held connections.

While its plugged in and working...
Perhaps the output of... would be a start...

--- Code: ---df -h
--- End code ---

I read this post, but cannot get into my gui screen to add it to my .config file (tried in terminal too, but it looked like just an empty file, so exited out, didn't want to mess anything up):

Changed my life adding

vm.dirty_background_ratio = 5
vm.dirty_ratio = 10

in /etc/sysctl.conf
and running sysctl -p
When I do Alt+F2 to access the file, nothing happens.  Any advice?  After I had shut down my computer last night, I started up fine, then tried copying over those files to my external usb hard drive again, and it's hung up again. 

I am very new with Linux, so I need very high level feedback. Any help is appreciated!

I am trying to mount my external hard drive (done many, many times) after a few copy processes hung up and having issues.  It's really important for us to retain the data on this drive.  I unmount and try to eject and receive another error.  My external hard drive is lit up constantly as though it's hung up.  I'm afraid to just unplug it.  Any ideas?

I have a File Operation Progress screen showing four copies in progress (I've clicked on the X next to each to cancel them, but those are all hung up, saying "Canceling" with nothing happening in the status bars).

When I try to eject the device after I unmount it, I get: Failed to eject "FreeAgent GoFlex Drive". / Error opening /dev/sde: Device or resource busy.

When I try to mount the device I get: Failed to mount "FreeAgent GoFlex Drive". / Error when getting information for file '/media/mountainlover/FreeAgent GoFlex Drive': Transport endpoint is not connected.

Any help is appreciated!


[0] Message Index

Go to full version