Hardware - Support > Hard Drives and SSDs

Can you update the BIOS when the disk is encrypted?


Nice! Glad you solved it.

Strangely enough I updated the BIOS of my work laptop last week.
This one was encrypted with BitLocker (Windows) and did not boot anymore, just kept asking for the unlock key (a really long key not related to the passwords).
I had the key so I was able to boot again... otherwise it would've been a wipe and reinstall.

So, I guess these stories are a word of caution to anyone using encryption. Always have a backup, just in case something happens! ;)

I solved it.

Even though I ended up using Rufus via an old Windows 7 VM, I don't think UNetbootin was the problem.  I was getting the same results with a Rufus built USB stick.  I believe the problem I was having, which yielded the following error on my PC and a Linux VM I created, was because of FreeDOS 1.2.  I found an archived version of FreeDOS 1.0, and then the instructions Dell gave worked.  I am somewhat pleased to know the LUKS disk encryption wasn't an issue.

I am following the instructions to update the BIOS at https://www.dell.com/support/kbdoc/en-us/000131486/update-the-dell-bios-in-a-linux-or-ubuntu-environment#Creating%20a%20USB%20Bootable%20Storage%20Device.  When I boot to the USB created using UNetBootin and I select FreeDOS, I get "Invalid or corrupt kernel image."

For the record, the md5sum and sha256sum are good for the FreeDOS file I downloaded, and I am using the binary for UNetBootin from https://unetbootin.github.io/.

My laptop is a Latitude E6430, and I used the USB 2.0 port to create and boot to the bootable USB.

I am running LUKS full disk encryption.  I'm not sure if a BIOS update will run with that in play.  If LUKS is the problem, is there a way to suspend it so that I can go through with the BIOS update?


[0] Message Index

Go to full version