Hardware - Support > Hard Drives and SSDs

[SOLVED] Toshiba USB Problem

(1/3) > >>

Thanks Valtam for the edit :)
Wasn't sure how to go about that.

Gold_finger, thanks for that info too, about marking as solved and creating the new partition table.
I hadn't tried making a new partition table, I only reformatted.
Making a new partition table before formatting made no difference to the performance of the USB's.

They are both faulty as the testing results of the 2nd device (below) are nearly identical to the first one's results.
A few hours ago we went onto e-bay to sort it out & the seller's account had been removed so I guess we weren't the only ones having problems with these devices.

Thanks to all for your help  8)

The media is likely to be defective.
6.9 GByte OK (14494182 sectors)
55.5 GByte DATA LOST (116543002 sectors)
Details:4 KByte overwritten (8 sectors)
0 KByte slightly changed (< 8 bit/sector, 0 sectors)
55.5 GByte corrupted (116542994 sectors)
4 KByte aliased memory (8 sectors)
First error at offset: 0x00000000104c1000
Expected: 0x00000000104c1000
Found: 0x29b4a100cf4d1000
H2testw version 1.3
Writing speed: 17.5 MByte/s
Reading speed: 7.16 MByte/s
H2testw v1.4

EDIT: Handy little testing utility that H2testw is, no install needed runs from the .exe if you have WINE.
When it starts it'll be in Deutsch, just click the English button.
Format your USB Drive/Memory Card/whatever, mount it, open H2testw, click Select Target, navigate to the drive you want to check, 'all available space' does the whole drive or you can select a smaller amount and set it manually, then just click Write + Verify.
It'll take a while, took over 3 hours to do 64 GB USB drives, once finished click the "Copy to Clipboard" button to save the report.
Website is here - http://www.heise.de/download/h2testw.html  Deutsch site.
I found it here - http://www.portablefreeware.com/?id=1519

Edited as Solved.


I've been watching this thread from the sidelines curiously waiting to see what problem might have been.  At this point, since it appears you have nothing to lose by experimenting, I'm wondering if you might try something else just out of curiosity?

You may have already done this and just not stated it, but if you haven't -- take one of those USBs and use GParted to make a new partition table before trying to reformat it.

*  Open GParted, select USB stick and click Device -> Create Partition Table -> msdos -> Apply.  (Make sure you have the USB selected and not your hard drive.)

*  Make one large FAT32 partition on it.

*  Run another experiment transferring some mp3's, etc. and see if the same problems occur.

This is just a long-shot, wild guess at a potential cause of the problem.
Sometimes brand new USBs come with some kind of built-in software pre-loaded on it.  What purpose it serves I don't know?  But, if it exists it likely does not work in Linux and might be causing the problem.  Wiping out the partition table and creating a new one will get rid of that pre-loaded stuff (and everything else on the USB) that might otherwise remain (hidden) if you just reformat the existing partition(s), or if you just delete and re-create partitions.  Again, this is just a wild guess -- but who knows?  Worth a shot at this point.

P.s.  To mark a thread as "SOLVED", modify the title of the very first post in the thread.  You'll notice that if you go to main page for Hard Drives and SSD's, your post does not say "Solved".  It only shows that on the last post you made.  If you change the title of the first post in the thread, it will show up on the main page listing.

Here's the H2testw results from the first USB, took about 3 & a half hours for it to complete.

The media is likely to be defective.
6.8 GByte OK (14430904 sectors)
55.6 GByte DATA LOST (116606280 sectors)
Details:4 KByte overwritten (8 sectors)
0 KByte slightly changed (< 8 bit/sector, 0 sectors)
55.6 GByte corrupted (116606272 sectors)
4 KByte aliased memory (8 sectors)
First error at offset: 0x00000001b8657000
Expected: 0x00000001b8657000
Found: 0x00000001ba966000
H2testw version 1.3
Writing speed: 16.2 MByte/s
Reading speed: 6.80 MByte/s
H2testw v1.4


I"ll post the results of the one that had the videos on it once it's finished being tested, I'm guessing the results will be similar.

Thanks for the help Scott :)


It's looking like they are faulty USB's, just found out my Mum got 2 of them from flea-bay at what I thought sounded like a deal that was too good to be true.
I got the unused one, formatted it, copied about 5 GB of mp3's to it, looked inside and they appeared ok, played a couple from the drive ok, unmounted then remounted and most of them can't be found even though it shows the space is used on the drive.
LOL, it shows files located outside the folders in it's root directory where they should not be, the folder structure appears different etc., the files won't play and so on...
Tried formatting as NTFS & exfat, on a Vista machine & then as Fat32 on LL2, same result.

Running one through H2testw now and it's time remaining seems to vary from about 15 minutes to over 4 hours, according to the readme that comes with it thats a sign it's defective.
Will see what the final report has to say...



[0] Message Index

[#] Next page

Go to full version