Hardware - Support > Hard Drives and SSDs

[SOLVED] Toshiba USB Problem

<< < (3/3)

JmaCWQ:
Hello All,

I have a Toshiba 64GB USB drive formatted as Fat32 that's full of picture and video files.
The data was copied to it from a Mac, when first plugging it in it mounted ok but none of the video or image files were visible/readable even though Thunar showed the drive was full.

So I opened Gparted, unmounted it, started a Check but after a few seconds Gparted crashes out & closes.
It wouldn't mount again after that & any further attempts with Gparted resulted in the same crash, so I tried 'sudo fsck' through the terminal but that wouldn't work, kept saying the media was mounted when it wasn't.
I ended up plugging it into a Vista machine and using chkdsk on it & managed to get it so it would mount again.

Lol, now I have a USB full of files named 'FSCK0819.REC' etc., all the image files are ok, just the extension had to be changed back to .jpg, some of the video files the same, work fine after an extension change but most of the video files are listed as unknown and won't play after an extension change even though the sizes of the files seem to be about correct.
It appears the crash with Gparted has caused it somehow, Avidemux won't open them, VLC won't play them even though it appears to open them, nothing happens.
Gparted still crashes out if I try doing a check again on this USB drive.

Can this be easily fixed so these videos are usable again?
Or is it not worth the effort?
From what I've been reading it sounds like it's not worth the effort or possibly they can't be recovered anyway but I don't understand much about this sort of issue.

Thanks.

Navigation

[0] Message Index

[*] Previous page

Go to full version