Hardware - Support > Hard Drives and SSDs

[SOLVED] Puzzled on my new project - auto mount partition


Thanks ukbrian.

I seem to have the auto-mount in fstab thing squared away now.  Next step will be the Bind part of the project.

I have some questions with that, but will start a new thread as that seems to be a separate topic/discussion.


Try mounting your data partition in your /home/user folder.

This is my fstab where I use the the partition label rather than UUID
--- Code: ---LABEL=data /home/user/data   ntfs-3g  defaults,uid=1000 0      0
--- End code ---
I did try mounting at /mnt once but had trouble like you with permissions so I stuck with what worked.

Thanks altman, I will do some more reading in the help manual.  I was getting hung up with the locked partitions, but taking another look it seems as though they are just showing as "locked" because I had mounted them.

Will give it another go shortly.


Wonder if this can apply to you : https://www.linuxliteos.com/forums/index.php?topic=1012.0

I currently have a small SSD (128Gb) with LL 2.2 on it and which I use for my normal /primary drive/OS. 

I have a second convention hard drive (1T) on the machine with Windows 7, Linux Mint Mate and a 500+ Gb partition (ntfs) labeled "Data" that I hoped to store photos/videos, etc. and make them available to all three operating systems.  The default boot is LL 2.2 and at the boot menu I can select the others, which works fine.

I was trying to follow this method:


I went through the commands to create mount point, take ownership, create directories, find UUID# and then add the fstab additional entries to auto mount.  When I boot into LL however, it stops while booting and says "disk drive for 2DEB175417534C94 is not ready or present enter W to wait S to continue or M to manually recover". 

(2DEB175417534C94 is the UUID# for my Data partiton) if I Wait, nothing happens, if I Skip it boots fine and then Data shows up on my Desktop and I can mount it there, it shows as "Removable Volume mounted in "/media/chris/Data".  If I open it I also don't see the folders I created, but if i try and recreate them in terminal it says they already exist.

If I look at the partitioning in GParted I see /dev/sdb3 (which contains /dev/sdb7 the Data partition) and /dev/sdb7 show up with a set of keys next to them which would seem to indicate they are locked?  Is this the issue with the "disk drive not ready or present" or what am I missing here?

Any thoughts?



[0] Message Index

Go to full version