Linux Lite Forums

Hardware - Support => Hard Drives and SSD's => Topic started by: timbuck2 on January 04, 2019, 11:08:47 PM

Title: Windows mounts suddenly going read-only
Post by: timbuck2 on January 04, 2019, 11:08:47 PM
For a couple of days my windows7 and windows10 drives have been going read-only and I have to reboot and check their filesystems.

They are auto-mounted via fstab:
Code: [Select]
# /etc/fstab: static file system information.
#
# Use 'blkid' to print the universally unique identifier for a
# device; this may be used with UUID= as a more robust way to name devices
# that works even if disks are added and removed. See fstab(5).
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
# / was on /dev/sda1 during installation
UUID=a2fbbae1-060e-4751-bec4-653e2c031c9f /  ext4    errors=remount-ro 0       1
UUID=CC36728936727474 /mnt/windows10 ntfs defaults 0 0
UUID=6460FFA960FF7FDA /mnt/windows7 ntfs defaults 0 0
/swapfile                                 none            swap    sw              0       0
/dev/fd0        /media/floppy0  auto    rw,user,noauto,exec,utf8 0       0

What could be causing this issue?  It just started yesterday and happened today a couple of times after I restarted LL.  Are they not being unmounted properly?
Title: Re: Windows mounts suddenly going read-only
Post by: Jerry on January 05, 2019, 12:05:00 AM
Did you chmod the drives?
Title: Re: Windows mounts suddenly going read-only
Post by: timbuck2 on January 05, 2019, 01:16:44 AM
Oh no, just mounted them as normal after I installed LL.  They are r/w:
Code: [Select]
 /mnt> ls -la
total 52
drwxr-xr-x  6 root root  4096 Jan  4 20:38 .
drwxr-xr-x 26 root root  4096 Jan  2 23:29 ..
drwxr-xr-x  2 root root  4096 Jan  4 20:38 cdrom
drwxr-xr-x  2 root root  4096 Jan  1 17:24 ftp
drwxrwxrwx  1 root root  8192 Dec 28 22:14 windows10
drwxrwxrwx  1 root root 28672 Jan  4 19:28 windows7

Just started doing this yesterday.  I was reading online if windows drives are not unmounted correctly they can require CHKDSK to be run so they go to RO until checked.  After I reboot and run each OS from its drive natively once, then they go back to RW on LL.  Really weird.  Maybe I should be shutting down instead of restarting so much.  I know when I log out and log back in, my wifi network won't come back up.  I have to do a shutdown and reboot.
Title: Re: Windows mounts suddenly going read-only
Post by: Jerry on January 05, 2019, 01:51:52 AM
There's excellent information on mouthing hard drives in the Help Manual, have a read through.
Title: Re: Windows mounts suddenly going read-only
Post by: trinidad on January 05, 2019, 10:01:36 AM
Hold the shift key down when you shut down Windows. (Press and hold first and select shutdown and don't release it until the computer goes off)

TC
Title: Re: Windows mounts suddenly going read-only
Post by: timbuck2 on January 05, 2019, 07:36:56 PM
Will try this to do true shutdown instead of hybrid shutdown.  Thanks.
Title: Re: Windows mounts suddenly going read-only
Post by: TheDead on January 07, 2019, 08:47:29 AM
Hi,
For Windows 10, you can disable the option like mentionned here :
https://www.windowscentral.com/how-disable-windows-10-fast-startup (https://www.windowscentral.com/how-disable-windows-10-fast-startup)
For Windows 7, just to be safe, open a command line in administrator mode (run as administrator) and type :powercfg -H OFFThis will disable hibernation.
I think the read only will also happen when the disk is in a "dirty" / not sut down properly state. But this I'm not 100% certain.
Cheers!

Title: Re: Windows mounts suddenly going read-only
Post by: timbuck2 on January 08, 2019, 09:31:22 PM
Thanks, I'll keep this information for reference.  I've noticed as I migrate more and more of my applications to linux and wine I'm finding less and less need to reboot into windows and the drives haven't gone RO for a couple days.