You are Here:
Download Linux Lite 5.4 Final today - See Release Announcements



X Close Ad
X Close Ad
The dreaded read-only problem

Author (Read 1120 times)

0 Members and 3 Guests are viewing this topic.

The dreaded read-only problem
« on: February 21, 2021, 09:57:36 PM »
 

Tyrannocaster

  • Forum Regular
  • ***
  • 132
    Posts
  • Country: 00
  • Reputation: 6
  • Linux Lite Member

  • Linux Lite: 4.8 64bit

  • CPU: e5300

  • MEMORY: 6Gb

  • Kernel: 5.x
I've been using an external HD to transfer files between my linux system and my windows PC. Tonight it wouldn't let me write to the disk. No matter what I did I got errors like chown: changing ownership of '/media/MYNAME/STORAGE': Read-only file system
(STORAGE is the name of the disk.)
When I look in the GUI properties tab it says I have read and write access but no groups have anything but read access. However, I plainly do not have write access. I've looked online for the last hour and I know this is a common issue in linux, but I've never run into it before and so far all the terminal commands I have seen suggested don't do anything useful; the disk stays read only. I have to get this working again!

I can write to it fine in Windows.
 


Re: The dreaded read-only problem
« Reply #1 on: February 21, 2021, 10:08:52 PM »
 

Tyrannocaster

  • Forum Regular
  • ***
  • 132
    Posts
  • Country: 00
  • Reputation: 6
  • Linux Lite Member

  • Linux Lite: 4.8 64bit

  • CPU: e5300

  • MEMORY: 6Gb

  • Kernel: 5.x
I've been using an external HD to transfer files between my linux system and my windows PC. Tonight it wouldn't let me write to the disk. No matter what I did I got errors like chown: changing ownership of '/media/MYNAME/STORAGE': Read-only file system
(STORAGE is the name of the disk.)
When I look in the GUI properties tab it says I have read and write access but no groups have anything but read access. However, I plainly do not have write access. I've looked online for the last hour and I know this is a common issue in linux, but I've never run into it before and so far all the terminal commands I have seen suggested don't do anything useful; the disk stays read only. I have to get this working again!

I can write to it fine in Windows. The disk is formatted as FAT 32.
 

Re: The dreaded read-only problem
« Reply #2 on: February 21, 2021, 10:11:06 PM »
 

Tyrannocaster

  • Forum Regular
  • ***
  • 132
    Posts
  • Country: 00
  • Reputation: 6
  • Linux Lite Member

  • Linux Lite: 4.8 64bit

  • CPU: e5300

  • MEMORY: 6Gb

  • Kernel: 5.x
Why did it quote me instead of modifying the message? And after telling me the forum is unavailable twice, too. Hiccups in everything tonight!
 

Re: The dreaded read-only problem
« Reply #3 on: February 21, 2021, 11:33:27 PM »
 

Jerry

  • Linux Lite Creator
  • Administrator
  • Platinum Level Poster
  • *****
  • 8009
    Posts
  • Country: nz
  • Reputation: 749
  • Linux Lite Member
    • Linux Lite OS

  • Linux Lite: 5.4 64bit

  • CPU: Intel Core i9-10850K CPU @ 3.60GHz

  • MEMORY: 32Gb

  • VIDEO CARD: nVidia GeForce GTX 1650

  • Kernel: 5.x
The Manual has all you need for this task.

https://www.linuxliteos.com/manual/install.html#mountpartdrives
 

Re: The dreaded read-only problem
« Reply #4 on: February 22, 2021, 09:08:07 AM »
 

Tyrannocaster

  • Forum Regular
  • ***
  • 132
    Posts
  • Country: 00
  • Reputation: 6
  • Linux Lite Member

  • Linux Lite: 4.8 64bit

  • CPU: e5300

  • MEMORY: 6Gb

  • Kernel: 5.x
That link talks about getting a disk to mount. This one already does that, it just won't let me write to it. And it was working fine yesterday, so something changed. I will try the Disks app again later (no luck there yesterday, though) when the usb dock is not being used to backup my Windows partition; right now I can't insert the funky disk. More later.

EDIT: just inserted it again and it let me write to it once. I have changed literally nothing since yesterday. I wonder if the disk itself is getting wonky. This is certainly not consistent behavior! It let me copy a file to it, but it won't let me delete the file once it's copied. This seems strange. And now once again it says the disk is read-only.

Going into Disks, I see that compared to the mount options shown in your link (users,noexec,nosuid), mine says nosuid,nodev,nofail,x-gvfs-show. Is this important? I left it the way it is until I know more about what I'm messing with. After saving the Disks changes the drive is still mounted but still also read-only.
Last Edit: February 22, 2021, 10:00:19 AM by Tyrannocaster
 

Re: The dreaded read-only problem
« Reply #5 on: February 22, 2021, 03:00:38 PM »
 

Tyrannocaster

  • Forum Regular
  • ***
  • 132
    Posts
  • Country: 00
  • Reputation: 6
  • Linux Lite Member

  • Linux Lite: 4.8 64bit

  • CPU: e5300

  • MEMORY: 6Gb

  • Kernel: 5.x
I copied all the settings in that instruction page, changed the Disks options to match them, and rebooted. As before, the drive let me copy one file to it and then said NO to anything else I try. If I click on the desktop icon and check properties there, it now says the owner is root and every one of the option pulldowns is grayed out. If I open it as root in a file manager, I still can't do anything to it.
 

Re: The dreaded read-only problem
« Reply #6 on: February 23, 2021, 11:17:08 AM »
 

Tyrannocaster

  • Forum Regular
  • ***
  • 132
    Posts
  • Country: 00
  • Reputation: 6
  • Linux Lite Member

  • Linux Lite: 4.8 64bit

  • CPU: e5300

  • MEMORY: 6Gb

  • Kernel: 5.x
Plugged in a different drive and I can write to it under Linux Lite with no trouble. I looked at it in the Disks accessory, and its options are identical with the way my problem drive was before I changed it to the specs in your link yesterday. And also put the "problem" drive in a usb dock and stuck it on my Windows machine, where it still appears to work perfectly; that is, I can read and write and delete with no trouble.

This is perplexing. The drive works fine with Windows, but can't be written to in Linux. I've tried the options suggested in the Installation page and they don't seem to have worked. What could be going on here?

I would sure like to resolve this problem!

EDIT: thinking the best thing to do is format the damn thing.
Last Edit: February 23, 2021, 11:36:44 AM by Tyrannocaster
 


Tags:
 

X Close Ad
X Close Ad

Download Linux Lite 5.4 Final today - See Release Announcements