You are Here:
Download Linux Lite 5.2 today - See Release Announcements



not auto mounting removable drives - think I have an idea why

Author (Read 2729 times)

0 Members and 2 Guests are viewing this topic.

not auto mounting removable drives - think I have an idea why
« on: August 29, 2018, 06:07:03 PM »
 

Sprintrdriver

  • Forum Regular
  • ***
  • 109
    Posts
  • Country: no
  • Reputation: 5
  • Linux Lite on Dell Lattude D620

  • Linux Lite: 4.2 64bit

  • CPU: Intel Core2 T5500

  • MEMORY: 3Gb

  • VIDEO CARD: Intel Mobile 945GM/GMS 943/940GML Express
Hi forum.

Have seen several threads around on the web (not just on LL forum) where users complains about usb drives that Linux for some reason does not mount automatically just after the device is plugged in.
I too have had this issues, and it seem to boil down to a few common factors. - Regular usb sticks (thumb drives) have never being an issue for me, it have always being those card readers with multiple slots for various memory cards that seems to be prone to this issue. - It is always memory cards that have being used in cameras (in todays case - a dashcam).- Memory card have not being formatted for a long period of time.

New interesting readingA couple of weeks ago I read a local (that is in norwegian) article on why format memory cards instead of just delete one by one file. So the article stated that one should avoid deleting files on memory cards by using the camera, because cameras often have poor file system suport, and therefore it is a chance of have a corrupted file system.
A practical test that pretty much confirm that the SD card file system is the cause of the problemSo when I inserted the SD card from the dashcam into the card reader, the volume did not mount automatically. I tried this several times without success.Then I found an older SD card (refers to as SD 2) that have being used for normal file storage (not being into a camera). And voilla - there it was, right in front on me on the LL desktop. Tried to insert and remove this card two times, success both times.Then I tried the SD card from the dashcam, no nothing - still doesn't mount.
I also made a similar test on a Linux Mint 18.3 computer, and got similar result.

My conclusion (so far at least)It seems that if there is problems with fat file system, then Linux won't mount the volume.

The issue now is:So I assume there is some issues to the file system on the SD card. The camera can access the files normally, and I assume that the windows 7 computer will be able to access the files on it - because it is a MS file system.
When MS stop supporting windows 7, I'm planning to never be dependent on MS - I will be a full time Linux user. But this - how can I overcome this problem with those SD cards that I cannot access unless hooking the card reader to a MS computer?
I won't let an old, but fully functional computer die just because some company tell me that they won't make no more security updates to their OS. Thanks Linux :)
 


Re: not auto mounting removable drives - think I have an idea why
« Reply #1 on: August 29, 2018, 06:20:30 PM »
 

kpanic

  • PayPal Supporter
  • Forum Regular
  • *****
  • 162
    Posts
  • Country: fi
  • Reputation: 66
  • Linux Lite Member

  • Linux Lite: 4.0 64bit

  • CPU: Core i5 M450

  • MEMORY: 8Gb

  • VIDEO CARD: Nvidia GT216
Hi @Sprintrdriver ,

There are a couple of factors here.
If you want LL automount the USB device, check that you have under
Start -> Settings -> Removable Drives and Media
under the "Storage" Tab the first 3 boxes checked.

There is also a Tab for cameras, see that too.

The other factor is that the drive that you connect must have been formatted
properly: For example FAT is fine. But NTFS disks cause trouble for Linux, since
NTFS is Microsoft proprietary filesystem and Linux has only Experimental/Partial
support for it. So, the USB connected device should have FAT filesystem or
other Linux supported filesystem: ext2, ext4, xfs, ...

(Same thing with SD cards)
Last Edit: August 29, 2018, 06:28:23 PM by kpanic
 

Re: not auto mounting removable drives - think I have an idea why
« Reply #2 on: August 29, 2018, 06:39:44 PM »
 

trinidad

  • Platinum Level Poster
  • **********
  • 1215
    Posts
  • Country: us
  • Reputation: 192
  • Linux Lite Member
    • dbts-analytics.com

  • Linux Lite: 5.0 64bit

  • CPU: AMD A8 5500 4 cores

  • MEMORY: 8Gb

  • VIDEO CARD: AMD/ATI Radeon HD 7560D

  • Kernel: 5.x
If you're having trouble mounting an SD from a camera chances are it's exFAT format. Some exFAT SDs have proprietary permissions, i/e you MUST upload files only via the camera.

Actually you could try creating an NTFS storage partition to upload the files to. NTFS supports some minor security measures for exFAT. Once the files are on your HDD Linux will be able to find them by extension and open and/or copy them anyway. If Linux is on your drive anywhere, it owns it.

TC
Last Edit: August 29, 2018, 06:57:15 PM by trinidad
All opinions expressed and all advice given by Trinidad Cruz on this forum are his responsibility alone and do not necessarily reflect the views or methods of the developers of Linux Lite. He is a citizen of the United States where it is acceptable to occasionally be uninformed and inept as long as you pay your taxes.
 

Re: not auto mounting removable drives - think I have an idea why
« Reply #3 on: August 29, 2018, 08:00:04 PM »
 

kpanic

  • PayPal Supporter
  • Forum Regular
  • *****
  • 162
    Posts
  • Country: fi
  • Reputation: 66
  • Linux Lite Member

  • Linux Lite: 4.0 64bit

  • CPU: Core i5 M450

  • MEMORY: 8Gb

  • VIDEO CARD: Nvidia GT216
@trinidad ,

I don't understand why you suggest creating NTFS storage.
If indeed the SD in the camera has been formatted as exFAT, which I doubt, then the most compatible filesystem
to upload files would be FAT32, which is compatible with Windows, Linux and most likely the camera.
 

Re: not auto mounting removable drives - think I have an idea why
« Reply #4 on: August 30, 2018, 08:42:08 AM »
 

trinidad

  • Platinum Level Poster
  • **********
  • 1215
    Posts
  • Country: us
  • Reputation: 192
  • Linux Lite Member
    • dbts-analytics.com

  • Linux Lite: 5.0 64bit

  • CPU: AMD A8 5500 4 cores

  • MEMORY: 8Gb

  • VIDEO CARD: AMD/ATI Radeon HD 7560D

  • Kernel: 5.x
I believe exfat-fuse and exfat-utils come with shotwell on LL in the default installation, so... try opening shotwell first, then plugging in the card...

A 2T file size can be allowed for in exFAT, though that is something rarely seen outside of music or movie studios, the point being...

**I believe only shotwell configures the port for exFAT in LL, and only does so while in use. Standard port mounting will not allow the file size, basically, so the drive won't show up as mounted on the desktop.

NTFS has no file size limit and the camera has an upload function that will write to a partition that it recognizes as NTFS.

There are many SDs that don't mount or can't be read automatically by Linux, some even need an SDK to mount and read, but there is nothing made that I know of that can't eventually be configured for use with Linux somehow.

TC
All opinions expressed and all advice given by Trinidad Cruz on this forum are his responsibility alone and do not necessarily reflect the views or methods of the developers of Linux Lite. He is a citizen of the United States where it is acceptable to occasionally be uninformed and inept as long as you pay your taxes.
 

Re: not auto mounting removable drives - think I have an idea why
« Reply #5 on: August 30, 2018, 10:55:13 AM »
 

Sprintrdriver

  • Forum Regular
  • ***
  • 109
    Posts
  • Country: no
  • Reputation: 5
  • Linux Lite on Dell Lattude D620

  • Linux Lite: 4.2 64bit

  • CPU: Intel Core2 T5500

  • MEMORY: 3Gb

  • VIDEO CARD: Intel Mobile 945GM/GMS 943/940GML Express
Thanks. The dash cam is a type DOD 460 (I think - the label is worn out), so I'm going to put the card reader into a win7 computer, and I'm coming back after that.

[edit 1]
Can confirm that the file system is fat32. Running a windows error-check now, so in some minutes, I'll hopefully can confirm that there are file system errors.

[edit 2]
Disk check in windows completed - this is the summary:
Code: [Select]
[Window Title]
Checking Disk DOD LS460 (E:)

[Main Instruction]
Your device or disk was successfully scanned

[Content]
No problems were found on the device or disk. It is ready to use.

If you removed the device or disk before all files were fully written to it, parts of some files might still be missing. If so, go back to the source and recopy those files to your device or disk.

[^] Hide details  [Close]

[Expanded Information]
Volume dismounted.  All opened handles to this volume are now invalid.
Volume DOD LS460 created 05.06.2017 20:58
Volume Serial Number is 3864-6330
Windows is verifying files and folders...
File and folder verification is complete.
Windows is verifying free space...
Free space verification is complete.
Windows has checked the file system and found no problems.
   31 154 688 KB total disk space.
          128 KB in 4 folders.
   30 233 408 KB in 65 files.
      921 120 KB are available.

       32 768 bytes in each allocation unit.
      973 584 total allocation units on disk.
       28 785 allocation units available on disk.

[edit 3]
Ok, I'm back on my LL computer now. After running a full disk check (and seek for hardware failure) in windows, the SD card still doesn't auto-mounts in LL (while the other SD card works properly regarding to auto mount).So maybe there is this space in the fat32 partition name "DOD LS460" tat cause trouble? Going back to the win7 computer and try to rename the volume and see if anything changes.

[edit 4]
Used the w7 computer to make the volum name blank, but when inserting SD card into card reader on LL computer, nothing happens - still.
I start wondering if it may be the SD card itself that Linux somehow doesn't support properly.

Storage card that works: ADATA 32GB micro HC I  |  micro HCI
Storage card that does NOT work: SanDisk, extreme plus, 32GB micro HC I, V30.

This puzzles me big time, guess if I'm confused by now. So what is next thing to try? Format the card from the w7 computer and see if LL behaves differently then.


[edit 5]
I have now formatted the SanDisk card using w7, regular formatting (fast format not used).

And the result in Linux Lite? Still the same!

So it seems like Linux just doesn't support some kind of SD cards. Can that be true?
Last Edit: August 30, 2018, 01:04:09 PM by Sprintrdriver
I won't let an old, but fully functional computer die just because some company tell me that they won't make no more security updates to their OS. Thanks Linux :)
 


 


Download Linux Lite 5.2 today - See Release Announcements