You are Here:
Download Linux Lite 5.4 RC1 today - See Release Announcements



[ SOLVED ] Enabling TRIM on an SSD

Author (Read 4277 times)

0 Members and 1 Guest are viewing this topic.

Enabling TRIM on an SSD
« on: November 27, 2017, 07:22:18 AM »
 

casaadelfa

  • New to Forums
  • *
  • 1
    Posts
  • Country: gb
  • Reputation: 0
  • Linux Lite Member

  • Linux Lite: 3.6 32bit

  • MEMORY: 2Gb
Have successfully installed Linux Lite 3.6 on an SSD, so  looked in the Install Manual for 'Enabling TRIM on your SSD'.

There is a script highlighted in yellow included in the instructions and as a 'Linux Newby'  have to admit to not understanding some of the instructions:-

1) 'Copy the text below and edit it to match your set up'.   Which lines need to be edited and to what values?
2) '#By default this script does nothing.'  Puzzled by this line in the yellow box.

 So, to anyone who has successfully installed TRIM on LL, any help would be appreciated !!
 Thanks in anticipation,
 Alan

 Friday p.m - Just back from a pleasant liquid lunch. With a little Dutch Courage and perseverance I have managed to sort this out myself from the Install Guide without doing any damage.  TRIM now working !!
Alan


Last Edit: December 01, 2017, 11:11:14 AM by casaadelfa
 


Re: Enabling TRIM on an SSD
« Reply #1 on: February 21, 2018, 04:41:56 PM »
 

mezzmer

  • New to Forums
  • *
  • 27
    Posts
  • Country: ca
  • Reputation: 0
  • Linux Lite Member

  • Linux Lite: 3.4 32bit

  • CPU: AMD Turion ML-37

  • MEMORY: 2Gb
It would be nice if you would share your solution with the group for the benefit of those who follow - thanks.
 

Re: Enabling TRIM on an SSD
« Reply #2 on: February 21, 2018, 05:27:29 PM »
 

TheDead

  • Gold Level Poster
  • *******
  • 851
    Posts
  • Country: ca
  • Reputation: 71
  • Linux Lite Worshipper
    • My OpenDesktop Projects

  • Linux Lite: 4.8 64bit

  • CPU: HAL9000

  • MEMORY: 2Gb

  • VIDEO CARD: Quantum State VR v.3

  • Kernel: 4.x
@mezzmer
OP already mentionned the solution: It's some Liquid Dutch Courage! trollololo ;)
- TheDead (TheUxNo0b)

If my blabbering was helpful, please click my [Thank] link.
 

Re: Enabling TRIM on an SSD
« Reply #3 on: February 21, 2018, 06:03:34 PM »
 

firenice03

  • Rockin' the FREE World
  • Global Moderator
  • Platinum Level Poster
  • *****
  • 1498
    Posts
  • Country: us
  • Reputation: 261
  • Linux Lite Member

  • Linux Lite: 4.8 64bit

  • CPU: AMD E2//Atom X5//AMD Phenom II X2

  • MEMORY: 4Gb

  • VIDEO CARD: AMD Mullin Radeon R2//Intel//AMD/ATI RS880

  • Kernel: 5.x
@mezzmer
It would be nice if you would share your solution with the group for the benefit of those who follow - thanks.

Follow the manual.. As OP mentioned the part "Copy the text below and edit it to match your set up."Probably missed the match part
https://www.linuxliteos.com/manual/install.html?q=trim&x=5&y=7&per_page=7&matchtype=0#enabletrim


@mezzmer
OP already mentionned the solution: It's some Liquid Dutch Courage! trollololo ;)
That too LOL
LL 4.8 UEFI 64 bit ASUS E402W - AMD E2 (Quad) 1.5Ghz  - 4GB - AMD Mullins Radeon R2
LL 4.8 UEFI 64 bit Test UEFI Kangaroo (Mobile Desktop) - Atom X5-Z8500 1.44Ghz - 2GB - Intel HD Graphics
LL 4.6 64 bit HP 6005- AMD Phenom II X2 - 8GB - AMD/ATI RS880 (HD4200)
LL 3.8 32 bit Dell Inspiron Mini - Atom N270 1.6Ghz - 1GB - Intel Mobile 945GSE Express
RETIRED LL 2.8 64 bit Dell Optiplex 160 (Thin) - Atom 230 1.6Ghz - 4GB-SiS 771/671 PCIE VGA
Running Linux Lite since LL2.2
 

Re: Enabling TRIM on an SSD
« Reply #4 on: March 29, 2018, 01:17:06 PM »
 

Kim100

  • New to Forums
  • *
  • 3
    Posts
  • Country: gb
  • Reputation: 1
  • Linux Lite Member

  • Linux Lite: 4.6 64bit
This procedure is not working for me, I get the following error message in the Terminal.

IBUS-WARNING **: The owner of ~/.config/ibus/bus is not root!


The fstab file contains only one [sda1] of my two partitions


# /etc/fstab: static file system information.
#
# Use 'blkid' to print the universally unique identifier for a
# device; this may be used with UUID= as a more robust way to name devices
# that works even if disks are added and removed. See fstab(5).
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
# / was on /dev/sda1 during installation
UUID=43e71665-c934-4f09-b4da-03626ab649bb /               ext4    errors=remount-ro 0       1

My SSD drive is split into two partitions, sda1 contains the operating system and sda3 is my Storage. I have no Swap partition, on a previous installation Swap had been sda2.

IBUS-WARNING **: The owner of ~/.config/ibus/bus is not root! Has been put down to improper use of the of the Terminal Sudo commands but I am not a Terminal person, I have hardly used this feature, this is virtually a virgin installation. The fix on the Ubuntu forum is to delete the IBUS folder, something I am loath to do.

This installation is LL 3.8 upgraded from 3.6.

Any suggestions?

Last Edit: March 29, 2018, 02:10:32 PM by Kim100
 


Tags:
 


Download Linux Lite 5.4 RC1 today - See Release Announcements