You are Here:
Install Updates Gimp Error - see Security & Bug Fixes Section Sticky



Windows mounts suddenly going read-only

Author (Read 1050 times)

0 Members and 1 Guest are viewing this topic.

Windows mounts suddenly going read-only
« on: January 04, 2019, 11:08:47 PM »
 

timbuck2

  • Patreon Supporter
  • Occasional Poster
  • *****
  • 51
    Posts
  • Country: us
  • Reputation: 0
  • Linux Lite Member

  • Linux Lite: 4.2 64bit

  • CPU: AMD64

  • MEMORY: 16Gb

  • VIDEO CARD: NVIDIA GTX680
For a couple of days my windows7 and windows10 drives have been going read-only and I have to reboot and check their filesystems.

They are auto-mounted via fstab:
Code: [Select]
# /etc/fstab: static file system information.
#
# Use 'blkid' to print the universally unique identifier for a
# device; this may be used with UUID= as a more robust way to name devices
# that works even if disks are added and removed. See fstab(5).
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
# / was on /dev/sda1 during installation
UUID=a2fbbae1-060e-4751-bec4-653e2c031c9f /  ext4    errors=remount-ro 0       1
UUID=CC36728936727474 /mnt/windows10 ntfs defaults 0 0
UUID=6460FFA960FF7FDA /mnt/windows7 ntfs defaults 0 0
/swapfile                                 none            swap    sw              0       0
/dev/fd0        /media/floppy0  auto    rw,user,noauto,exec,utf8 0       0

What could be causing this issue?  It just started yesterday and happened today a couple of times after I restarted LL.  Are they not being unmounted properly?
 


Re: Windows mounts suddenly going read-only
« Reply #1 on: January 05, 2019, 12:05:00 AM »
 

Jerry

  • Linux Lite Creator
  • Administrator
  • Platinum Level Poster
  • *****
  • 7163
    Posts
  • Country: nz
  • Reputation: 672
  • Linux Lite Member
    • Linux Lite OS

  • Linux Lite: 3.8 64bit

  • CPU: Intel Xeon Dual CPU's E5645 2.4GHz 12 Cores

  • MEMORY: 16Gb

  • VIDEO CARD: nVidia GeForce GTX 960
Did you chmod the drives?
 

Re: Windows mounts suddenly going read-only
« Reply #2 on: January 05, 2019, 01:16:44 AM »
 

timbuck2

  • Patreon Supporter
  • Occasional Poster
  • *****
  • 51
    Posts
  • Country: us
  • Reputation: 0
  • Linux Lite Member

  • Linux Lite: 4.2 64bit

  • CPU: AMD64

  • MEMORY: 16Gb

  • VIDEO CARD: NVIDIA GTX680
Oh no, just mounted them as normal after I installed LL.  They are r/w:
Code: [Select]
 /mnt> ls -la
total 52
drwxr-xr-x  6 root root  4096 Jan  4 20:38 .
drwxr-xr-x 26 root root  4096 Jan  2 23:29 ..
drwxr-xr-x  2 root root  4096 Jan  4 20:38 cdrom
drwxr-xr-x  2 root root  4096 Jan  1 17:24 ftp
drwxrwxrwx  1 root root  8192 Dec 28 22:14 windows10
drwxrwxrwx  1 root root 28672 Jan  4 19:28 windows7

Just started doing this yesterday.  I was reading online if windows drives are not unmounted correctly they can require CHKDSK to be run so they go to RO until checked.  After I reboot and run each OS from its drive natively once, then they go back to RW on LL.  Really weird.  Maybe I should be shutting down instead of restarting so much.  I know when I log out and log back in, my wifi network won't come back up.  I have to do a shutdown and reboot.
 

Re: Windows mounts suddenly going read-only
« Reply #3 on: January 05, 2019, 01:51:52 AM »
 

Jerry

  • Linux Lite Creator
  • Administrator
  • Platinum Level Poster
  • *****
  • 7163
    Posts
  • Country: nz
  • Reputation: 672
  • Linux Lite Member
    • Linux Lite OS

  • Linux Lite: 3.8 64bit

  • CPU: Intel Xeon Dual CPU's E5645 2.4GHz 12 Cores

  • MEMORY: 16Gb

  • VIDEO CARD: nVidia GeForce GTX 960
There's excellent information on mouthing hard drives in the Help Manual, have a read through.
 

Re: Windows mounts suddenly going read-only
« Reply #4 on: January 05, 2019, 10:01:36 AM »
 

trinidad

  • Platinum Level Poster
  • **********
  • 1034
    Posts
  • Country: us
  • Reputation: 179
  • Linux Lite Member
    • dbts-analytics.com

  • Linux Lite: 4.6 64bit

  • CPU: AMD A8 5500 4 cores

  • MEMORY: 8Gb

  • VIDEO CARD: AMD/ATI Radeon HD 7560D
Hold the shift key down when you shut down Windows. (Press and hold first and select shutdown and don't release it until the computer goes off)

TC
All opinions expressed and all advice given by Trinidad Cruz on this forum are his responsibility alone and do not necessarily reflect the views or methods of the developers of Linux Lite. He is a citizen of the United States where it is acceptable to occasionally be uninformed and inept as long as you pay your taxes.
 

Re: Windows mounts suddenly going read-only
« Reply #5 on: January 05, 2019, 07:36:56 PM »
 

timbuck2

  • Patreon Supporter
  • Occasional Poster
  • *****
  • 51
    Posts
  • Country: us
  • Reputation: 0
  • Linux Lite Member

  • Linux Lite: 4.2 64bit

  • CPU: AMD64

  • MEMORY: 16Gb

  • VIDEO CARD: NVIDIA GTX680
Will try this to do true shutdown instead of hybrid shutdown.  Thanks.
 

Re: Windows mounts suddenly going read-only
« Reply #6 on: January 07, 2019, 08:47:29 AM »
 

TheDead

  • Gold Level Poster
  • *******
  • 630
    Posts
  • Country: ca
  • Reputation: 55
  • Linux Lite Worshipper
    • My OpenDesktop Projects

  • Linux Lite: 3.8 32bit

  • CPU: HAL9000

  • MEMORY: 1Gb

  • VIDEO CARD: Oculus Rift v.5
Hi,
For Windows 10, you can disable the option like mentionned here :
https://www.windowscentral.com/how-disable-windows-10-fast-startup
For Windows 7, just to be safe, open a command line in administrator mode (run as administrator) and type :powercfg -H OFFThis will disable hibernation.
I think the read only will also happen when the disk is in a "dirty" / not sut down properly state. But this I'm not 100% certain.
Cheers!

- TheDead (TheUxNo0b)

If my blabbering was helpful, please click my [Thank] link.
 

Re: Windows mounts suddenly going read-only
« Reply #7 on: January 08, 2019, 09:31:22 PM »
 

timbuck2

  • Patreon Supporter
  • Occasional Poster
  • *****
  • 51
    Posts
  • Country: us
  • Reputation: 0
  • Linux Lite Member

  • Linux Lite: 4.2 64bit

  • CPU: AMD64

  • MEMORY: 16Gb

  • VIDEO CARD: NVIDIA GTX680
Thanks, I'll keep this information for reference.  I've noticed as I migrate more and more of my applications to linux and wine I'm finding less and less need to reboot into windows and the drives haven't gone RO for a couple days.
 


Tags:
 


Install Updates Gimp Error - see Security & Bug Fixes Section Sticky