Linux Lite Forums

Hardware - Support => Hard Drives and SSD's => Topic started by: CaperAsh on January 09, 2019, 09:46:09 AM

Title: After 4.2 installation, data HD needs password to open up every time
Post by: CaperAsh on January 09, 2019, 09:46:09 AM
The HD doesn't automatically mount as it used to with previous version and also requires a password to open. Maybe for some reason (Apparently this is a 'root' enabled drive, at least when I click on Properties from the Drives icon in Thunar.


In GPart it says that this HD is flagged as "boot'. Does this means the bootup files are on this drive? If so, that is a mistake during installation. But if I can at least have it open properly, that would be fine.

Question: how to get it to load every time and get rid of the password prompt so that I can keep and save bookmarks?
Title: Re: After 4.2 installation, data HD needs password to open up every time
Post by: trinidad on January 09, 2019, 11:55:39 AM
Flagged as boot can just mean it's an msdos-MBR partitioning scheme not necessarily a mistake for a spare drive. If I understand you correctly, which is not easy to do from the information you provide, this is an extra data drive, and not the drive where the  / fs of the OS is mounted. My head hurts reading this question, but how you installed the system is probably the issue. Did you encrypt your home partition? Are you running secure boot with a dual boot? Did you select a specific place to install grub other than SDA? Is this a UEFI-GUID disk install or Msdos-MBR? Were both drives listed by the installer when you installed? Is this a two disk setup, or multiple partition? Do the disks have different formats i/e /fs on ext4 and data-vfat on the other? If it's two disks: Yes "/'" root of the OS can own the data drive. Change the permissions. Crap, my crystal ball just clouded over.

TC
Title: Re: After 4.2 installation, data HD needs password to open up every time
Post by: CaperAsh on January 09, 2019, 01:42:43 PM
Great reply! I get a headache reading it (and certainly don't understand most!).


I have an SSD 500 GB drive on which (at least it was before the upgrade) I have all systems, including one partition for Windows, which I open about once a year these days but it came with the laptop, and another partition for Linux distro which is sub-divided for an additional experimental distro (50 GB) but is now empty. The other HD is a 2TB non-SSD on which I keep all my data (so that I don't have to back it up etc when doing upgrades or trying out different OS's). It is working fine as far as I can tell, and when I look at it with Control-H to show hidden files I don't see anything different other than my own collection of data files.


The issue is that after booting up, that 2 TB HD does not automatically mount, even though I've ticked off automatic mounting (I believe). Which means also that any bookmarks I've made in thunar for directories are lost. I have to open thunar then click on the Drive icon and enter a password for it to mount. I've no idea where to control that password option. I don't want it. I want the drive to just mount automatically like it has always done for years.


I'll try to answer your other questions:
No encryption.
No idea what secure boot with dual boot means. When the machine boots, I have a screen with various OS options (including old OS's no longer there, like Vista from God Knows When - I bought this used 2 years ago) inc. on top the current LL OS, then another older installation, then the Windows options and I pick the first one or after X seconds it automatically selects that and continues booting.


I don't recall if or where I selected grub, but on looking into GParted today, for some reason the System Drive is no longer SDA but SDB. I suspect this happened during the installation though no idea why. All I tried to do was erase the contents of the prior installation in the relevant partition and replace with this new upgrade, albeit this was also the new LTS version of Ubuntu.


I can't remember about UEFI-GUID stuff and don't know how to answer that.


Both drives were in the install routine; I was in the custom mode in order to select the correct system partition and not accidentally wipe out the Windows for which have no installation disk.


This is a two-disk setup (1 500 GB SSD, and 1 2TB normal HD), but there are partitions on the System Drive which is basically divided into two: one for Windows and one for Linux.


The file system on the 2 TB drive SDA1 is ntfs. The mount point is media/b....ash/2TB, where b.....ash is my user name and 2TB is the Drive Label.


The file system on the SSD system drive is ntfs on the windows partitions and ext4 on the Linux partitions except the Swap partition.
The first linux is sdb4 and it has the / for mount point which I believe indicates root although it is not flagged as root in the information window like the 2TB drive which for some reason is flagged root, but the mount point is what I wrote above.


As far as I can tell, all have administrator / root read-write permissions.


A simpler question: where is the function controlling the password prompt located? How did this happen and how can it be gotten rid of?


Thanks for your reply and sorry for having been the cause of cerebral distress!