You are Here:
Download Linux Lite 5.2 today - See Release Announcements



[SOLVED] USB stick automounts but cannot change Read Write permissions

Author (Read 5026 times)

0 Members and 1 Guest are viewing this topic.

 

javier_mina

  • New to Forums
  • *
  • 17
    Posts
  • Reputation: 2
  • Linux Lite Member
Hello

I'm new to Linux and Linux Lite and really impressed so far.  My problem is that I cannot seem to be able to change the Read Write permissions on a USB stick permissions for Group and Others from NONE to READ AND WRITE.  I installed Disk Utility and formatted the drive and volume to FAT, but no joy.  What am I missing?  Can you please help?

Thanks, Javier

[attachment deleted by admin]
Last Edit: January 22, 2015, 10:12:48 AM by Scott(0)
 


Re: USB stick automounts but cannot change Read Write permissions
« Reply #1 on: January 21, 2015, 12:21:48 PM »
 

gold_finger

  • Documentation Writer
  • Platinum Level Poster
  • *****
  • 1094
    Posts
  • Country: us
  • Reputation: 325
  • Linux Lite Member

  • Linux Lite: 3.2 64bit

  • CPU: Intel Core2 Duo E7500 3.0GHz

  • MEMORY: 4Gb

  • VIDEO CARD: Intel 4 Series Integrated Graphics
Are you saying that you (main user) can read and write to the USB, but others can not?

Or are you trying to change permissions with the "chown" or "chmod" commands?

With a FAT formatted USB there shouldn't be any problems reading/writing to it.  Linux permissions don't apply to FAT formatted devices.  Does the USB stick itself have some kind of write protection feature that can be turned on/off?  Maybe that's what is happening.

With USB stick plugged-in and auto-mounted, open a terminal and post back with output of these two commands if still having problems:
Code: [Select]
ls -l /media
ls -l /media/yourusername
(Change "yourusername" to your actual username.)
Try Linux Beginner Search Engine for answers to Linux questions.
 

Re: USB stick automounts but cannot change Read Write permissions
« Reply #2 on: January 21, 2015, 04:57:26 PM »
 

javier_mina

  • New to Forums
  • *
  • 17
    Posts
  • Reputation: 2
  • Linux Lite Member
 Thanks very much for your response.  There is no protection at play and it happens with most of my USB sticks.  Here is the output:

[email protected]:~$ ls -l /media
total 8
drwxr-xr-x 2 root  root  4096 Jun 21  2013 cdrom
drwx------ 3 steve steve 4096 Dec 31  1969 New Volume
[email protected]:~$ ls -l /media/steve
ls: cannot access /media/steve: No such file or directory
[email protected]:~$
 
The other puzzling aspect is that I can write and delete files; however, after delete, they " disappear" on the file listing using Thunar, but still occupy space on the stick and show as number of files under properties.  That's why I tried reformatting as FAT using the Disk Utility.

Hopefully you can help.

 

Re: USB stick automounts but cannot change Read Write permissions
« Reply #3 on: January 21, 2015, 07:50:53 PM »
 

gold_finger

  • Documentation Writer
  • Platinum Level Poster
  • *****
  • 1094
    Posts
  • Country: us
  • Reputation: 325
  • Linux Lite Member

  • Linux Lite: 3.2 64bit

  • CPU: Intel Core2 Duo E7500 3.0GHz

  • MEMORY: 4Gb

  • VIDEO CARD: Intel 4 Series Integrated Graphics
I'm still unclear what the problem is.  What exactly is it that you are trying to do with regards to permissions?  Give general example please.

A FAT formatted USB will not accept setting permissions like an Ext4 (Ext3, Ext2) formatted volume.  All users should be able to read and write to the USB stick by default if it's formatted with FAT32 (FAT16, etc.).

As for files disappearing from view?  It's possible that they are ending up in the Trash folder on the USB stick instead of actually being deleted, which might explain why you say the number of files being reported on disk doesn't change.

Plug USB back in, open file manager and navigate to USB stick.  Type Ctrl+H, or click View -> Show Hidden Files.  Look to see if there is a hidden folder (likely) called ".Trash-1000".  If there is, just go to your Trash bin (probably shown on left side of Thunar) and empty the trash (File -> Empty Trash).  That should get rid of the stuff in ".Trash-1000" on the USB stick as well as other things that ended up in trash from other deletes you've done elsewhere.
Try Linux Beginner Search Engine for answers to Linux questions.
 

Re: USB stick automounts but cannot change Read Write permissions
« Reply #4 on: January 21, 2015, 08:03:38 PM »
 

altman

  • Gold Level Poster
  • *******
  • 740
    Posts
  • Reputation: 43
  • Linux Lite Member
Looks like he s either try to install something from it or have access to some files .
HP DV7 i7 2670QM 500.1GB 8GB Ram Dual-Boot LL2.4 Beta / Extix 15.1.1 64-bit 
Dell Inspiron 1720 CrunchBang 11

Duckduckgo ( for now )
 

Re: USB stick automounts but cannot change Read Write permissions
« Reply #5 on: January 21, 2015, 10:51:46 PM »
 

javier_mina

  • New to Forums
  • *
  • 17
    Posts
  • Reputation: 2
  • Linux Lite Member
My thanks to gold_finger for the easy solution.  I simply wanted to clean up USB sticks and make the space available.  I am embarrassed that I did not think about hidden files on USB sticks.  Anyhow, using Thunar, I was able to CUT the files from trash-1000 and then empty the TRASH to get the empty space I needed.

Muchas gracias
 


Tags:
 


Download Linux Lite 5.2 today - See Release Announcements