You are Here:
Download Linux Lite 5.2 today - See Release Announcements



[ SOLVED ] Supertuxkart 0.8.1-2 dependencies not satisfied in LL3.0 - how to fix?

Author (Read 2942 times)

0 Members and 1 Guest are viewing this topic.

 

m654321

  • Gold Level Poster
  • *******
  • 891
    Posts
  • Country: gb
  • Reputation: 86
  • Linux Lite Member, 'Advocate' & Donator

  • Linux Lite: 4.6 64bit

  • CPU: Intel Pentium T3200@2.0GHz (2cores) on an Asus X71Q

  • MEMORY: 4Gb

  • VIDEO CARD: Intel GM45 Express Chipset

  • Kernel: 4.x
Setup (3) in sig below is too old (outdated graphics card) to run Supertuxkart version 0.9 - this version is found in the LL3.0 repo.  Therefore, the only way to get Supertuxkart working in LL3.0, is to run an earlier version.  Previously, I've run Supertuxkart 0.8.1-2 successfully on setup3, using LL2.8, however it won't install on LL3.0, due to dependency issues.

To install version 0.8.1-2, I have the following packages:
(1) supertuxkart_0.8.1-2_amd64.deb
(2) supertuxkart-data_0.8.1-2_all.deb

I used gdebi to install both packages.
First, I installed package(2) - that went smoothly. When I attempted to install package(1), the installation got stuck, gdebi giving the following alert:
Error: Dependency is not satisfiable: libenet2a (>=1.3.7+ds)

I'd appreciate your help on how to fix this.  I did sudo apt-get install libenet2a in terminal but that didn't work. It would be a shame if I had to revert to LL2.8 in order to get supertuxkart to work...

Many thanks in advance for your help.

Regards
Mike
Last Edit: November 03, 2016, 05:13:13 AM by m654321
64bit OS (32-bit on Samsung netbook) installed in Legacy mode on MBR-formatted SSDs (except pi which uses a micro SDHC card):
2017 - Raspberry pi 3B (4cores) ~ Arm710@1.2GHz - LibreElec, used for upgrading our Samsung TV (excellent for the task)  
2012 - Lenovo G580 2689 (2cores; 4threads] ~ i3-3110M@2.4GHz - LL3.8/Win8.1 dual-boot (LL working smoothly)
2011 - Samsung NP-N145 Plus (1core; 2threads) ~ Intel Atom N455@1.66GHz - LL 3.8 32-bit (64-bit too 'laggy')
2008 - Asus X71Q (2cores) ~ Intel T3200@2.0GHz - LL4.6/Win8.1 dual-boot, LL works fine with kernel 4.15
2007 - Dell Latitude D630 (2cores) ~ Intel T7100@1.8GHz - LL4.6, works well with kernel 4.4; 4.15 doesn't work
 


Re: Supertuxkart 0.8.1-2 dependencies not satisfied in LL3.0 - how to fix?
« Reply #1 on: November 03, 2016, 05:12:34 AM »
 

m654321

  • Gold Level Poster
  • *******
  • 891
    Posts
  • Country: gb
  • Reputation: 86
  • Linux Lite Member, 'Advocate' & Donator

  • Linux Lite: 4.6 64bit

  • CPU: Intel Pentium T3200@2.0GHz (2cores) on an Asus X71Q

  • MEMORY: 4Gb

  • VIDEO CARD: Intel GM45 Express Chipset

  • Kernel: 4.x
Solved: for anyone interested go to the following link to download the dependency 'libenet2a' to make Supertuxkart 0.8.1-2 work in the LL3 series:
https://pkgs.org/ubuntu-14.04/ubuntu-universe-amd64/libenet2a_1.3.11+ds-1_amd64.deb.html

At this webpage, scroll down to the subheading Download & click on the icon which is shown next to the text "Download libenet2a_1.3.11+ds-1_amd64.deb for Ubuntu 14.04 LTS from the Ubuntu Universe repository" and then open the downloaded package with gdebi.

Useful for those of us running LL3 series, who are fans of Supertuxkart, but who have PCs with video cards that are too old to run the Supertuxkart version 0.9, which is currently available in the LL3.0 series repository and replaces version 0.8.

Mike
Last Edit: November 03, 2016, 05:21:57 AM by m654321
64bit OS (32-bit on Samsung netbook) installed in Legacy mode on MBR-formatted SSDs (except pi which uses a micro SDHC card):
2017 - Raspberry pi 3B (4cores) ~ Arm710@1.2GHz - LibreElec, used for upgrading our Samsung TV (excellent for the task)  
2012 - Lenovo G580 2689 (2cores; 4threads] ~ i3-3110M@2.4GHz - LL3.8/Win8.1 dual-boot (LL working smoothly)
2011 - Samsung NP-N145 Plus (1core; 2threads) ~ Intel Atom N455@1.66GHz - LL 3.8 32-bit (64-bit too 'laggy')
2008 - Asus X71Q (2cores) ~ Intel T3200@2.0GHz - LL4.6/Win8.1 dual-boot, LL works fine with kernel 4.15
2007 - Dell Latitude D630 (2cores) ~ Intel T7100@1.8GHz - LL4.6, works well with kernel 4.4; 4.15 doesn't work
 


Tags:
 


Download Linux Lite 5.2 today - See Release Announcements