Software - Support > Games Support

Horrible game performance while Steam is running.

(1/2) > >>

Zead:
Hello,

I found out Steam is eating my game's performance, a lot! For example the mentioned Warzone 2100, downloaded from Ubuntu repositories. I don't even run this game from the non-steam library, I'm just starting it normally through whisker menu and Steam is running in the background. I have a low FPS while Steam is running, EVEN IF STEAM STAYS AT LOGIN SCREEN MINIMIZED! If I shutdown Steam completely, FPS is back to normal. What is this? I can run many apps on the desktop and background, web browser playing videos on youtube, which eats a lot of CPU, and yet I get full speed. Only Steam is acting stupid (I even looked in the task manager, there's not any suspicious CPU usage by Steam).

I'm using the free GPU drivers, proprietary drivers ain't available to me. I don't think drivers are the issue though, since only Steam is doing this.

My CPU is Intel Core 2 Duo 1.6GHZ, GPU is ATI Mobility Radeon X2300 256MB, 2GB RAM.

Please note I even tried SwatX, Oibaf and xorg edgers PPAs, no change.
Newest CPU microcode is installed.

Funny is, like I said, it happens when Steam sits on the login screen too, which shouldn't really eat anything.
I have running Skype, FireFox etc in the background, yet no slowdown.

Did anyone experience this with ther free GPU drivers and low-lower end PC/laptop?

Note I already asked for help on the Steam forums, but I was immediately attacked and named troll by the immature Steam community.

Scott:

--- Quote ---Can I delete posts?
--- End quote ---
At the top of the post to the right do you see a "remove" icon? The icon is a red "x", it should be available for all of your personally created posts.

Zead:

--- Quote from: Scott(0) on March 27, 2015, 11:20:09 AM ---
--- Quote ---Can I delete posts?
--- End quote ---
At the top of the post to the right do you see a "remove" icon? The icon is a red "x", it should be available for all of your personally created posts.

--- End quote ---
I don't see anything like that...

I guess no one knows the answer for my issue though...

Drawing4Life:
Assuming this is a steam bug, try updating steam (re-install if that doesn't work).
The reason why I say that is because this post has been inactive for 120 days. Meaning that if this is a bug on Valves part it should have been patched now.
I'm using LinuxLite3 btw, everything fine here. Would upgrading be an issue in-case my solution doesn't work?

nateliv:
Your graphics card should be able to handle that...

Make sure you don't use crazy high anti-aliasing (AA), this makes the graphic card redraw the same screen multiple times to sharpen it's edges smooth. However, too high can be taxing on the graphics card, causing some lag too.






Tutuapp 9apps Showbox

Navigation

[0] Message Index

[#] Next page

Go to full version