Linux Lite Forums

Software - Support => Games Support => Topic started by: Zead on March 26, 2015, 10:02:47 AM

Title: Horrible game performance while Steam is running.
Post by: Zead on March 26, 2015, 10:02:47 AM
Hello,

I found out Steam is eating my game's performance, a lot! For example the mentioned Warzone 2100, downloaded from Ubuntu repositories. I don't even run this game from the non-steam library, I'm just starting it normally through whisker menu and Steam is running in the background. I have a low FPS while Steam is running, EVEN IF STEAM STAYS AT LOGIN SCREEN MINIMIZED! If I shutdown Steam completely, FPS is back to normal. What is this? I can run many apps on the desktop and background, web browser playing videos on youtube, which eats a lot of CPU, and yet I get full speed. Only Steam is acting stupid (I even looked in the task manager, there's not any suspicious CPU usage by Steam).

I'm using the free GPU drivers, proprietary drivers ain't available to me. I don't think drivers are the issue though, since only Steam is doing this.

My CPU is Intel Core 2 Duo 1.6GHZ, GPU is ATI Mobility Radeon X2300 256MB, 2GB RAM.

Please note I even tried SwatX, Oibaf and xorg edgers PPAs, no change.
Newest CPU microcode is installed.

Funny is, like I said, it happens when Steam sits on the login screen too, which shouldn't really eat anything.
I have running Skype, FireFox etc in the background, yet no slowdown.

Did anyone experience this with ther free GPU drivers and low-lower end PC/laptop?

Note I already asked for help on the Steam forums, but I was immediately attacked and named troll by the immature Steam community.
Title: Re: Horrible game performance while Steam is running.
Post by: Scott on March 27, 2015, 11:20:09 AM
Quote
Can I delete posts?
At the top of the post to the right do you see a "remove" icon? The icon is a red "x", it should be available for all of your personally created posts.
Title: Re: Horrible game performance while Steam is running.
Post by: Zead on March 29, 2015, 04:35:58 PM
Quote
Can I delete posts?
At the top of the post to the right do you see a "remove" icon? The icon is a red "x", it should be available for all of your personally created posts.
I don't see anything like that...

I guess no one knows the answer for my issue though...
Title: Re: Horrible game performance while Steam is running.
Post by: Drawing4Life on July 24, 2016, 08:58:22 AM
Assuming this is a steam bug, try updating steam (re-install if that doesn't work).
The reason why I say that is because this post has been inactive for 120 days. Meaning that if this is a bug on Valves part it should have been patched now.
I'm using LinuxLite3 btw, everything fine here. Would upgrading be an issue in-case my solution doesn't work?
Title: Re: Horrible game performance while Steam is running.
Post by: nateliv on June 14, 2019, 11:37:50 AM
Your graphics card should be able to handle that...

Make sure you don't use crazy high anti-aliasing (AA), this makes the graphic card redraw the same screen multiple times to sharpen it's edges smooth. However, too high can be taxing on the graphics card, causing some lag too.






Tutuapp (https://tutuapp.uno/) 9apps (https://9apps.ooo/) Showbox (https://showbox.kim/)
Title: Re: Horrible game performance while Steam is running.
Post by: TheDead on June 14, 2019, 12:30:30 PM
Thread from 2015-2016... :(https://i.kym-cdn.com/photos/images/newsfeed/000/028/430/raise_thread.jpg)